aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayer
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2010-09-02 19:56:12 +0000
committerRene Ladan <rene@FreeBSD.org>2010-09-02 19:56:12 +0000
commit92f38f55f854e8e4c2577cd688e6a8b166cb6ac1 (patch)
tree3dcab3b494af91ebad41ceb7649907b720520e9d /multimedia/mplayer
parentc45a36f4ac767040718621f07379c1773cbc0a04 (diff)
Notes
Diffstat (limited to 'multimedia/mplayer')
-rw-r--r--multimedia/mplayer/Makefile3
-rw-r--r--multimedia/mplayer/Makefile.options8
-rw-r--r--multimedia/mplayer/Makefile.shared3
3 files changed, 11 insertions, 3 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 4439d2e45db2..677c5ab83e0b 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mplayer
PORTVERSION= ${MPLAYER_PORT_VERSION}
-
+PORTREVISION= 1
COMMENT= High performance media player supporting many formats
.include "${.CURDIR}/Makefile.shared"
@@ -47,6 +47,7 @@ OPTIONS+= LIBMPCDEC "Enable libmpcdec support" off
OPTIONS+= LADSPA "Enable LADSPA plugin support" off
OPTIONS+= SPEEX "Enable speex audio codec support" on
OPTIONS+= THEORA "Enable ogg theora video support" off
+OPTIONS+= VPX "Enable VP8 video via libvpx" off
OPTIONS+= SCHROEDINGER "Dirac codec via libschroedinger" off
.if !defined(PACKAGE_BUILDING)
OPTIONS+= WIN32 "Enable win32 codec set on the IA32 arch" on
diff --git a/multimedia/mplayer/Makefile.options b/multimedia/mplayer/Makefile.options
index 666b96017b06..c47aa0aacb16 100644
--- a/multimedia/mplayer/Makefile.options
+++ b/multimedia/mplayer/Makefile.options
@@ -84,10 +84,16 @@ LIB_DEPENDS+= theora.0:${PORTSDIR}/multimedia/libtheora
CONFIGURE_ARGS+= --disable-theora
.endif
+.if defined(WITH_VPX)
+LIB_DEPENDS+= vpx.0:${PORTSDIR}/multimedia/libvpx
+.else
+CONFIGURE_ARGS+= --disable-libvpx-lavc
+.endif
+
.if defined(WITH_SCHROEDINGER)
LIB_DEPENDS+= schroedinger-1.0.3:${PORTSDIR}/multimedia/schroedinger
.else
-CONFIGURE_ARGS+= --disable-libschroedinger
+CONFIGURE_ARGS+= --disable-libschroedinger-lavc
.endif
.if defined(WITH_LIBMPCDEC)
diff --git a/multimedia/mplayer/Makefile.shared b/multimedia/mplayer/Makefile.shared
index 2b318b2d30b0..f1778461b73d 100644
--- a/multimedia/mplayer/Makefile.shared
+++ b/multimedia/mplayer/Makefile.shared
@@ -24,7 +24,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
TMPDIR="${WRKSRC}"
-CONFIGURE_ARGS= --disable-bitmap-font
+CONFIGURE_ARGS= --disable-bitmap-font \
+ --disable-liba52
WANT_GNOME= yes
WANT_SDL= yes