aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayer
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-08-29 09:55:41 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-08-29 09:55:41 +0000
commitbb6d0ade27f0b37db68fd682f0f54e18db13d834 (patch)
tree975be47e95cd99945aa6b5ec252d356f7dae525d /multimedia/mplayer
parent28eb5029d35a3126eb34739ef51c0266755b8548 (diff)
downloadports-bb6d0ade27f0b37db68fd682f0f54e18db13d834.tar.gz
ports-bb6d0ade27f0b37db68fd682f0f54e18db13d834.zip
Notes
Diffstat (limited to 'multimedia/mplayer')
-rw-r--r--multimedia/mplayer/Makefile3
-rw-r--r--multimedia/mplayer/Makefile.options5
-rw-r--r--multimedia/mplayer/Makefile.shared3
-rw-r--r--multimedia/mplayer/distinfo4
-rw-r--r--multimedia/mplayer/files/patch-CVE-2014-461048
-rw-r--r--multimedia/mplayer/files/patch-configure43
-rw-r--r--multimedia/mplayer/files/patch-ffmpeg-Makefile8
-rw-r--r--multimedia/mplayer/files/patch-libavcodec-libgsmdec.c (renamed from multimedia/mplayer/files/patch-libavcodec-libgsm.c)4
-rw-r--r--multimedia/mplayer/files/patch-libavcodec-libgsmenc.c14
-rw-r--r--multimedia/mplayer/files/patch-vidix-mga_vid.c8
10 files changed, 61 insertions, 79 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index f5f6928408da..f6e8ebab7c67 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -3,7 +3,6 @@
PORTNAME= mplayer
PORTVERSION= ${MPLAYER_PORT_VERSION}
-PORTREVISION= 6
COMMENT= High performance media player supporting many formats
@@ -20,7 +19,7 @@ OPTIONS_DEFINE= AALIB AMR_NB AMR_WB BLURAY CACA DEBUG DV \
OPTIONS_RADIO= RGCD
OPTIONS_RADIO_RGCD= CDIO CDPARANOIA
-OPTIONS_DEFAULT=FRIBIDI GUI IPV6 OCFLAGS OPENGL RTCPU SKINS \
+OPTIONS_DEFAULT=FRIBIDI IPV6 OCFLAGS OPENGL RTCPU SKINS \
WIN32 X11 X11DGA X11VM XINERAMA XVIDEO
BLURAY_DESC?= BluRay support
diff --git a/multimedia/mplayer/Makefile.options b/multimedia/mplayer/Makefile.options
index fa111c12ee28..c927b9f5a151 100644
--- a/multimedia/mplayer/Makefile.options
+++ b/multimedia/mplayer/Makefile.options
@@ -159,7 +159,12 @@ CFLAGS+= -O -fomit-frame-pointer
.if ${PORT_OPTIONS:MPROFILE}
CONFIGURE_ARGS+= --enable-profile
LDFLAGS+= -pg
+.if ${OSVERSION} >= 1100000
+#Workaround a temporary bug in 11-CURRENT where
+#using -pie does not work with -pthread
+CONFIGURE_ARGS+= --disable-relocatable
.endif
+.endif #PROFILE
# Edge case: binary codecs on i386, mostly superseded by internal ffmpeg
# ======================================================================
diff --git a/multimedia/mplayer/Makefile.shared b/multimedia/mplayer/Makefile.shared
index bf0caeebf29c..d9e0c30b42e3 100644
--- a/multimedia/mplayer/Makefile.shared
+++ b/multimedia/mplayer/Makefile.shared
@@ -4,7 +4,7 @@
#
# $FreeBSD$
-MPLAYER_SNAPSHOT_DATE= 2014-04-18
+MPLAYER_SNAPSHOT_DATE= 2014-08-24
MPLAYER_PORT_VERSION= 1.1.r${MPLAYER_SNAPSHOT_DATE:S/-//g}
CATEGORIES?= multimedia audio
MASTER_SITES= ${MASTER_SITE_LOCAL}
@@ -46,7 +46,6 @@ CONFIGURE_ARGS= --cc="${CC}" \
--disable-live \
--disable-joystick \
--disable-mad \
- --disable-mp3lib \
--disable-libmpeg2 \
--disable-nemesi \
--disable-speex \
diff --git a/multimedia/mplayer/distinfo b/multimedia/mplayer/distinfo
index ce6e7137324b..3cbbbe6014e3 100644
--- a/multimedia/mplayer/distinfo
+++ b/multimedia/mplayer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mplayer-1.1.20140418.tar.xz) = 8ac4bc58897e4f7d007040eae569cb2bf19f544fe772bb51127d801154350a7e
-SIZE (mplayer-1.1.20140418.tar.xz) = 11105012
+SHA256 (mplayer-1.1.20140824.tar.xz) = ea11e84bb3ea21904fccc2b661aee997e87d16c2d56659c1a439328c2d1d0745
+SIZE (mplayer-1.1.20140824.tar.xz) = 11397312
diff --git a/multimedia/mplayer/files/patch-CVE-2014-4610 b/multimedia/mplayer/files/patch-CVE-2014-4610
deleted file mode 100644
index 83802fc3e648..000000000000
--- a/multimedia/mplayer/files/patch-CVE-2014-4610
+++ /dev/null
@@ -1,48 +0,0 @@
---- ffmpeg/libavutil/lzo.c.orig 2013-05-25 19:20:04.000000000 +0200
-+++ ffmpeg/libavutil/lzo.c 2014-06-28 12:23:13.517164344 +0200
-@@ -65,8 +65,13 @@
- {
- int cnt = x & mask;
- if (!cnt) {
-- while (!(x = get_byte(c)))
-+ while (!(x = get_byte(c))) {
-+ if (cnt >= INT_MAX - 1000) {
-+ c->error |= AV_LZO_ERROR;
-+ break;
-+ }
- cnt += 255;
-+ }
- cnt += mask + x;
- }
- return cnt;
-@@ -80,6 +85,10 @@
- {
- register const uint8_t *src = c->in;
- register uint8_t *dst = c->out;
-+ if (cnt < 0) {
-+ c->error |= AV_LZO_ERROR;
-+ return;
-+ }
- if (cnt > c->in_end - src) {
- cnt = FFMAX(c->in_end - src, 0);
- c->error |= AV_LZO_INPUT_DEPLETED;
-@@ -103,7 +112,7 @@
- /**
- * @brief Copies previously decoded bytes to current position.
- * @param back how many bytes back we start, must be > 0
-- * @param cnt number of bytes to copy, must be >= 0
-+ * @param cnt number of bytes to copy, must be > 0
- *
- * cnt > back is valid, this will copy the bytes we just copied,
- * thus creating a repeating pattern with a period length of back.
-@@ -111,6 +120,10 @@
- static inline void copy_backptr(LZOContext *c, int back, int cnt)
- {
- register uint8_t *dst = c->out;
-+ if (cnt <= 0) {
-+ c->error |= AV_LZO_ERROR;
-+ return;
-+ }
- if (dst - c->out_start < back) {
- c->error |= AV_LZO_INVALID_BACKPTR;
- return;
diff --git a/multimedia/mplayer/files/patch-configure b/multimedia/mplayer/files/patch-configure
index 372c9568589f..8f29caa87b0d 100644
--- a/multimedia/mplayer/files/patch-configure
+++ b/multimedia/mplayer/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2014-04-15 15:12:18.000000000 +0200
-+++ configure 2014-04-21 18:34:48.440563168 +0200
-@@ -645,7 +645,7 @@
+--- configure.orig 2014-08-05 13:12:59.000000000 +0200
++++ configure 2014-08-15 17:48:16.698117164 +0200
+@@ -649,7 +649,7 @@
_iwmmxt=auto
_mtrr=auto
_altivec=auto
@@ -9,7 +9,7 @@
_ranlib=ranlib
_windres=windres
_cc=cc
-@@ -995,7 +995,7 @@
+@@ -999,7 +999,7 @@
ld_static=''
;;
--enable-profile)
@@ -18,7 +18,7 @@
;;
--disable-profile)
_profile=
-@@ -1466,7 +1466,6 @@
+@@ -1474,7 +1474,6 @@
*)
echo "Unknown parameter: $ac_option"
@@ -26,7 +26,7 @@
;;
esac
-@@ -1719,7 +1718,7 @@
+@@ -1727,7 +1726,7 @@
case "$1" in
x86_64|amd64|i[3-9]86*|i86pc|x86|x86pc|k5|k6|k6_2|k6_3|k6-2|k6-3|pentium*|athlon*|i586_i686|i586-i686) host_arch=i386 ;;
ia64) host_arch=ia64 ;;
@@ -35,7 +35,20 @@
alpha) host_arch=alpha ;;
sun4*|sparc*) host_arch=sparc ;;
parisc*|hppa*|9000*) host_arch=hppa ;;
-@@ -3868,7 +3867,7 @@
+@@ -1843,7 +1842,11 @@
+ cflag_check "" || die "Compiler is not functioning correctly. Check your installation and custom CFLAGS $CFLAGS ."
+ echo "yes"
+
+-cflag_check "-lm" && libm="-lm"
++if test -z "$_profile" ; then
++ cflag_check "-lm" && libm="-lm"
++else
++ cflag_check "-lm_p" && libm="-lm_p"
++fi
+
+ if test -z "$_target" ; then
+ cat > $TMPC << EOF
+@@ -3882,7 +3885,7 @@
if linux ; then
THREAD_CFLAGS=-D_REENTRANT
elif freebsd || netbsd || openbsd || bsdos ; then
@@ -44,7 +57,7 @@
fi
if test "$_pthreads" = auto ; then
cat > $TMPC << EOF
-@@ -3878,7 +3877,7 @@
+@@ -3892,7 +3895,7 @@
EOF
_pthreads=no
if ! hpux ; then
@@ -53,7 +66,7 @@
# for crosscompilation, we cannot execute the program, be happy if we can link statically
cc_check $THREAD_CFLAGS $ld_tmp && (tmp_run || test "$ld_static") && ld_pthread="$ld_tmp" && _pthreads=yes && break
done
-@@ -4030,7 +4029,7 @@
+@@ -4044,7 +4047,7 @@
# NOTE: -L/usr/lib is a hack to avoid issues due to a
# broken libiconv that e.g. macports installs into /opt/local/lib
# which might get addded to the search path later by e.g. SDL
@@ -62,7 +75,7 @@
cc_check $ld_tmp && extra_ldflags="$extra_ldflags $ld_tmp" &&
ld_iconv="$ld_tmp" && _iconv=yes && break
done
-@@ -5974,7 +5973,7 @@
+@@ -5996,7 +5999,7 @@
elif dragonfly ; then
default_cdrom_device="/dev/cd0"
elif freebsd ; then
@@ -71,7 +84,7 @@
elif openbsd ; then
default_cdrom_device="/dev/rcd0c"
elif sunos ; then
-@@ -5987,7 +5986,7 @@
+@@ -6009,7 +6012,7 @@
default_cdrom_device="/dev/cdrom"
fi
@@ -80,7 +93,7 @@
default_dvd_device=$default_cdrom_device
elif darwin ; then
default_dvd_device="/dev/rdiskN"
-@@ -6586,7 +6585,7 @@
+@@ -6608,7 +6611,7 @@
echocheck "libgsm"
if test "$_libgsm" = auto ; then
_libgsm=no
@@ -89,7 +102,7 @@
fi
if test "$_libgsm" = yes ; then
def_libgsm='#define CONFIG_LIBGSM 1'
-@@ -7071,6 +7070,16 @@
+@@ -7093,6 +7096,16 @@
nolibrtmp=no
def_librtmp='#define CONFIG_LIBRTMP 1'
inputmodules="librtmp $inputmodules"
@@ -106,7 +119,7 @@
else
nolibrtmp=yes
_librtmp=no
-@@ -7470,7 +7479,7 @@
+@@ -7492,7 +7505,7 @@
echocheck "mencoder"
if test "$_mencoder" = no ; then
# mpeg1video for vf_lavc, snow for vf_uspp / vf_mcdeint,
@@ -115,7 +128,7 @@
fi
echores "$_mencoder"
-@@ -8399,7 +8408,7 @@
+@@ -8421,7 +8434,7 @@
EXESUF = $_exesuf
EXESUFS_ALL = .exe
diff --git a/multimedia/mplayer/files/patch-ffmpeg-Makefile b/multimedia/mplayer/files/patch-ffmpeg-Makefile
index 0f5b49f2c258..04df63bb0efa 100644
--- a/multimedia/mplayer/files/patch-ffmpeg-Makefile
+++ b/multimedia/mplayer/files/patch-ffmpeg-Makefile
@@ -1,11 +1,11 @@
---- ffmpeg/Makefile.orig 2012-06-29 19:20:03.000000000 +0200
-+++ ffmpeg/Makefile 2012-07-21 18:47:01.068697043 +0200
-@@ -82,7 +82,7 @@
+--- ffmpeg/Makefile.orig 2014-07-22 19:20:06.000000000 +0200
++++ ffmpeg/Makefile 2014-08-11 20:49:48.038911362 +0200
+@@ -91,7 +91,7 @@
$(foreach V,$(SUBDIR_VARS),$(eval $(call RESET,$(V))))
SUBDIR := $(1)/
include $(SRC_PATH)/$(1)/Makefile
--include $(SRC_PATH)/$(1)/$(ARCH)/Makefile
+-include $(SRC_PATH)/$(1)/$(MPLAYER_ARCH)/Makefile
+ -include $(SRC_PATH)/$(1)/$(INTRINSICS)/Makefile
include $(SRC_PATH)/library.mak
endef
-
diff --git a/multimedia/mplayer/files/patch-libavcodec-libgsm.c b/multimedia/mplayer/files/patch-libavcodec-libgsmdec.c
index 12f81952b39b..f0b78f6d2bea 100644
--- a/multimedia/mplayer/files/patch-libavcodec-libgsm.c
+++ b/multimedia/mplayer/files/patch-libavcodec-libgsmdec.c
@@ -1,5 +1,5 @@
---- ffmpeg/libavcodec/libgsm.c.orig 2013-03-07 19:20:04.000000000 +0100
-+++ ffmpeg/libavcodec/libgsm.c 2013-03-22 16:31:14.983780842 +0100
+--- ffmpeg/libavcodec/libgsmdec.c.orig 2014-07-21 19:20:03.000000000 +0200
++++ ffmpeg/libavcodec/libgsmdec.c 2014-08-15 11:02:55.987422815 +0200
@@ -28,11 +28,7 @@
// The idiosyncrasies of GSM-in-WAV are explained at http://kbs.cs.tu-berlin.de/~jutta/toast.html
diff --git a/multimedia/mplayer/files/patch-libavcodec-libgsmenc.c b/multimedia/mplayer/files/patch-libavcodec-libgsmenc.c
new file mode 100644
index 000000000000..1e331ad4c5cd
--- /dev/null
+++ b/multimedia/mplayer/files/patch-libavcodec-libgsmenc.c
@@ -0,0 +1,14 @@
+--- ffmpeg/libavcodec/libgsmenc.c.orig 2014-08-15 11:02:02.619426519 +0200
++++ ffmpeg/libavcodec/libgsmenc.c 2014-08-15 11:02:28.587424476 +0200
+@@ -28,11 +28,7 @@
+ // The idiosyncrasies of GSM-in-WAV are explained at http://kbs.cs.tu-berlin.de/~jutta/toast.html
+
+ #include "config.h"
+-#if HAVE_GSM_H
+ #include <gsm.h>
+-#else
+-#include <gsm/gsm.h>
+-#endif
+
+ #include "libavutil/common.h"
+
diff --git a/multimedia/mplayer/files/patch-vidix-mga_vid.c b/multimedia/mplayer/files/patch-vidix-mga_vid.c
index d94ced8935e8..d4bf4588fe6c 100644
--- a/multimedia/mplayer/files/patch-vidix-mga_vid.c
+++ b/multimedia/mplayer/files/patch-vidix-mga_vid.c
@@ -1,5 +1,5 @@
---- vidix/mga_vid.c.orig 2009-05-12 21:58:57.000000000 -0500
-+++ vidix/mga_vid.c 2009-07-23 20:41:50.683011307 -0500
+--- vidix/mga_vid.c.orig 2014-05-17 03:38:00.000000000 +0200
++++ vidix/mga_vid.c 2014-08-11 20:58:07.109876980 +0200
@@ -1110,13 +1110,10 @@
i, lst[i].vendor, lst[i].device);
if (lst[i].vendor == VENDOR_MATROX)
@@ -7,9 +7,9 @@
-#if 0
if ((lst[i].command & PCI_COMMAND_IO) == 0)
{
-- printf("[mga] Device is disabled, ignoring\n");
+- mp_msg(MSGT_VO, MSGL_STATUS, "[mga] Device is disabled, ignoring\n");
- continue;
-+ printf("[mga] Device is disabled, trying anyways.\n");
++ mp_msg(MSGT_VO, MSGL_STATUS, "[mga] Device seems disabled, trying anyway\n");
}
-#endif
switch(lst[i].device)