aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayer
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-05-17 03:19:02 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-05-17 03:19:02 +0000
commit847da8f9ae8ed70c30c1094ed878f7d1316dceaf (patch)
tree2b87c985716c2abcc9b81ca53b9586c6e0bff3ab /multimedia/mplayer
parent158f9c87d6c3cb1ceeefc366b6858f52e72e5210 (diff)
downloadports-847da8f9ae8ed70c30c1094ed878f7d1316dceaf.tar.gz
ports-847da8f9ae8ed70c30c1094ed878f7d1316dceaf.zip
Notes
Diffstat (limited to 'multimedia/mplayer')
-rw-r--r--multimedia/mplayer/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 197b33825038..5b2728e6dac6 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -97,6 +97,9 @@
# WITH_ARTS
# default: autodetect
#
+# WITH_CDPARANOIA
+# default: autodetect
+#
# WITH_LIBDV
# default: autodetect
#
@@ -218,6 +221,10 @@ TOOLFILES= calcbpp.pl countquant.pl \
WITH_ARTS= yes
.endif
+.if exists(${LOCALBASE}/lib/libcdda_paranoia.so)
+WITH_CDPARANOIA= yes
+.endif
+
.if exists(${LOCALBASE}/lib/libdv.so.3)
WITH_LIBDV= yes
.endif
@@ -321,6 +328,12 @@ CONFIGURE_ARGS+= --enable-arts
CONFIGURE_ARGS+= --disable-arts
.endif
+.if defined(WITH_CDPARANOIA)
+LIB_DEPENDS+= cdda_paranoia.0:${PORTSDIR}/audio/cdparanoia
+.else
+CONFIGURE_ARGS+= --disable-cdparanoia
+.endif
+
.if defined(WITH_DVD)
.if !defined(WITH_LIBDVDREAD)
LIB_DEPENDS+= dvdcss.2:${PORTSDIR}/multimedia/libdvdcss