aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayer
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-04-25 08:29:23 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-04-25 08:29:23 +0000
commitf155fbed294a190874c4a27f472726b9c56dabab (patch)
treededb8d84a99fb5dbb50f712debe5aa371e8e83ae /multimedia/mplayer
parente52e1bb2f8c028d38a5f4e1c32c38819fe0f0c57 (diff)
Notes
Diffstat (limited to 'multimedia/mplayer')
-rw-r--r--multimedia/mplayer/Makefile3
-rw-r--r--multimedia/mplayer/Makefile.options8
2 files changed, 3 insertions, 8 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 6424943baed1..d13855cf26aa 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mplayer
PORTVERSION= ${MPLAYER_PORT_VERSION}
+PORTREVISION= 1
COMMENT= High performance media player supporting many formats
@@ -42,7 +43,6 @@ OPTIONS+= SVGALIB "Enable svgalib support" off
OPTIONS+= LIBDV "Enable libdv support" off
OPTIONS+= MAD "Enable mad MPEG audio engine support" off
OPTIONS+= AMR "Enable opencore AMR audio codec support" off
-OPTIONS+= DTS "Enable DTS audio codec support" on
OPTIONS+= LIBMPCDEC "Enable libmpcdec support" off
OPTIONS+= LADSPA "Enable LADSPA plugin support" off
OPTIONS+= SPEEX "Enable speex audio codec support" on
@@ -74,6 +74,7 @@ CONFFILES= example.conf input.conf menu.conf dvb-menu.conf
CONFIGURE_ARGS+= --disable-ssse3 \
--disable-directfb \
--disable-faac \
+ --disable-libdca \
--disable-twolame \
--disable-x264 \
--disable-xvid \
diff --git a/multimedia/mplayer/Makefile.options b/multimedia/mplayer/Makefile.options
index 160c87bc0421..43565c2c7563 100644
--- a/multimedia/mplayer/Makefile.options
+++ b/multimedia/mplayer/Makefile.options
@@ -96,12 +96,6 @@ LIB_DEPENDS+= mpcdec.5:${PORTSDIR}/audio/libmpcdec
CONFIGURE_ARGS+= --disable-musepack
.endif
-.if !defined(WITHOUT_DTS)
-LIB_DEPENDS+= dca.0:${PORTSDIR}/multimedia/libdca
-.else
-CONFIGURE_ARGS+= --disable-libdca
-.endif
-
.if !defined(WITHOUT_SPEEX)
LIB_DEPENDS+= speex.1:${PORTSDIR}/audio/speex
.else
@@ -160,7 +154,7 @@ CONFIGURE_ARGS+= --disable-cdparanoia
.endif
.if defined(WITH_LIBCDIO) && !defined(WITH_CDPARANOIA)
-BUILD_DEPENDS+= ${LOCALBASE}/include/cdio/cdio.h:${PORTSDIR}/sysutils/libcdio
+LIB_DEPENDS+= cdio.12:${PORTSDIR}/sysutils/libcdio
.else
CONFIGURE_ARGS+= --disable-libcdio
.endif