aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayer
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-05-15 02:43:08 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-05-15 02:43:08 +0000
commit6292fb972b37bdaa7fc115cde2f4f8df8b304b2c (patch)
treec0b03a64d71da3c39a50585637591f0f7439cb18 /multimedia/mplayer
parent6a33d3ed9984c1e0746497967caad955e7964aa1 (diff)
downloadports-6292fb972b37bdaa7fc115cde2f4f8df8b304b2c.tar.gz
ports-6292fb972b37bdaa7fc115cde2f4f8df8b304b2c.zip
Notes
Diffstat (limited to 'multimedia/mplayer')
-rw-r--r--multimedia/mplayer/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index f22fbf382ce3..c922a01c679c 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -134,6 +134,9 @@
# WITH_FAAD
# default: autodetect
#
+# WITH_LZO
+# default: autodetect
+#
# WITHOUT_WIN32_CODECS
# default: undefined
# By default, mplayer depends on and uses the win32-codecs collection.
@@ -277,6 +280,10 @@ WITH_XVID= yes
WITH_FAAD= yes
.endif
+.if exists(${LOCALBASE}/lib/liblzo.so)
+WITH_LZO= yes
+.endif
+
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
.endif
@@ -397,6 +404,12 @@ CONFIGURE_ARGS+= --enable-xvid \
LIB_DEPENDS+= xvidcore.0:${PORTSDIR}/multimedia/xvid
.endif
+.if defined(WITH_LZO)
+LIB_DEPENDS+= lzo.1:${PORTSDIR}/archivers/lzo
+.else
+CONFIGURE_ARGS+= --disable-liblzo
+.endif
+
.if defined(WITH_FAAD)
CONFIGURE_ARGS+= --enable-faad
LIB_DEPENDS+= faad.0:${PORTSDIR}/audio/faad