aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayer
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-11-08 09:16:50 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-11-08 09:16:50 +0000
commitca9fe663d47d354499309559d085dbfee0ee1fd5 (patch)
tree7bfab2f4a79c643600b74d4f86262b8b6fae06b0 /multimedia/mplayer
parent176ac189c6c48b7f0fd2f4a3c37958b13ff0039b (diff)
Notes
Diffstat (limited to 'multimedia/mplayer')
-rw-r--r--multimedia/mplayer/Makefile30
1 files changed, 27 insertions, 3 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 132968a8be70..984468ed65fc 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -27,6 +27,12 @@
# If you define this, there are several additional knobs to explicitly
# disable some possible CPU features. See below.
#
+# WITH_NVIDIA
+# default: disabled
+# Enable nvidia XVMC support for nvidia video cards
+# Note: This is highly experimental at the moment and works only for
+# MPEG1/2 using -vo xvmc -vc ffmpeg12mc
+#
# WITHOUT_MENCODER
# default: undefined
# the default is to build mplayer with mencoder. If you're sure that you
@@ -50,6 +56,12 @@
# If you want to force mplayer to disable the graphical user interface and
# build without gui ability, define this.
#
+# WITHOUT_SKINS
+# default: undefined
+# removes the run dependency on the mplayer-skins port, _even if_ built with
+# GUI. This is useful e.g. if you don't want the skins installed system-wide.
+# Please note that 'gmplayer' *must* have at least one default skin to run.
+#
# WITHOUT_FREETYPE
# default: undefined
# since freetype is installed on almost any system people might want
@@ -231,7 +243,7 @@
PORTNAME= mplayer
PORTVERSION= 0.99.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= multimedia audio ipv6
MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/ \
http://www2.mplayerhq.hu/MPlayer/releases/ \
@@ -306,6 +318,10 @@ PLIST_SUB+= VIDIX="@comment "
#WITH_RTC= yes
#.endif
+#.if exists(${X11BASE}/lib/libXvMCNVIDIA.so.1)
+#WITH_NVIDIA= yes
+#.endif
+
.if exists(${LOCALBASE}/lib/libfribidi.so.0)
WITH_FRIBIDI= yes
.endif
@@ -409,7 +425,9 @@ WITH_GTK1= yes
.if !defined(WITHOUT_GUI)
PLIST_SUB+= GMPLAYER=""
+.if !defined(WITHOUT_SKINS)
RUN_DEPENDS+= ${LOCALBASE}/share/mplayer/Skin:${PORTSDIR}/multimedia/mplayer-skins
+.endif
.else
PLIST_SUB+= GMPLAYER="@comment "
.endif
@@ -463,7 +481,13 @@ CONFIGURE_ARGS+= --disable-mencoder
PLIST_SUB+= MENCODER="@comment "
.endif
-.if defined(WITH_ARTS) && !defined(WITHOUT_ARTS) && defined(WITHOUT_GUI)
+.if defined(WITH_NVIDIA)
+LIB_DEPENDS+= XvMCNVIDIA.1:${PORTSDIR}/x11/nvidia-driver
+CONFIGURE_ARGS+= --enable-xvmc \
+ --enable-xvmclib=XvMCNVIDIA
+.endif
+
+.if defined(WITH_ARTS) && !defined(WITHOUT_ARTS) && !defined(WITH_GTK1)
LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
CONFIGURE_ARGS+= --enable-arts
@@ -516,7 +540,7 @@ CONFIGURE_ARGS+= --disable-mad
.if defined(WITH_MATROSKA)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libmatroska.a:${PORTSDIR}/multimedia/libmatroska
-CONFIGURE_ARGS+= --enable-external-matroska
+CONFIGURE_ARGS+= --enable-external-matroska=${LOCALBASE}/lib
.else
CONFIGURE_ARGS+= --disable-external-matroska
.endif