aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayer
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-05-03 00:13:16 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-05-03 00:13:16 +0000
commit0260448577c5426192c72649674f413bdcc6c1f1 (patch)
treea1f0b83284a1881901747927684c78d465b0f9d0 /multimedia/mplayer
parenta573ab46c5e08d4c742437ba19c025dd93d6382e (diff)
downloadports-0260448577c5426192c72649674f413bdcc6c1f1.tar.gz
ports-0260448577c5426192c72649674f413bdcc6c1f1.zip
Notes
Diffstat (limited to 'multimedia/mplayer')
-rw-r--r--multimedia/mplayer/Makefile1
-rw-r--r--multimedia/mplayer/files/patch-libavcodec-mpegaudio_parser.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 2d3efefa45f5..f95b98972c23 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mplayer
PORTVERSION= ${MPLAYER_PORT_VERSION}
+PORTREVISION= 1
COMMENT= High performance media player supporting many formats
diff --git a/multimedia/mplayer/files/patch-libavcodec-mpegaudio_parser.c b/multimedia/mplayer/files/patch-libavcodec-mpegaudio_parser.c
new file mode 100644
index 000000000000..847155cdd360
--- /dev/null
+++ b/multimedia/mplayer/files/patch-libavcodec-mpegaudio_parser.c
@@ -0,0 +1,11 @@
+--- ffmpeg/libavcodec/mpegaudio_parser.c.orig 2012-03-04 19:20:05.000000000 +0100
++++ ffmpeg/libavcodec/mpegaudio_parser.c 2012-05-01 14:57:54.645626270 +0200
+@@ -78,7 +78,7 @@
+ if (s->header_count > 1) {
+ avctx->sample_rate= sr;
+ avctx->channels = channels;
+- s1->duration = frame_size;
++ avctx->frame_size = frame_size;
+ avctx->bit_rate = bit_rate;
+ }
+ break;