aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayer
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-01 08:27:47 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-01 08:27:47 +0000
commit001fdf62d582debff6e107f47c2cea03bdc35053 (patch)
tree8bd2cc98d670fe8e819eb5d7fc098b9ffcca6e8e /multimedia/mplayer
parent7ce5950bb992d847a67965898e67226f8667bffe (diff)
downloadports-001fdf62d582debff6e107f47c2cea03bdc35053.tar.gz
ports-001fdf62d582debff6e107f47c2cea03bdc35053.zip
Notes
Diffstat (limited to 'multimedia/mplayer')
-rw-r--r--multimedia/mplayer/Makefile4
-rw-r--r--multimedia/mplayer/files/patch-ad25
2 files changed, 23 insertions, 6 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 6a653daa148d..b57012294e6b 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -642,11 +642,9 @@ post-patch:
@${REINPLACE_CMD} -e \
's|libxmms.so.1|libxmms.so|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
- @${REINPLACE_CMD} -Ee 's#-pthread|-lc_r#${PTHREAD_LIBS}#g' \
- ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/dev/dvd|${DEFAULT_DVD_DEVICE}|; \
s|/dev/cdrom|${DEFAULT_CDROM_DEVICE}|' \
- ${WRKSRC}/configure
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
.if defined(WITH_RTC)
@${REINPLACE_CMD} -e \
's|<linux/rtc.h>|<rtc.h>|' \
diff --git a/multimedia/mplayer/files/patch-ad b/multimedia/mplayer/files/patch-ad
index f7e930c1dab2..d16072f7d5ba 100644
--- a/multimedia/mplayer/files/patch-ad
+++ b/multimedia/mplayer/files/patch-ad
@@ -1,5 +1,5 @@
---- configure.orig Mon Apr 26 11:44:06 2004
-+++ configure Wed Apr 28 16:09:47 2004
+--- configure.orig Mon Apr 26 05:44:06 2004
++++ configure Sun Jun 27 03:30:21 2004
@@ -339,7 +339,7 @@
@@ -123,7 +123,26 @@
int main(void) { return RTC_IRQP_READ; }
EOF
_rtc=no
-@@ -5772,7 +5722,7 @@
+@@ -5736,7 +5686,7 @@
+ _stripbinaries=no
+ elif test -z "$CFLAGS" ; then
+ if test "$host_arch" != "mips" ; then
+- CFLAGS="-O4 $_march $_mcpu -pipe -ffast-math -fomit-frame-pointer"
++ CFLAGS="-O"
+ else
+ CFLAGS="-O4 $_march $_mcpu -ffast-math -fomit-frame-pointer"
+ fi
+@@ -5746,6 +5696,9 @@
+ _stripbinaries=no
+ fi
+ else
++ if test "$_runtime_cpudetection" = no ; then
++ CFLAGS="$CFLAGS $_march $_mcpu"
++ fi
+ cat <<EOF
+
+ MPlayer compilation will use the CFLAGS set by you, but:
+@@ -5772,7 +5725,7 @@
CFLAGS="$CFLAGS -D_REENTRANT"
elif bsd ; then
# FIXME bsd needs this so maybe other OS'es