aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayerxp/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-03-08 01:01:31 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-03-08 01:01:31 +0000
commit672c044e2eee3598f19a0f5e618e0c2fe8aea68d (patch)
tree771bbdda8fc0a17d5351cfa925732955ccc44706 /multimedia/mplayerxp/Makefile
parent86240c80e62c10278c8b2c49d61a2198db15e6ed (diff)
downloadports-672c044e2eee3598f19a0f5e618e0c2fe8aea68d.tar.gz
ports-672c044e2eee3598f19a0f5e618e0c2fe8aea68d.zip
Notes
Diffstat (limited to 'multimedia/mplayerxp/Makefile')
-rw-r--r--multimedia/mplayerxp/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/multimedia/mplayerxp/Makefile b/multimedia/mplayerxp/Makefile
index 84a83d707acb..82ecb31f51b4 100644
--- a/multimedia/mplayerxp/Makefile
+++ b/multimedia/mplayerxp/Makefile
@@ -29,10 +29,10 @@ USE_GMAKE= yes
USE_REINPLACE= yes
USE_SIZE= yes
HAS_CONFIGURE= yes
+WANT_SDL= yes
MAN1= mplayerxp.1
-SDL_CONFIG?= "${LOCALBASE}/bin/sdl11-config"
WIN32_CODEC_PREFIX= ${LOCALBASE}/lib/win32
# dirs to create before installation
@@ -80,11 +80,11 @@ WITH_CDPARANOIA=yes
WITH_DVD=yes
.endif
# sdl
-.if exists(${LOCALBASE}/lib/libSDL-1.1.a)
+.if ${HAVE_SDL:Msdl}!=""
WITH_SDL=yes
.endif
# sdl_image
-.if exists(${LOCALBASE}/lib/libSDL_image.a)
+.if ${HAVE_SDL:Mimage}!=""
WITH_SDL_IMAGE=yes
.endif
# xvid
@@ -139,17 +139,14 @@ CONFIGURE_ARGS+= --with-libdvdnav=${LOCALBASE}
.endif
# sdl
.ifdef(WITH_SDL)
-LIB_DEPENDS+= SDL-1.1.5:${PORTSDIR}/devel/sdl12
-
+USE_SDL= sdl
CONFIGURE_ARGS+= --enable-sdl
-CONFIGURE_ENV+= SDL_CONFIG=${SDL_CONFIG}
.else
CONFIGURE_ARGS+= --disable-sdl
.endif
# sdl_image
.ifdef(WITH_SDL_IMAGE)
-LIB_DEPENDS+= SDL_image.10:${PORTSDIR}/graphics/sdl_image
-
+USE_SDL+= image
CONFIGURE_ARGS+= --enable-sdl-image
.else
CONFIGURE_ARGS+= --disable-sdl-image