aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mplayerxp
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2002-09-19 16:42:33 +0000
committerOliver Braun <obraun@FreeBSD.org>2002-09-19 16:42:33 +0000
commit439d291bdc669abea808fb6caf76189177cfa5de (patch)
tree236d8de9fb9886ab8018eae3ad66ec242d8cb291 /multimedia/mplayerxp
parent97bdda3e788cee043d0fd4644dd847db27ac1f97 (diff)
downloadports-439d291bdc669abea808fb6caf76189177cfa5de.tar.gz
ports-439d291bdc669abea808fb6caf76189177cfa5de.zip
Notes
Diffstat (limited to 'multimedia/mplayerxp')
-rw-r--r--multimedia/mplayerxp/Makefile15
-rw-r--r--multimedia/mplayerxp/distinfo2
-rw-r--r--multimedia/mplayerxp/files/patch-ad47
-rw-r--r--multimedia/mplayerxp/files/patch-ae21
-rw-r--r--multimedia/mplayerxp/files/patch-mplayer:subreader.c14
-rw-r--r--multimedia/mplayerxp/pkg-plist11
6 files changed, 28 insertions, 82 deletions
diff --git a/multimedia/mplayerxp/Makefile b/multimedia/mplayerxp/Makefile
index 2877ffdd2726..bb718ae867b6 100644
--- a/multimedia/mplayerxp/Makefile
+++ b/multimedia/mplayerxp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mplayer
-PORTVERSION= 0.90.0.6
+PORTVERSION= 0.90.0.8
CATEGORIES= graphics
MASTER_SITES= http://ftp.mplayerhq.hu/MPlayer/releases/ \
http://www.mplayerhq.hu/MPlayer/releases/ \
@@ -16,7 +16,7 @@ MASTER_SITES= http://ftp.mplayerhq.hu/MPlayer/releases/ \
ftp://ftp2.mplayerhq.hu/MPlayer/releases/ \
ftp://ftp.lug.udel.edu/MPlayer/releases/ \
http://www.rrr.de/~riggs/mplayer/
-DISTNAME= MPlayer-0.90pre6
+DISTNAME= MPlayer-0.90pre8
MAINTAINER= riggs@rrr.de
@@ -32,7 +32,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS=${PTHREAD_LIBS}
CONFIGURE_ARGS= --with-extralibdir=${LOCALBASE}/lib \
- --with-extraincdir=${LOCALBASE}/include
+ --with-extraincdir=${LOCALBASE}/include \
+ --disable-vidix
USE_GNOMENG= yes
WANT_GNOME= yes
@@ -79,6 +80,9 @@ CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
.if ${HAVE_GNOME:Mgtk12}!=""
WITH_GUI= yes
+PLIST_SUB+= GMPLAYER=""
+.else
+PLIST_SUB+= GMPLAYER="@comment"
.endif
.if defined(WITH_GUI)
@@ -228,7 +232,10 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/DOCS/${doc} ${DOCSDIR}
.endfor
.endif
- @${CAT} pkg-message
+.if defined(WITH_GUI)
+ @${LN} -sf ${PREFIX}/bin/mplayer ${PREFIX}/bin/gmplayer
+.endif
+ @${CAT} ${.CURDIR}/pkg-message
install-user:
@${PERL} ${FILESDIR}/install-user
diff --git a/multimedia/mplayerxp/distinfo b/multimedia/mplayerxp/distinfo
index 10d26e07bc53..e483e3861986 100644
--- a/multimedia/mplayerxp/distinfo
+++ b/multimedia/mplayerxp/distinfo
@@ -1 +1 @@
-MD5 (MPlayer-0.90pre6.tar.bz2) = 819b4db6133291886df34cadcc03e09d
+MD5 (MPlayer-0.90pre8.tar.bz2) = 8c844865b05574a1cfb2813e8487d21b
diff --git a/multimedia/mplayerxp/files/patch-ad b/multimedia/mplayerxp/files/patch-ad
index be62aea43499..5ebd397726a8 100644
--- a/multimedia/mplayerxp/files/patch-ad
+++ b/multimedia/mplayerxp/files/patch-ad
@@ -1,6 +1,6 @@
---- configure.orig Mon Aug 5 19:23:22 2002
-+++ configure Wed Aug 7 12:47:05 2002
-@@ -480,19 +480,10 @@
+--- configure.orig Tue Sep 17 21:47:55 2002
++++ configure Thu Sep 19 12:19:12 2002
+@@ -491,19 +491,10 @@
# Try to find the available options for the current CPU
if x86 || ppc; then
@@ -20,7 +20,7 @@
pname=`$_cpuinfo | grep 'model name' | cut -d ':' -f 2 | head -1`
pvendor=`$_cpuinfo | grep 'vendor_id' | cut -d ':' -f 2 | cut -d ' ' -f 2 | head -1`
-@@ -1246,8 +1237,8 @@
+@@ -1289,8 +1280,8 @@
;;
*)
@@ -31,7 +31,7 @@
;;
esac
-@@ -1588,13 +1579,7 @@
+@@ -1688,13 +1679,7 @@
echocheck "memalign()"
@@ -45,7 +45,7 @@
if test "$_memalign" = yes ; then
_def_memalign='#define HAVE_MEMALIGN 1'
else
-@@ -1671,31 +1656,7 @@
+@@ -1771,31 +1756,7 @@
echocheck "pthread"
@@ -78,43 +78,12 @@
echores "yes (using $_ld_pthread)"
-@@ -3413,11 +3374,7 @@
-
- echocheck "iconv"
- if test "$_iconv" = auto ; then
-- if freebsd ; then
-- _iconv_tmp='#include <giconv.h>'
-- else
-- _iconv_tmp='#include <iconv.h>'
-- fi
-+ _iconv_tmp='#include <iconv.h>'
- cat > $TMPC << EOF
- #include <stdio.h>
- #include <unistd.h>
-@@ -3451,7 +3408,7 @@
- EOF
- _iconv=no
- if freebsd ; then
-- cc_check -lm -lgiconv && _iconv=yes
-+ cc_check -lm -liconv && _iconv=yes
- elif bsdos || openbsd ; then
- cc_check -lm -liconv && _iconv=yes
- else
-@@ -3460,7 +3417,7 @@
- fi
- if test "$_iconv" = yes ; then
- _def_iconv='#define USE_ICONV 1'
-- freebsd && _ld_iconv='-lgiconv'
-+ freebsd && _ld_iconv='-liconv'
- bsdos && _ld_iconv='-liconv'
- openbsd && _ld_iconv='-liconv'
- else
-@@ -3979,7 +3936,7 @@
+@@ -4211,7 +4172,7 @@
CFLAGS="$CFLAGS -D_REENTRANT"
elif bsd ; then
# FIXME bsd needs this so maybe other OS'es
- CFLAGS="$CFLAGS -D_THREAD_SAFE"
+ CFLAGS="$CFLAGS ${PTHREAD_CFLAGS}"
fi
-
# 64 bit file offsets?
+ if test "$_largefiles" = yes || freebsd ; then
diff --git a/multimedia/mplayerxp/files/patch-ae b/multimedia/mplayerxp/files/patch-ae
index ad5ea9731aab..8fa1b930b4c2 100644
--- a/multimedia/mplayerxp/files/patch-ae
+++ b/multimedia/mplayerxp/files/patch-ae
@@ -1,22 +1,15 @@
---- Makefile.orig Thu Jul 25 05:37:27 2002
-+++ Makefile Wed Aug 7 13:07:21 2002
-@@ -24,12 +24,12 @@
+--- Makefile.orig Mon Sep 9 13:47:54 2002
++++ Makefile Thu Sep 19 12:54:34 2002
+@@ -24,7 +24,7 @@
endif
- #prefix = /usr/local
--BINDIR = ${prefix}/bin
-+BINDIR = $(PREFIX)/bin
- # BINDIR = /usr/local/bin
--MANDIR = ${prefix}/man
-+MANDIR = $(PREFIX)/man
-
# a BSD compatible 'install' program
-INSTALL = install
+INSTALL = @${BSD_INSTALL_PROGRAM}
- SRCS_COMMON = xacodec.c cpudetect.c codec-cfg.c cfgparser.c my_profile.c spudec.c playtree.c playtreeparser.c asxparser.c vobsub.c subreader.c sub_cc.c find_sub.c
- SRCS_MENCODER = mencoder.c mp_msg-mencoder.c $(SRCS_COMMON) libao2/afmt.c divx4_vbr.c libvo/aclib.c libvo/osd.c libvo/sub.c libvo/font_load.c me-opt-reg.c
-@@ -226,44 +226,11 @@
+ SRCS_COMMON = cpudetect.c codec-cfg.c cfgparser.c my_profile.c spudec.c playtree.c playtreeparser.c asxparser.c vobsub.c subreader.c sub_cc.c find_sub.c
+ SRCS_MENCODER = mencoder.c mp_msg-mencoder.c $(SRCS_COMMON) libao2/afmt.c divx4_vbr.c libvo/aclib.c libvo/osd.c libvo/sub.c libvo/font_load.c libvo/font_load_ft.c me-opt-reg.c xvid_vbr.c
+@@ -193,44 +193,11 @@
ifeq ($(VIDIX),yes)
$(DO_MAKE)
endif
@@ -50,7 +43,7 @@
-ifeq ($(DVDKIT),yes)
-ifeq ($(DVDKIT_SHARED),yes)
- if test ! -d $(LIBDIR) ; then mkdir -p $(LIBDIR) ; fi
-- $(INSTALL) -m 755 $(INSTALLSTRIP) libmpdvdkit/libmpdvdkit.so $(LIBDIR)/libmpdvdkit.so
+- $(INSTALL) -m 755 $(INSTALLSTRIP) libmpdvdkit2/libmpdvdkit.so $(LIBDIR)/libmpdvdkit.so
-endif
-endif
-ifeq ($(CSS_USE),yes)
diff --git a/multimedia/mplayerxp/files/patch-mplayer:subreader.c b/multimedia/mplayerxp/files/patch-mplayer:subreader.c
deleted file mode 100644
index 93af516634a2..000000000000
--- a/multimedia/mplayerxp/files/patch-mplayer:subreader.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- subreader.c.orig Mon May 13 22:41:20 2002
-+++ subreader.c Tue Jun 4 22:54:33 2002
-@@ -18,11 +18,7 @@
- #define ERR ((void *) -1)
-
- #ifdef USE_ICONV
--#ifdef __FreeBSD__
--#include <giconv.h>
--#else
- #include <iconv.h>
--#endif
- char *sub_cp=NULL;
- #endif
-
diff --git a/multimedia/mplayerxp/pkg-plist b/multimedia/mplayerxp/pkg-plist
index 36514b014f5c..9e56a14f12c5 100644
--- a/multimedia/mplayerxp/pkg-plist
+++ b/multimedia/mplayerxp/pkg-plist
@@ -1,13 +1,6 @@
bin/mplayer
bin/mencoder
-lib/libdha-0.1.so
-lib/libdha.so
-lib/mplayer/vidix/mach64_vid.so
-lib/mplayer/vidix/mga_crtc2_vid.so
-lib/mplayer/vidix/mga_vid.so
-lib/mplayer/vidix/pm3_vid.so
-lib/mplayer/vidix/radeon_vid.so
-lib/mplayer/vidix/rage128_vid.so
+%%GMPLAYER%%bin/gmplayer
%%PORTDOCS%%share/doc/mplayer/bugreports.html
%%PORTDOCS%%share/doc/mplayer/cd-dvd.html
%%PORTDOCS%%share/doc/mplayer/codecs-in.html
@@ -24,5 +17,3 @@ share/mplayer/codecs.conf
share/mplayer/example.conf
share/mplayer/input.conf
%%PORTDOCS%%@dirrm share/doc/mplayer
-@dirrm lib/mplayer/vidix
-@dirrm lib/mplayer