aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mpvpaper
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2020-11-17 17:46:11 +0000
committerMark Linimon <linimon@FreeBSD.org>2020-11-17 17:46:11 +0000
commitba8525314c080ea65f28b9f884e575e994a4aa9a (patch)
treed756f43c6036f79620a548358804d6f3c236a42d /multimedia/mpvpaper
parent75f93b8b8c9e605bbbaeb8c02ac58e50d89e3f83 (diff)
Fix build on GCC-based systems by add compiler:c++11-lang to USES:
../inc/glad/glad_egl.h:50: error: redefinition of typedef 'GLADloadproc' ../inc/glad/glad.h:55: error: previous declaration of 'GLADloadproc' was here ../src/main.c: In function 'init_egl': ../src/main.c:175: error: 'for' loop initial declaration used outside C99 mode Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=555573
Diffstat (limited to 'multimedia/mpvpaper')
-rw-r--r--multimedia/mpvpaper/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/multimedia/mpvpaper/Makefile b/multimedia/mpvpaper/Makefile
index 967f69382958..aba04126a1dd 100644
--- a/multimedia/mpvpaper/Makefile
+++ b/multimedia/mpvpaper/Makefile
@@ -13,7 +13,7 @@ BUILD_DEPENDS= wayland-protocols>0:graphics/wayland-protocols
LIB_DEPENDS= libwayland-egl.so:graphics/wayland \
libmpv.so:multimedia/mpv
-USES= gl meson pkgconfig
+USES= compiler:c++11-lang gl meson pkgconfig
USE_GITHUB= yes
USE_GL= egl
GH_ACCOUNT= GhostNaN