aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mythtv/files
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2012-10-27 13:24:45 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2012-10-27 13:24:45 +0000
commit064885a929c190b562074eb5517514d70ab5dfee (patch)
tree573ace09da711840dc451a767d80367d6812c04b /multimedia/mythtv/files
parent3d665e8d6b5c518b4b9233197f64d6a19421774d (diff)
downloadports-064885a929c190b562074eb5517514d70ab5dfee.tar.gz
ports-064885a929c190b562074eb5517514d70ab5dfee.zip
Notes
Diffstat (limited to 'multimedia/mythtv/files')
-rw-r--r--multimedia/mythtv/files/patch-bindings__php__MythBase.php11
-rw-r--r--multimedia/mythtv/files/patch-bindings__python__setup.py2
-rw-r--r--multimedia/mythtv/files/patch-configure36
-rw-r--r--multimedia/mythtv/files/patch-extern__zeromq__doc__Makefile.in11
-rw-r--r--multimedia/mythtv/files/patch-external__FFmpeg__libavcodec__Makefile11
-rw-r--r--multimedia/mythtv/files/patch-programs__mythtranscode__transcode.cpp11
6 files changed, 30 insertions, 52 deletions
diff --git a/multimedia/mythtv/files/patch-bindings__php__MythBase.php b/multimedia/mythtv/files/patch-bindings__php__MythBase.php
deleted file mode 100644
index e291c6dc26f6..000000000000
--- a/multimedia/mythtv/files/patch-bindings__php__MythBase.php
+++ /dev/null
@@ -1,11 +0,0 @@
---- bindings/php/MythBase.php.orig 2012-07-16 17:21:00.000000000 +0200
-+++ bindings/php/MythBase.php 2012-07-29 14:13:02.915720097 +0200
-@@ -47,7 +47,7 @@
-
- public function __destruct() {
- if (!is_null($this->cacheKey))
-- Cache::setObject($this->cacheKey, &$this, $this->cacheLifetime);
-+ Cache::setObject($this->cacheKey, $this, $this->cacheLifetime);
- $this->cacheKey = null;
- }
-
diff --git a/multimedia/mythtv/files/patch-bindings__python__setup.py b/multimedia/mythtv/files/patch-bindings__python__setup.py
index 9cda71b3ab21..66c95ffa184f 100644
--- a/multimedia/mythtv/files/patch-bindings__python__setup.py
+++ b/multimedia/mythtv/files/patch-bindings__python__setup.py
@@ -5,7 +5,7 @@
setup(
name='MythTV',
- version='0.25.0',
-+ version='0.25.2',
++ version='0.26.0',
description='MythTV Python bindings.',
long_description='Provides canned database and protocol access to the MythTV database, mythproto, mythxml, and frontend remote control.',
packages=['MythTV', 'MythTV/tmdb', 'MythTV/tmdb3', 'MythTV/ttvdb', 'MythTV/wikiscripts'],
diff --git a/multimedia/mythtv/files/patch-configure b/multimedia/mythtv/files/patch-configure
index df490e145ddd..ec18184b8f97 100644
--- a/multimedia/mythtv/files/patch-configure
+++ b/multimedia/mythtv/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2012-03-19 06:39:10.000000000 +0100
-+++ configure 2012-03-21 23:40:37.060067228 +0100
-@@ -734,21 +734,21 @@
+--- configure.orig 2012-10-02 12:30:24.000000000 +0200
++++ configure 2012-10-03 19:27:16.773415414 +0200
+@@ -731,21 +731,21 @@
log check_cc "$@"
cat > $TMPC
log_file $TMPC
@@ -8,6 +8,14 @@
+ check_cmd $cc $CPPFLAGS $CFLAGS -I${prefix}/include "$@" -c -o $TMPO $TMPC
}
+ check_cxx(){
+ log check_cxx "$@"
+ cat > $TMPCPP
+ log_file $TMPCPP
+- check_cmd $cxx $CPPFLAGS $CXXFLAGS "$@" -c -o $TMPO $TMPCPP
++ check_cmd $cxx $CPPFLAGS $CXXFLAGS -I${prefix}/include "$@" -c -o $TMPO $TMPCPP
+ }
+
check_cpp(){
log check_cpp "$@"
cat > $TMPC
@@ -16,16 +24,8 @@
+ check_cmd $cc $CPPFLAGS $CFLAGS -I${prefix}/include "$@" -E -o $TMPO $TMPC
}
- check_cxx(){
- log check_cxx "$@"
- cat > $TMPCXX
- log_file $TMPCXX
-- check_cmd $cxx $CXXPPFLAGS $ECXXFLAGS "$@" -c -o $TMPO $TMPCXX
-+ check_cmd $cxx $CXXPPFLAGS $ECXXFLAGS -I${prefix}/include "$@" -c -o $TMPO $TMPCXX
- }
-
check_as(){
-@@ -1942,7 +1942,7 @@
+@@ -2152,7 +2152,7 @@
# machine
arch_default=$(uname -m)
@@ -34,8 +34,8 @@
processor=`uname -p 2>/dev/null`
processor_flags=""
tune="generic"
-@@ -2920,7 +2920,7 @@
- i686|pentiumpro|pentium[23]|pentium-m|athlon|athlon-tbird|athlon-4|athlon-[mx]p|athlon64|k8|opteron|athlon-fx|k8-sse3|opteron-sse3|athlon64-sse3|core2|amdfam10|barcelona|atom)
+@@ -3185,7 +3185,7 @@
+ i686|pentiumpro|pentium[23]|pentium-m|athlon|athlon-tbird|athlon-4|athlon-[mx]p|athlon64*|k8*|opteron*|athlon-fx|core2|amdfam10|barcelona|atom)
cpuflags="-march=$cpu"
enable cmov
- enable fast_cmov
@@ -43,15 +43,15 @@
;;
# targets that do support conditional mov but on which it's slow
pentium4|pentium4m|prescott|nocona)
-@@ -3120,7 +3120,6 @@
- enable malloc_aligned
+@@ -3401,7 +3401,6 @@
+ append CCONFIG "freebsd"
# Workaround compile errors from missing u_int/uint def
CPPFLAGS=`echo $CPPFLAGS | sed 's/-D_POSIX_C_SOURCE=200112//'`
- disable ivtv
enable backend
;;
bsd/os)
-@@ -4962,6 +4961,8 @@
+@@ -5427,6 +5426,8 @@
QMAKE_LIBDIR_QT-=${sysroot}${libdir}
QMAKE_LIBDIR-=${sysroot}${libdir}
LATE_LIBS+=-L${sysroot}${libdir}
@@ -60,7 +60,7 @@
EOF
#echo "endif # FFMPEG_CONFIG_MAK" >> $TMPMAK
-@@ -5012,7 +5013,7 @@
+@@ -5477,7 +5478,7 @@
BINDIR=\$(INSTALL_ROOT)$bindir
DATADIR=\$(INSTALL_ROOT)$datadir
MANDIR=\$(INSTALL_ROOT)$mandir
diff --git a/multimedia/mythtv/files/patch-extern__zeromq__doc__Makefile.in b/multimedia/mythtv/files/patch-extern__zeromq__doc__Makefile.in
new file mode 100644
index 000000000000..0630820f8d82
--- /dev/null
+++ b/multimedia/mythtv/files/patch-extern__zeromq__doc__Makefile.in
@@ -0,0 +1,11 @@
+--- external/zeromq/doc/Makefile.in.orig 2012-10-02 12:30:24.000000000 +0200
++++ external/zeromq/doc/Makefile.in 2012-10-20 16:56:13.777947694 +0200
+@@ -476,7 +476,7 @@
+
+ install-info-am:
+
+-install-man: install-man3 install-man7
++install-man:
+
+ install-pdf: install-pdf-am
+
diff --git a/multimedia/mythtv/files/patch-external__FFmpeg__libavcodec__Makefile b/multimedia/mythtv/files/patch-external__FFmpeg__libavcodec__Makefile
deleted file mode 100644
index 2f3a9b67c3f1..000000000000
--- a/multimedia/mythtv/files/patch-external__FFmpeg__libavcodec__Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- external/FFmpeg/libavcodec/Makefile.orig 2010-11-01 21:14:42.000000000 +0100
-+++ external/FFmpeg/libavcodec/Makefile 2010-11-01 20:30:35.000000000 +0100
-@@ -631,7 +631,7 @@
- # well.
- OBJS-$(!CONFIG_SMALL) += inverse.o
-
---include $(SUBDIR)$(ARCH)/Makefile
-+-include $(SUBDIR)x86/Makefile
-
- SKIPHEADERS = %_tablegen.h
- SKIPHEADERS-$(CONFIG_DXVA2) += dxva2.h dxva2_internal.h
diff --git a/multimedia/mythtv/files/patch-programs__mythtranscode__transcode.cpp b/multimedia/mythtv/files/patch-programs__mythtranscode__transcode.cpp
deleted file mode 100644
index aab1bde45ded..000000000000
--- a/multimedia/mythtv/files/patch-programs__mythtranscode__transcode.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- programs/mythtranscode/transcode.cpp.orig 2012-03-19 06:39:10.000000000 +0100
-+++ programs/mythtranscode/transcode.cpp 2012-03-24 18:25:25.121052981 +0100
-@@ -484,7 +484,7 @@
- {
- return false;
- }
-- else if (abs(audioFramesToCut - frames) < audioFramesToCut)
-+ else if (llabs(audioFramesToCut - frames) < audioFramesToCut)
- {
- // Drop the packet containing these frames if doing
- // so gets us closer to zero left to drop