aboutsummaryrefslogtreecommitdiff
path: root/multimedia/mythtv
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2009-04-25 01:13:39 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2009-04-25 01:13:39 +0000
commit40a58cd616d8cc89618b11b9f4274c313901bc63 (patch)
treeb9c2d54b1fc26c7c48bcc9965ff7ed382e82b8a2 /multimedia/mythtv
parent9d85b727b50aad89fb5a26aeae5cdd1b419258ad (diff)
downloadports-40a58cd616d8cc89618b11b9f4274c313901bc63.tar.gz
ports-40a58cd616d8cc89618b11b9f4274c313901bc63.zip
Notes
Diffstat (limited to 'multimedia/mythtv')
-rw-r--r--multimedia/mythtv/Makefile1
-rw-r--r--multimedia/mythtv/files/patch-libs__libmyth__libmyth.pro25
-rw-r--r--multimedia/mythtv/files/patch-libs__libmythtv__libmythtv.pro10
-rw-r--r--multimedia/mythtv/files/patch-programs__mythtranscode__mythtranscode.pro10
4 files changed, 46 insertions, 0 deletions
diff --git a/multimedia/mythtv/Makefile b/multimedia/mythtv/Makefile
index 2aa5127bba33..816b6da1db96 100644
--- a/multimedia/mythtv/Makefile
+++ b/multimedia/mythtv/Makefile
@@ -8,6 +8,7 @@
PORTNAME= mythtv
PORTVERSION= 0.21
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= ftp://ftp.osuosl.org/pub/mythtv/ \
LOCAL/glarkin
diff --git a/multimedia/mythtv/files/patch-libs__libmyth__libmyth.pro b/multimedia/mythtv/files/patch-libs__libmyth__libmyth.pro
new file mode 100644
index 000000000000..cd5a89abd2d4
--- /dev/null
+++ b/multimedia/mythtv/files/patch-libs__libmyth__libmyth.pro
@@ -0,0 +1,25 @@
+--- ./libs/libmyth/libmyth.pro.orig 2008-03-04 12:08:41.000000000 -0500
++++ ./libs/libmyth/libmyth.pro 2009-04-22 21:04:16.000000000 -0400
+@@ -43,14 +43,14 @@
+ SOURCES += volumebase.cpp volumecontrol.cpp virtualkeyboard.cpp xmlparse.cpp
+ SOURCES += mythhdd.cpp mythcdrom.cpp storagegroup.cpp dbutil.cpp
+
+-INCLUDEPATH += ../libmythsamplerate ../libmythsoundtouch ../libmythfreesurround
+-INCLUDEPATH += ../libavcodec ../libavutil
+-INCLUDEPATH += ../.. ../ ./
+-DEPENDPATH += ../libmythsamplerate ../libmythsoundtouch
+-DEPENDPATH += ../libmythfreesurround
+-DEPENDPATH += ../libavcodec ../libavutil
+-DEPENDPATH += ../ ../libmythui
+-DEPENDPATH += ../libmythupnp
++INCLUDEPATH = ../libmythsamplerate ../libmythsoundtouch ../libmythfreesurround $${INCLUDEPATH}
++INCLUDEPATH = ../libavcodec ../libavutil $${INCLUDEPATH}
++INCLUDEPATH = ../.. ../ ./ $${INCLUDEPATH}
++DEPENDPATH = ../libmythsamplerate ../libmythsoundtouch $${DEPENDPATH}
++DEPENDPATH = ../libmythfreesurround $${DEPENDPATH}
++DEPENDPATH = ../libavcodec ../libavutil $${DEPENDPATH}
++DEPENDPATH = ../ ../libmythui $${DEPENDPATH}
++DEPENDPATH = ../libmythupnp $${DEPENDPATH}
+
+
+ LIBS += -L../libmythsamplerate -lmythsamplerate-$${LIBVERSION}
diff --git a/multimedia/mythtv/files/patch-libs__libmythtv__libmythtv.pro b/multimedia/mythtv/files/patch-libs__libmythtv__libmythtv.pro
new file mode 100644
index 000000000000..5e44101e9a0c
--- /dev/null
+++ b/multimedia/mythtv/files/patch-libs__libmythtv__libmythtv.pro
@@ -0,0 +1,10 @@
+--- ./libs/libmythtv/libmythtv.pro.orig 2008-02-18 17:59:32.000000000 -0500
++++ ./libs/libmythtv/libmythtv.pro 2009-04-22 21:04:16.000000000 -0400
+@@ -49,6 +49,7 @@
+
+
+ DEFINES += _LARGEFILE_SOURCE
++QMAKE_CXXFLAGS = -I../libmyth -I../libavcodec -I../libavutil -I../libmythmpeg2 $${QMAKE_CXXFLAGS}
+ QMAKE_CXXFLAGS += $${FREETYPE_CFLAGS}
+ QMAKE_LFLAGS_SHLIB += $${FREETYPE_LIBS}
+
diff --git a/multimedia/mythtv/files/patch-programs__mythtranscode__mythtranscode.pro b/multimedia/mythtv/files/patch-programs__mythtranscode__mythtranscode.pro
new file mode 100644
index 000000000000..8ba1a51e220d
--- /dev/null
+++ b/multimedia/mythtv/files/patch-programs__mythtranscode__mythtranscode.pro
@@ -0,0 +1,10 @@
+--- ./programs/mythtranscode/mythtranscode.pro.orig 2007-02-24 12:44:00.000000000 -0500
++++ ./programs/mythtranscode/mythtranscode.pro 2009-04-22 21:04:16.000000000 -0400
+@@ -20,3 +20,7 @@
+ INCLUDEPATH += replex
+ INCLUDEPATH += ../../libs/libavcodec ../../libs/libavformat \
+ ../../libs/libavutil ../../libs/libmythmpeg2
++
++QMAKE_CXXFLAGS = -I../../libs/libavcodec -I../../libs/libavformat \
++ -I../../libs/libavutil -I../../libs/libmythmpeg2 \
++ $${QMAKE_CXXFLAGS}