aboutsummaryrefslogtreecommitdiff
path: root/multimedia/nordlicht
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2016-01-01 16:14:28 +0000
committerThomas Zander <riggs@FreeBSD.org>2016-01-01 16:14:28 +0000
commit750aa4fe2e42dc2cd66e49d6897ede26869322ea (patch)
tree56e1ab8d6ca0e775bf912a5b42f5f21a29eff275 /multimedia/nordlicht
parent76db1743277853c45c95925dd971079200172adf (diff)
downloadports-750aa4fe2e42dc2cd66e49d6897ede26869322ea.tar.gz
ports-750aa4fe2e42dc2cd66e49d6897ede26869322ea.zip
Notes
Diffstat (limited to 'multimedia/nordlicht')
-rw-r--r--multimedia/nordlicht/Makefile24
-rw-r--r--multimedia/nordlicht/distinfo2
-rw-r--r--multimedia/nordlicht/files/patch-CMakeLists.txt13
-rw-r--r--multimedia/nordlicht/pkg-descr6
-rw-r--r--multimedia/nordlicht/pkg-plist6
5 files changed, 51 insertions, 0 deletions
diff --git a/multimedia/nordlicht/Makefile b/multimedia/nordlicht/Makefile
new file mode 100644
index 000000000000..a86fa71636f4
--- /dev/null
+++ b/multimedia/nordlicht/Makefile
@@ -0,0 +1,24 @@
+# Created by: Tobias Kortkamp <t@tobik.me>
+# $FreeBSD$
+
+PORTNAME= nordlicht
+PORTVERSION= 0.4.0
+DISTVERSIONPREFIX= v
+CATEGORIES= multimedia
+
+MAINTAINER= t@tobik.me
+COMMENT= Create moodbars from video files
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= help2man:${PORTSDIR}/misc/help2man
+LIB_DEPENDS= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg \
+ libpopt.so:${PORTSDIR}/devel/popt \
+ libpng.so:${PORTSDIR}/graphics/png
+
+USE_GITHUB= yes
+
+USES= cmake:outsource pkgconfig
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/multimedia/nordlicht/distinfo b/multimedia/nordlicht/distinfo
new file mode 100644
index 000000000000..d576a5a350c0
--- /dev/null
+++ b/multimedia/nordlicht/distinfo
@@ -0,0 +1,2 @@
+SHA256 (nordlicht-nordlicht-v0.4.0_GH0.tar.gz) = dce586372b66959f158ba86739b66f0c7f6285306c8779b29ddb89eac9c31cdd
+SIZE (nordlicht-nordlicht-v0.4.0_GH0.tar.gz) = 37743
diff --git a/multimedia/nordlicht/files/patch-CMakeLists.txt b/multimedia/nordlicht/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..31672f93e9c4
--- /dev/null
+++ b/multimedia/nordlicht/files/patch-CMakeLists.txt
@@ -0,0 +1,13 @@
+--- CMakeLists.txt.orig 2015-12-30 13:35:04 UTC
++++ CMakeLists.txt
+@@ -39,8 +39,8 @@ add_custom_command(TARGET nordlicht POST
+ install(TARGETS libnordlicht DESTINATION ${LIB_INSTALL_DIR})
+ install(TARGETS nordlicht DESTINATION bin)
+ install(FILES nordlicht.h DESTINATION include)
+-install(FILES ${CMAKE_BINARY_DIR}/nordlicht.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
+-install(FILES ${CMAKE_BINARY_DIR}/nordlicht.1 DESTINATION share/man/man1)
++install(FILES ${CMAKE_BINARY_DIR}/nordlicht.pc DESTINATION libdata/pkgconfig)
++install(FILES ${CMAKE_BINARY_DIR}/nordlicht.1 DESTINATION man/man1)
+
+ add_custom_target(check testsuite)
+ add_custom_target(download_testfile ${CMAKE_COMMAND} -P ${CMAKE_SOURCE_DIR}/cmake/download_testfile.cmake)
diff --git a/multimedia/nordlicht/pkg-descr b/multimedia/nordlicht/pkg-descr
new file mode 100644
index 000000000000..8c21628a52c0
--- /dev/null
+++ b/multimedia/nordlicht/pkg-descr
@@ -0,0 +1,6 @@
+nordlicht is a tool that converts video files into colorful barcodes.
+nordlicht is free software, supports a large number of styles, and is
+optimized for speed. It comes with a software library written in C
+that allows for easy integration into other programs.
+
+WWW: https://nordlicht.github.io/
diff --git a/multimedia/nordlicht/pkg-plist b/multimedia/nordlicht/pkg-plist
new file mode 100644
index 000000000000..05846be20312
--- /dev/null
+++ b/multimedia/nordlicht/pkg-plist
@@ -0,0 +1,6 @@
+bin/nordlicht
+include/nordlicht.h
+lib/libnordlicht.so
+lib/libnordlicht.so.0
+libdata/pkgconfig/nordlicht.pc
+man/man1/nordlicht.1.gz