aboutsummaryrefslogtreecommitdiff
path: root/multimedia/oggvideotools
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2013-11-28 15:29:50 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2013-11-28 15:29:50 +0000
commita3ab9c1e591c2bc62bb12c206c6f163a5eef7ecd (patch)
tree56655710ba7647360dde67630adb9ef16468cfac /multimedia/oggvideotools
parenta12576ddf63de710db157e74854d0a27ccb5c076 (diff)
- Fix build on CURRENT
PR: ports/184243 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=335100
Diffstat (limited to 'multimedia/oggvideotools')
-rw-r--r--multimedia/oggvideotools/Makefile16
-rw-r--r--multimedia/oggvideotools/files/patch-src__pictureBlend.cpp11
-rw-r--r--multimedia/oggvideotools/pkg-plist11
3 files changed, 28 insertions, 10 deletions
diff --git a/multimedia/oggvideotools/Makefile b/multimedia/oggvideotools/Makefile
index d5662d62cca2..7e9fc3346fd8 100644
--- a/multimedia/oggvideotools/Makefile
+++ b/multimedia/oggvideotools/Makefile
@@ -12,20 +12,16 @@ COMMENT= Toolbox for manipulating Ogg video files
LICENSE= GPLv2 # (or later)
-LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd \
- ogg:${PORTSDIR}/audio/libogg \
- theora:${PORTSDIR}/multimedia/libtheora \
- vorbis:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd \
+ libogg.so:${PORTSDIR}/audio/libogg \
+ libtheora.so:${PORTSDIR}/multimedia/libtheora \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis
-USE_SDL= sdl
USES= cmake pkgconfig
+USE_SDL= sdl
USE_LDCONFIG= yes
+CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAN1= mkThumbs.1 oggCat.1 oggCut.1 oggDump.1 oggJoin.1 \
- oggLength.1 oggSilence.1 oggSlideshow.1 oggSplit.1 \
- oggThumb.1 oggTranscode.1
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/multimedia/oggvideotools/files/patch-src__pictureBlend.cpp b/multimedia/oggvideotools/files/patch-src__pictureBlend.cpp
new file mode 100644
index 000000000000..5a02d275a3ea
--- /dev/null
+++ b/multimedia/oggvideotools/files/patch-src__pictureBlend.cpp
@@ -0,0 +1,11 @@
+--- src/pictureBlend.cpp.orig
++++ src/pictureBlend.cpp
+@@ -9,6 +9,8 @@
+ // Copyright: See COPYING file that comes with this distribution
+ //
+ //
++#include <string>
++
+ #include "pictureBlend.h"
+ #include "exception.h"
+
diff --git a/multimedia/oggvideotools/pkg-plist b/multimedia/oggvideotools/pkg-plist
index d955517b8c73..6bab8b6371b9 100644
--- a/multimedia/oggvideotools/pkg-plist
+++ b/multimedia/oggvideotools/pkg-plist
@@ -78,5 +78,16 @@ include/oggvt/vorbisPosInterpreter.h
include/oggvt/vorbisStreamParameter.h
include/oggvt/wishList.h
lib/liboggvideotools.so
+man/man1/mkThumbs.1.gz
+man/man1/oggCat.1.gz
+man/man1/oggCut.1.gz
+man/man1/oggDump.1.gz
+man/man1/oggJoin.1.gz
+man/man1/oggLength.1.gz
+man/man1/oggSilence.1.gz
+man/man1/oggSlideshow.1.gz
+man/man1/oggSplit.1.gz
+man/man1/oggThumb.1.gz
+man/man1/oggTranscode.1.gz
sbin/mkThumbs
@dirrm include/oggvt