aboutsummaryrefslogtreecommitdiff
path: root/multimedia/oggvideotools
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-03-15 15:29:07 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-03-15 15:29:07 +0000
commit8e2d32f40f94e6963c2409fc12019801be3ff658 (patch)
tree99f4ef8d509819c630c0129ba4a16497336d248e /multimedia/oggvideotools
parentba52c5196a8a9ab01346c71f2625f3f03d97b930 (diff)
downloadports-8e2d32f40f94e6963c2409fc12019801be3ff658.tar.gz
ports-8e2d32f40f94e6963c2409fc12019801be3ff658.zip
Notes
Diffstat (limited to 'multimedia/oggvideotools')
-rw-r--r--multimedia/oggvideotools/Makefile10
-rw-r--r--multimedia/oggvideotools/distinfo4
-rw-r--r--multimedia/oggvideotools/files/patch-src_base_fileRepository.h (renamed from multimedia/oggvideotools/files/patch-src_fileRepository.h)4
-rw-r--r--multimedia/oggvideotools/files/patch-src_effect_pictureBlend.cpp (renamed from multimedia/oggvideotools/files/patch-src__pictureBlend.cpp)4
-rw-r--r--multimedia/oggvideotools/files/patch-src_main_cmdlineextractor.h (renamed from multimedia/oggvideotools/files/patch-src_cmdlineextractor.h)8
-rw-r--r--multimedia/oggvideotools/pkg-plist70
6 files changed, 17 insertions, 83 deletions
diff --git a/multimedia/oggvideotools/Makefile b/multimedia/oggvideotools/Makefile
index 8674f1cd984b..837f55039eac 100644
--- a/multimedia/oggvideotools/Makefile
+++ b/multimedia/oggvideotools/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= oggvideotools
-PORTVERSION= 0.8a
-PORTREVISION= 4
+PORTVERSION= 0.9
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}
@@ -17,11 +16,16 @@ LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd \
libtheora.so:${PORTSDIR}/multimedia/libtheora \
libvorbis.so:${PORTSDIR}/audio/libvorbis
-USES= cmake pkgconfig
+USES= cmake compiler:c++11-lib pkgconfig
+USE_CXXSTD= c++11
USE_SDL= sdl
USE_LDCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|-O0.*-fPIC|-fPIC|' ${WRKSRC}/CMakeLists.txt
+
.include <bsd.port.mk>
diff --git a/multimedia/oggvideotools/distinfo b/multimedia/oggvideotools/distinfo
index 39c919d3eb3b..93e8a5d1e901 100644
--- a/multimedia/oggvideotools/distinfo
+++ b/multimedia/oggvideotools/distinfo
@@ -1,2 +1,2 @@
-SHA256 (oggvideotools-0.8a.tar.gz) = 27f96a98d8b5a2c90f042ace7b4d08c9246d4d0590a8e630800b4779024514cc
-SIZE (oggvideotools-0.8a.tar.gz) = 186093
+SHA256 (oggvideotools-0.9.tar.gz) = 16589d6f4b888ec3ed2c7cc22c915899a8ff1358a8a56cdfd91432cb6223cb79
+SIZE (oggvideotools-0.9.tar.gz) = 289859
diff --git a/multimedia/oggvideotools/files/patch-src_fileRepository.h b/multimedia/oggvideotools/files/patch-src_base_fileRepository.h
index e3f05cda52e1..cd05f2441b19 100644
--- a/multimedia/oggvideotools/files/patch-src_fileRepository.h
+++ b/multimedia/oggvideotools/files/patch-src_base_fileRepository.h
@@ -1,5 +1,5 @@
---- src/fileRepository.h.orig 2010-05-30 19:11:10.000000000 +0000
-+++ src/fileRepository.h
+--- src/base/fileRepository.h.orig 2015-10-05 06:33:52 UTC
++++ src/base/fileRepository.h
@@ -23,6 +23,7 @@
#define FILEREPOSITORY_H_
diff --git a/multimedia/oggvideotools/files/patch-src__pictureBlend.cpp b/multimedia/oggvideotools/files/patch-src_effect_pictureBlend.cpp
index 5a02d275a3ea..c119a7f83996 100644
--- a/multimedia/oggvideotools/files/patch-src__pictureBlend.cpp
+++ b/multimedia/oggvideotools/files/patch-src_effect_pictureBlend.cpp
@@ -1,5 +1,5 @@
---- src/pictureBlend.cpp.orig
-+++ src/pictureBlend.cpp
+--- src/effect/pictureBlend.cpp.orig 2015-10-05 06:33:52 UTC
++++ src/effect/pictureBlend.cpp
@@ -9,6 +9,8 @@
// Copyright: See COPYING file that comes with this distribution
//
diff --git a/multimedia/oggvideotools/files/patch-src_cmdlineextractor.h b/multimedia/oggvideotools/files/patch-src_main_cmdlineextractor.h
index 257bda729d12..363df989d876 100644
--- a/multimedia/oggvideotools/files/patch-src_cmdlineextractor.h
+++ b/multimedia/oggvideotools/files/patch-src_main_cmdlineextractor.h
@@ -1,8 +1,8 @@
---- src/cmdlineextractor.h.orig 2010-05-30 21:11:10.000000000 +0200
-+++ src/cmdlineextractor.h 2014-01-25 18:46:51.620972183 +0100
-@@ -20,7 +20,7 @@
- #include "oggComment.h"
+--- src/main/cmdlineextractor.h.orig 2015-10-05 06:33:52 UTC
++++ src/main/cmdlineextractor.h
+@@ -21,7 +21,7 @@
#include "blendElement.h"
+ #include "effectorTypes.h"
-const std::string validChars ( "0123456789,x" );
+const std::string validChars ( "0123456789,x:" );
diff --git a/multimedia/oggvideotools/pkg-plist b/multimedia/oggvideotools/pkg-plist
index 445cc6046aa4..140e402ba64a 100644
--- a/multimedia/oggvideotools/pkg-plist
+++ b/multimedia/oggvideotools/pkg-plist
@@ -8,76 +8,6 @@ bin/oggSlideshow
bin/oggSplit
bin/oggThumb
bin/oggTranscode
-include/oggvt/audioConverter.h
-include/oggvt/audioHook.h
-include/oggvt/audioPacket.h
-include/oggvt/basePlane.h
-include/oggvt/blendElement.h
-include/oggvt/bufferRepository.h
-include/oggvt/cmdlineextractor.h
-include/oggvt/crc.h
-include/oggvt/crossfader.h
-include/oggvt/definition.h
-include/oggvt/effector.h
-include/oggvt/exception.h
-include/oggvt/fileRepository.h
-include/oggvt/granulePosInterpreter.h
-include/oggvt/helper.h
-include/oggvt/hookHandler.h
-include/oggvt/kateExtractor.h
-include/oggvt/kateHeader.h
-include/oggvt/katePosInterpreter.h
-include/oggvt/kateStreamParameter.h
-include/oggvt/kenburnseffect.h
-include/oggvt/log.h
-include/oggvt/lowpassEffect.h
-include/oggvt/mediaConverter.h
-include/oggvt/mediaDecoder.h
-include/oggvt/mediaEncoder.h
-include/oggvt/mediaInputEncoder.h
-include/oggvt/mediaOutputDecoder.h
-include/oggvt/mediaRepository.h
-include/oggvt/mediaUnit.h
-include/oggvt/oggBOSExtractorFactory.h
-include/oggvt/oggComment.h
-include/oggvt/oggDecoder.h
-include/oggvt/oggEncoder.h
-include/oggvt/oggHeader.h
-include/oggvt/oggPacket.h
-include/oggvt/oggPage.h
-include/oggvt/oggRingbuffer.h
-include/oggvt/oggStreamDecoder.h
-include/oggvt/oggStreamEncoder.h
-include/oggvt/oggTypes.h
-include/oggvt/pictureBlend.h
-include/oggvt/pictureLoader.h
-include/oggvt/pictureResize.h
-include/oggvt/plainPicture.h
-include/oggvt/rawMediaPacket.h
-include/oggvt/refObject.h
-include/oggvt/rgbPlane.h
-include/oggvt/ringbuffer.h
-include/oggvt/streamConfig.h
-include/oggvt/streamExtractor.h
-include/oggvt/streamMux.h
-include/oggvt/streamParameter.h
-include/oggvt/streamSerializer.h
-include/oggvt/th_helper.h
-include/oggvt/theoraDecoder.h
-include/oggvt/theoraEncoder.h
-include/oggvt/theoraExtractor.h
-include/oggvt/theoraHeader.h
-include/oggvt/theoraPosInterpreter.h
-include/oggvt/theoraStreamParameter.h
-include/oggvt/videoHook.h
-include/oggvt/vorbisDecoder.h
-include/oggvt/vorbisEncoder.h
-include/oggvt/vorbisExtractor.h
-include/oggvt/vorbisHeader.h
-include/oggvt/vorbisPosInterpreter.h
-include/oggvt/vorbisStreamParameter.h
-include/oggvt/wishList.h
-lib/liboggvideotools.so
man/man1/mkThumbs.1.gz
man/man1/oggCat.1.gz
man/man1/oggCut.1.gz