aboutsummaryrefslogtreecommitdiff
path: root/multimedia/ogle-gui/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-10-26 15:40:05 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-10-26 15:40:05 +0000
commit109111b8b367f11f040cf97b3f02cdf87e65c07e (patch)
tree310409c80e84cadb3f917bf7e01fd7711a52224b /multimedia/ogle-gui/Makefile
parentb4e36dc966de6a8805c3f3c6faccc773b689c2dd (diff)
downloadports-109111b8b367f11f040cf97b3f02cdf87e65c07e.tar.gz
ports-109111b8b367f11f040cf97b3f02cdf87e65c07e.zip
Notes
Diffstat (limited to 'multimedia/ogle-gui/Makefile')
-rw-r--r--multimedia/ogle-gui/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/multimedia/ogle-gui/Makefile b/multimedia/ogle-gui/Makefile
new file mode 100644
index 000000000000..7d376c873e6e
--- /dev/null
+++ b/multimedia/ogle-gui/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: ogle
+# Date created: Tue Oct 16 18:35:39 BRST 2001
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ogle
+PORTVERSION= 0.7.5
+CATEGORIES= graphics gnome
+MASTER_SITES= http://www.dtek.chalmers.se/groups/dvd/dist/
+PKGNAMESUFFIX= -gui
+DISTNAME= ${PORTNAME}_gui-${PORTVERSION}
+
+MAINTAINER= lioux@FreeBSD.org
+
+BUILD_DEPENDS= automake:${PORTSDIR}/devel/automake
+LIB_DEPENDS= dvdcontrol.4:${PORTSDIR}/graphics/ogle \
+ intl.1:${PORTSDIR}/devel/gettext \
+ jpeg.9:${PORTSDIR}/graphics/jpeg
+RUN_DEPENDS= ogle:${PORTSDIR}/graphics/ogle
+
+USE_X_PREFIX= yes
+USE_GNOMELIBS= yes
+USE_GTK= yes
+USE_XPM= yes
+GNU_CONFIGURE= yes
+USE_AUTOCONF= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-dvd-includes=${LOCALBASE}/include \
+ --with-dvdcontrol=${LOCALBASE} \
+ --without-included-gettext
+
+post-patch:
+ @${LN} -sf ${LOCALBASE}/bin/libtool ${WRKSRC}
+
+pre-configure:
+.for file in intl/Makefile.in po/Makefile.in.in
+ @${ECHO} 'all:' > ${WRKSRC}/${file}
+ @${ECHO} 'install:' >> ${WRKSRC}/${file}
+.endfor
+
+.include <bsd.port.mk>