aboutsummaryrefslogtreecommitdiff
path: root/multimedia/ogle
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-04-17 00:29:35 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-04-17 00:29:35 +0000
commit5d54f417a032fca429a303406f166ffbfc8c8d08 (patch)
tree3c6afdc00ad5d171d60f3186fff3dc5bf6b0da95 /multimedia/ogle
parentf12f2f611714f10bb25a68f917c09c60ca463f5a (diff)
downloadports-5d54f417a032fca429a303406f166ffbfc8c8d08.tar.gz
ports-5d54f417a032fca429a303406f166ffbfc8c8d08.zip
Notes
Diffstat (limited to 'multimedia/ogle')
-rw-r--r--multimedia/ogle/Makefile14
-rw-r--r--multimedia/ogle/files/extra-patch-include:ogle_endian.h16
2 files changed, 29 insertions, 1 deletions
diff --git a/multimedia/ogle/Makefile b/multimedia/ogle/Makefile
index c249c75a064c..84f135445d98 100644
--- a/multimedia/ogle/Makefile
+++ b/multimedia/ogle/Makefile
@@ -40,6 +40,12 @@ pre-everything::
@${ECHO_MSG} '===> Define WITH_DVD_DEVICE if you want to change the default'
@${ECHO_MSG} "===> For example, 'make WITH_DVD_DEVICE=\"/dev/somedevice\"'"
.endif
+.ifndef(WITH_OPTIMIZED_BYTESWAP)
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITH_OPTIMIZED_BYTESWAP to use optimized byteswap'
+ @${ECHO_MSG} '===> routines. This works only in the i386 architecture but'
+ @${ECHO_MSG} '===> only with 486 processors and above.'
+.endif
post-patch:
.ifdef(WITH_DVD_DEVICE)
@@ -61,4 +67,10 @@ post-configure:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386" && defined(WITH_OPTIMIZED_BYTESWAP)
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-include:ogle_endian.h
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/ogle/files/extra-patch-include:ogle_endian.h b/multimedia/ogle/files/extra-patch-include:ogle_endian.h
new file mode 100644
index 000000000000..4ac268a17041
--- /dev/null
+++ b/multimedia/ogle/files/extra-patch-include:ogle_endian.h
@@ -0,0 +1,16 @@
+--- include/ogle_endian.h.orig Thu Oct 4 05:42:11 2001
++++ include/ogle_endian.h Wed Apr 10 01:16:32 2002
+@@ -39,6 +39,13 @@
+ #elif defined(HAVE_SYS_ENDIAN_H)
+ # include <sys/endian.h>
+ # define FROM_BE_32(x) (swap32(x))
++#elif defined(__FreeBSD__)
++# define _KERNEL
++# define I486_CPU /* Will crash unless 486+ */
++# include <machine/endian.h>
++# undef _KERNEL
++# undef I486_CPU
++# define FROM_BE_32(x) (ntohl(x))
+ #else
+ # warning "No accelerated byte swap found. Using slow c version."
+ # include <inttypes.h>