aboutsummaryrefslogtreecommitdiff
path: root/multimedia/ogmrip/Makefile
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2012-06-05 20:58:39 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2012-06-05 20:58:39 +0000
commita9a856ece2b752d15e2f3dde360f3427cf115454 (patch)
tree40f411e80129681c074a97043dd633492701106c /multimedia/ogmrip/Makefile
parent78b3778238e58d201fefc8d14496783e90033183 (diff)
Notes
Diffstat (limited to 'multimedia/ogmrip/Makefile')
-rw-r--r--multimedia/ogmrip/Makefile52
1 files changed, 25 insertions, 27 deletions
diff --git a/multimedia/ogmrip/Makefile b/multimedia/ogmrip/Makefile
index 59039203f9fa..1e74b438526a 100644
--- a/multimedia/ogmrip/Makefile
+++ b/multimedia/ogmrip/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ogmrip
-PORTVERSION= 0.13.7
-PORTREVISION?= 3
+PORTVERSION= 0.13.8
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}/${PORTVERSION}
@@ -30,14 +29,13 @@ RUN_DEPENDS= lame:${PORTSDIR}/audio/lame \
mplayer:${PORTSDIR}/multimedia/mplayer \
ogmmerge:${PORTSDIR}/multimedia/ogmtools
-OPTIONS= GUI "Build the GTK+ GUI" on \
- ENCHANT "Enable spell checking for text subtitles" off \
- MATROSKA "Enable Matroska container support" off \
- MP4 "Enable Mpeg-4 container support" off \
- THEORA "Enable Ogg Theora video codec support" off \
- FAAC "Enable Advance Audio Coding (AAC) support" off \
- SRT "Enable SRT text subtitles support" off \
- DEBUG "Enable debug" off
+OPTIONS_DEFINE= GTK2 ENCHANT MATROSKA MP4BOX THEORA FAAC SRT DEBUG
+OPTIONS_DEFAULT=GTK2
+ENCHANT_DESC= Enable spell checking for text subtitles
+MATROSKA_DESC= Enable Matroska container support
+MP4BOX_DESC= Enable Mpeg-4 container support
+THEORA_DESC= Enable Ogg Theora video codec support
+SRT_DESC= Enable SRT text subtitles support
USE_GNOME= glib20 gnomehack intlhack libxml2
USE_GETTEXT= yes
@@ -51,23 +49,23 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAN1= dvdcpy.1 avibox.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_GUI)
-CONFIGURE_ARGS+= --disable-gtk-support --disable-dbus-support \
- --disable-libnotify-support
-PLIST_SUB+= GUI_SUPPORT="@comment "
-.else
+.if ${PORT_OPTIONS:MGTK2}
CONFIGURE_ARGS+= --enable-gtk-support --enable-dbus-support \
--enable-libnotify-support
LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
notify.4:${PORTSDIR}/devel/libnotify
USE_GNOME+= gconf2 libglade2
GCONF_SCHEMAS= ogmrip.schemas
-PLIST_SUB+= GUI_SUPPORT=""
+PLIST_SUB+= GTK2_SUPPORT=""
+.else
+CONFIGURE_ARGS+= --disable-gtk-support --disable-dbus-support \
+ --disable-libnotify-support
+PLIST_SUB+= GTK2_SUPPORT="@comment "
.endif
-.if defined(WITH_ENCHANT)
+.if ${PORT_OPTIONS:MENCHANT}
CONFIGURE_ARGS+= --enable-enchant-support
LIB_DEPENDS+= enchant:${PORTSDIR}/textproc/enchant
PLIST_SUB+= ENCHANT_SUPPORT=""
@@ -76,7 +74,7 @@ CONFIGURE_ARGS+= --disable-enchant-support
PLIST_SUB+= ENCHANT_SUPPORT="@comment "
.endif
-.if defined(WITH_MATROSKA)
+.if ${PORT_OPTIONS:MMATROSKA}
CONFIGURE_ARGS+= --enable-mkv-support
RUN_DEPENDS+= mkvmerge:${PORTSDIR}/multimedia/mkvtoolnix
PLIST_SUB+= MATROSKA_SUPPORT=""
@@ -85,16 +83,16 @@ CONFIGURE_ARGS+= --disable-mkv-support
PLIST_SUB+= MATROSKA_SUPPORT="@comment "
.endif
-.if defined(WITH_MP4)
+.if ${PORT_OPTIONS:MMP4BOX}
CONFIGURE_ARGS+= --enable-mp4-support
RUN_DEPENDS+= mp4box:${PORTSDIR}/multimedia/gpac-mp4box
-PLIST_SUB+= MP4_SUPPORT=""
+PLIST_SUB+= MP4BOX_SUPPORT=""
.else
CONFIGURE_ARGS+= --disable-mp4-support
-PLIST_SUB+= MP4_SUPPORT="@comment "
+PLIST_SUB+= MP4BOX_SUPPORT="@comment "
.endif
-.if defined(WITH_THEORA)
+.if ${PORT_OPTIONS:MTHEORA}
CONFIGURE_ARGS+= --enable-theora-support
LIB_DEPENDS+= theora:${PORTSDIR}/multimedia/libtheora
PLIST_SUB+= THEORA_SUPPORT=""
@@ -103,7 +101,7 @@ CONFIGURE_ARGS+= --disable-theora-support
PLIST_SUB+= THEORA_SUPPORT="@comment "
.endif
-.if defined(WITH_FAAC)
+.if ${PORT_OPTIONS:MFAAC}
CONFIGURE_ARGS+= --enable-aac-support
RUN_DEPENDS+= faac:${PORTSDIR}/audio/faac
PLIST_SUB+= FAAC_SUPPORT=""
@@ -112,7 +110,7 @@ CONFIGURE_ARGS+= --disable-aac-support
PLIST_SUB+= FAAC_SUPPORT="@comment "
.endif
-.if defined(WITH_SRT)
+.if ${PORT_OPTIONS:MSRT}
CONFIGURE_ARGS+= --enable-srt-support
RUN_DEPENDS+= gocr:${PORTSDIR}/graphics/gocr
MAN1+= subp2pgm.1 subptools.1
@@ -122,7 +120,7 @@ CONFIGURE_ARGS+= --disable-srt-support
PLIST_SUB+= SRT_SUPPORT="@comment "
.endif
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-maintainer-mode --enable-devel-mode
.endif
@@ -146,4 +144,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG} ""
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>