aboutsummaryrefslogtreecommitdiff
path: root/multimedia/ogmrip
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2006-05-21 23:37:11 +0000
committerHerve Quiroz <hq@FreeBSD.org>2006-05-21 23:37:11 +0000
commit10a5c12d468c37387cb5dc8b90e3fb1f970079e1 (patch)
treee8d71eae91f6539191f38b78d2e1ce056c66db91 /multimedia/ogmrip
parentae159b0c6e4539a9cafcbde606bd6c501996413f (diff)
downloadports-10a5c12d468c37387cb5dc8b90e3fb1f970079e1.tar.gz
ports-10a5c12d468c37387cb5dc8b90e3fb1f970079e1.zip
Notes
Diffstat (limited to 'multimedia/ogmrip')
-rw-r--r--multimedia/ogmrip/Makefile17
-rw-r--r--multimedia/ogmrip/files/patch-configure23
-rw-r--r--multimedia/ogmrip/pkg-plist1
3 files changed, 34 insertions, 7 deletions
diff --git a/multimedia/ogmrip/Makefile b/multimedia/ogmrip/Makefile
index fb6804400c67..79993cd19f77 100644
--- a/multimedia/ogmrip/Makefile
+++ b/multimedia/ogmrip/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ogmrip
PORTVERSION= 0.9.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,9 +19,12 @@ BUILD_DEPENDS= mencoder:${PORTSDIR}/multimedia/mplayer \
oggenc:${PORTSDIR}/audio/vorbis-tools \
ogmmerge:${PORTSDIR}/multimedia/ogmtools \
lame:${PORTSDIR}/audio/lame \
- gsed:${PORTSDIR}/textproc/gsed \
gocr:${PORTSDIR}/graphics/gocr
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= mencoder:${PORTSDIR}/multimedia/mplayer \
+ oggenc:${PORTSDIR}/audio/vorbis-tools \
+ ogmmerge:${PORTSDIR}/multimedia/ogmtools \
+ lame:${PORTSDIR}/audio/lame \
+ gocr:${PORTSDIR}/graphics/gocr
LIB_DEPENDS= xvidcore:${PORTSDIR}/multimedia/xvid \
dvdread:${PORTSDIR}/multimedia/libdvdread \
enchant:${PORTSDIR}/textproc/enchant
@@ -49,6 +52,10 @@ PLIST_SUB+= MKV_SUPPORT=""
PLIST_SUB+= MKV_SUPPORT="@comment "
.endif
+X264_SUPPORT!= ${LOCALBASE}/bin/mencoder -ovc help 2> /dev/null | ${GREP} -q '^ *x264 *- .*$$' \
+ && ${ECHO_CMD} "" || ${ECHO_CMD} "@comment "
+PLIST_SUB+= X264_SUPPORT="${X264_SUPPORT}"
+
.if !defined(WITH_DEBUG)
pre-extract:
@${ECHO_MSG} ""
@@ -68,10 +75,6 @@ pre-configure:
${FALSE} ; \
fi
-pre-install:
- @${LOCALBASE}/bin/mencoder -ovc help 2> /dev/null | ${GREP} -q "^ *x264 *- .*$$" \
- && ${ECHO_CMD} "include/ogmrip/ogmrip-x264.h" >>${TMPPLIST} || ${TRUE}
-
post-install:
@${ECHO_CMD} ""
@${CAT} ${PKGMESSAGE}
diff --git a/multimedia/ogmrip/files/patch-configure b/multimedia/ogmrip/files/patch-configure
new file mode 100644
index 000000000000..ed0e32311e56
--- /dev/null
+++ b/multimedia/ogmrip/files/patch-configure
@@ -0,0 +1,23 @@
+--- configure.orig Tue Jun 28 08:16:09 2005
++++ configure Sun May 21 14:20:18 2006
+@@ -20713,11 +20713,6 @@
+ fi
+
+ fi
+-if ! "$SED_PROG" --version 2> /dev/null | head -n 1 | grep -q "GNU sed"; then
+- { { echo "$as_me:$LINENO: error: Unable to GNU sed in the PATH. You need GNU sed to configure OGMRip. Find it on ftp://ftp.gnu.org/gnu/sed" >&5
+-echo "$as_me: error: Unable to GNU sed in the PATH. You need GNU sed to configure OGMRip. Find it on ftp://ftp.gnu.org/gnu/sed" >&2;}
+- { (exit 1); exit 1; }; }
+-fi
+
+
+ GTK_REQUIRED=2.6.0
+@@ -21304,7 +21299,7 @@
+
+
+ if $MPLAYER_PROG | grep -q "MPlayer [0-1]\.[0-9]\+pre[0-9]\+.*"; then
+- MPLAYER_PRE=`$MPLAYER_PROG | head -n 1 | $SED_PROG -e 's%MPlayer [0-1]\.[0-9]\+pre\([0-9]\+\).*%\1%'`
++ MPLAYER_PRE=`$MPLAYER_PROG | head -n 1 | $SED_PROG -e 's%MPlayer [0-1]\.[0-9]pre\([0-9]\).*%\1%'`
+
+ cat >>confdefs.h <<_ACEOF
+ #define MPLAYER_PRE $MPLAYER_PRE
diff --git a/multimedia/ogmrip/pkg-plist b/multimedia/ogmrip/pkg-plist
index a345ee68fd26..e9623ccb0315 100644
--- a/multimedia/ogmrip/pkg-plist
+++ b/multimedia/ogmrip/pkg-plist
@@ -21,6 +21,7 @@ include/ogmrip/ogmrip-video.h
include/ogmrip/ogmrip-vobsub.h
include/ogmrip/ogmrip-vorbis.h
include/ogmrip/ogmrip-wav.h
+%%X264_SUPPORT%%include/ogmrip/ogmrip-x264.h
include/ogmrip/ogmrip-xvid.h
include/ogmrip/ogmrip.h
include/ogmspawn/ogmsp-bin.h