aboutsummaryrefslogtreecommitdiff
path: root/multimedia/ogmrip
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2012-06-05 20:58:39 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2012-06-05 20:58:39 +0000
commita9a856ece2b752d15e2f3dde360f3427cf115454 (patch)
tree40f411e80129681c074a97043dd633492701106c /multimedia/ogmrip
parent78b3778238e58d201fefc8d14496783e90033183 (diff)
downloadports-a9a856ece2b752d15e2f3dde360f3427cf115454.tar.gz
ports-a9a856ece2b752d15e2f3dde360f3427cf115454.zip
Notes
Diffstat (limited to 'multimedia/ogmrip')
-rw-r--r--multimedia/ogmrip/Makefile52
-rw-r--r--multimedia/ogmrip/distinfo4
-rw-r--r--multimedia/ogmrip/pkg-plist118
3 files changed, 86 insertions, 88 deletions
diff --git a/multimedia/ogmrip/Makefile b/multimedia/ogmrip/Makefile
index 59039203f9fa..1e74b438526a 100644
--- a/multimedia/ogmrip/Makefile
+++ b/multimedia/ogmrip/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ogmrip
-PORTVERSION= 0.13.7
-PORTREVISION?= 3
+PORTVERSION= 0.13.8
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}/${PORTVERSION}
@@ -30,14 +29,13 @@ RUN_DEPENDS= lame:${PORTSDIR}/audio/lame \
mplayer:${PORTSDIR}/multimedia/mplayer \
ogmmerge:${PORTSDIR}/multimedia/ogmtools
-OPTIONS= GUI "Build the GTK+ GUI" on \
- ENCHANT "Enable spell checking for text subtitles" off \
- MATROSKA "Enable Matroska container support" off \
- MP4 "Enable Mpeg-4 container support" off \
- THEORA "Enable Ogg Theora video codec support" off \
- FAAC "Enable Advance Audio Coding (AAC) support" off \
- SRT "Enable SRT text subtitles support" off \
- DEBUG "Enable debug" off
+OPTIONS_DEFINE= GTK2 ENCHANT MATROSKA MP4BOX THEORA FAAC SRT DEBUG
+OPTIONS_DEFAULT=GTK2
+ENCHANT_DESC= Enable spell checking for text subtitles
+MATROSKA_DESC= Enable Matroska container support
+MP4BOX_DESC= Enable Mpeg-4 container support
+THEORA_DESC= Enable Ogg Theora video codec support
+SRT_DESC= Enable SRT text subtitles support
USE_GNOME= glib20 gnomehack intlhack libxml2
USE_GETTEXT= yes
@@ -51,23 +49,23 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAN1= dvdcpy.1 avibox.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_GUI)
-CONFIGURE_ARGS+= --disable-gtk-support --disable-dbus-support \
- --disable-libnotify-support
-PLIST_SUB+= GUI_SUPPORT="@comment "
-.else
+.if ${PORT_OPTIONS:MGTK2}
CONFIGURE_ARGS+= --enable-gtk-support --enable-dbus-support \
--enable-libnotify-support
LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
notify.4:${PORTSDIR}/devel/libnotify
USE_GNOME+= gconf2 libglade2
GCONF_SCHEMAS= ogmrip.schemas
-PLIST_SUB+= GUI_SUPPORT=""
+PLIST_SUB+= GTK2_SUPPORT=""
+.else
+CONFIGURE_ARGS+= --disable-gtk-support --disable-dbus-support \
+ --disable-libnotify-support
+PLIST_SUB+= GTK2_SUPPORT="@comment "
.endif
-.if defined(WITH_ENCHANT)
+.if ${PORT_OPTIONS:MENCHANT}
CONFIGURE_ARGS+= --enable-enchant-support
LIB_DEPENDS+= enchant:${PORTSDIR}/textproc/enchant
PLIST_SUB+= ENCHANT_SUPPORT=""
@@ -76,7 +74,7 @@ CONFIGURE_ARGS+= --disable-enchant-support
PLIST_SUB+= ENCHANT_SUPPORT="@comment "
.endif
-.if defined(WITH_MATROSKA)
+.if ${PORT_OPTIONS:MMATROSKA}
CONFIGURE_ARGS+= --enable-mkv-support
RUN_DEPENDS+= mkvmerge:${PORTSDIR}/multimedia/mkvtoolnix
PLIST_SUB+= MATROSKA_SUPPORT=""
@@ -85,16 +83,16 @@ CONFIGURE_ARGS+= --disable-mkv-support
PLIST_SUB+= MATROSKA_SUPPORT="@comment "
.endif
-.if defined(WITH_MP4)
+.if ${PORT_OPTIONS:MMP4BOX}
CONFIGURE_ARGS+= --enable-mp4-support
RUN_DEPENDS+= mp4box:${PORTSDIR}/multimedia/gpac-mp4box
-PLIST_SUB+= MP4_SUPPORT=""
+PLIST_SUB+= MP4BOX_SUPPORT=""
.else
CONFIGURE_ARGS+= --disable-mp4-support
-PLIST_SUB+= MP4_SUPPORT="@comment "
+PLIST_SUB+= MP4BOX_SUPPORT="@comment "
.endif
-.if defined(WITH_THEORA)
+.if ${PORT_OPTIONS:MTHEORA}
CONFIGURE_ARGS+= --enable-theora-support
LIB_DEPENDS+= theora:${PORTSDIR}/multimedia/libtheora
PLIST_SUB+= THEORA_SUPPORT=""
@@ -103,7 +101,7 @@ CONFIGURE_ARGS+= --disable-theora-support
PLIST_SUB+= THEORA_SUPPORT="@comment "
.endif
-.if defined(WITH_FAAC)
+.if ${PORT_OPTIONS:MFAAC}
CONFIGURE_ARGS+= --enable-aac-support
RUN_DEPENDS+= faac:${PORTSDIR}/audio/faac
PLIST_SUB+= FAAC_SUPPORT=""
@@ -112,7 +110,7 @@ CONFIGURE_ARGS+= --disable-aac-support
PLIST_SUB+= FAAC_SUPPORT="@comment "
.endif
-.if defined(WITH_SRT)
+.if ${PORT_OPTIONS:MSRT}
CONFIGURE_ARGS+= --enable-srt-support
RUN_DEPENDS+= gocr:${PORTSDIR}/graphics/gocr
MAN1+= subp2pgm.1 subptools.1
@@ -122,7 +120,7 @@ CONFIGURE_ARGS+= --disable-srt-support
PLIST_SUB+= SRT_SUPPORT="@comment "
.endif
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-maintainer-mode --enable-devel-mode
.endif
@@ -146,4 +144,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG} ""
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/ogmrip/distinfo b/multimedia/ogmrip/distinfo
index 3e97a629c83d..95fa0fefbd37 100644
--- a/multimedia/ogmrip/distinfo
+++ b/multimedia/ogmrip/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ogmrip-0.13.7.tar.gz) = 362060e4c1944f020f9a491d9a8af53cd3bf4f94d4f5beb8d3d855ebf17d9c2a
-SIZE (ogmrip-0.13.7.tar.gz) = 3246395
+SHA256 (ogmrip-0.13.8.tar.gz) = ea6a75e6cc4fe7df1ed65648af208c87748959a6b372847b1005c3b92cc5a423
+SIZE (ogmrip-0.13.8.tar.gz) = 3254176
diff --git a/multimedia/ogmrip/pkg-plist b/multimedia/ogmrip/pkg-plist
index baf177867485..03cb423344f2 100644
--- a/multimedia/ogmrip/pkg-plist
+++ b/multimedia/ogmrip/pkg-plist
@@ -1,30 +1,30 @@
bin/avibox
bin/dvdcpy
-%%GUI_SUPPORT%%bin/ogmrip
+%%GTK2_SUPPORT%%bin/ogmrip
%%SRT_SUPPORT%%bin/subp2pgm
%%SRT_SUPPORT%%bin/subp2png
%%SRT_SUPPORT%%bin/subp2tiff
%%SRT_SUPPORT%%bin/subptools
%%THEORA_SUPPORT%%bin/theoraenc
include/ogmdvd/ogmdvd-audio.h
-%%GUI_SUPPORT%%include/ogmdvd/ogmdvd-cell-renderer-language.h
-%%GUI_SUPPORT%%include/ogmdvd/ogmdvd-chapter-list.h
+%%GTK2_SUPPORT%%include/ogmdvd/ogmdvd-cell-renderer-language.h
+%%GTK2_SUPPORT%%include/ogmdvd/ogmdvd-chapter-list.h
include/ogmdvd/ogmdvd-disc.h
-%%GUI_SUPPORT%%include/ogmdvd/ogmdvd-drive-chooser-dialog.h
-%%GUI_SUPPORT%%include/ogmdvd/ogmdvd-drive-chooser-widget.h
-%%GUI_SUPPORT%%include/ogmdvd/ogmdvd-drive-chooser.h
+%%GTK2_SUPPORT%%include/ogmdvd/ogmdvd-drive-chooser-dialog.h
+%%GTK2_SUPPORT%%include/ogmdvd/ogmdvd-drive-chooser-widget.h
+%%GTK2_SUPPORT%%include/ogmdvd/ogmdvd-drive-chooser.h
include/ogmdvd/ogmdvd-drive.h
include/ogmdvd/ogmdvd-enums.h
-%%GUI_SUPPORT%%include/ogmdvd/ogmdvd-gtk.h
+%%GTK2_SUPPORT%%include/ogmdvd/ogmdvd-gtk.h
include/ogmdvd/ogmdvd-labels.h
-%%GUI_SUPPORT%%include/ogmdvd/ogmdvd-marshal.h
+%%GTK2_SUPPORT%%include/ogmdvd/ogmdvd-marshal.h
include/ogmdvd/ogmdvd-monitor.h
include/ogmdvd/ogmdvd-parser.h
include/ogmdvd/ogmdvd-reader.h
include/ogmdvd/ogmdvd-stream.h
include/ogmdvd/ogmdvd-subp.h
-%%GUI_SUPPORT%%include/ogmdvd/ogmdvd-title-chooser-widget.h
-%%GUI_SUPPORT%%include/ogmdvd/ogmdvd-title-chooser.h
+%%GTK2_SUPPORT%%include/ogmdvd/ogmdvd-title-chooser-widget.h
+%%GTK2_SUPPORT%%include/ogmdvd/ogmdvd-title-chooser.h
include/ogmdvd/ogmdvd-title.h
include/ogmdvd/ogmdvd-types.h
include/ogmdvd/ogmdvd.h
@@ -39,9 +39,9 @@ include/ogmjob/ogmjob-queue.h
include/ogmjob/ogmjob-spawn.h
include/ogmjob/ogmjob.h
include/ogmrip/ogmrip-audio-codec.h
-%%GUI_SUPPORT%%include/ogmrip/ogmrip-chapter-list.h
+%%GTK2_SUPPORT%%include/ogmrip/ogmrip-chapter-list.h
include/ogmrip/ogmrip-chapters.h
-%%GUI_SUPPORT%%include/ogmrip/ogmrip-chooser-list.h
+%%GTK2_SUPPORT%%include/ogmrip/ogmrip-chooser-list.h
include/ogmrip/ogmrip-codec.h
include/ogmrip/ogmrip-container.h
include/ogmrip/ogmrip-dvdcpy.h
@@ -51,29 +51,29 @@ include/ogmrip/ogmrip-encoding.h
include/ogmrip/ogmrip-enums.h
include/ogmrip/ogmrip-file.h
include/ogmrip/ogmrip-fs.h
-%%GUI_SUPPORT%%include/ogmrip/ogmrip-gconf-settings.h
-%%GUI_SUPPORT%%include/ogmrip/ogmrip-gtk.h
+%%GTK2_SUPPORT%%include/ogmrip/ogmrip-gconf-settings.h
+%%GTK2_SUPPORT%%include/ogmrip/ogmrip-gtk.h
include/ogmrip/ogmrip-hardsub.h
-%%GUI_SUPPORT%%include/ogmrip/ogmrip-helper.h
+%%GTK2_SUPPORT%%include/ogmrip/ogmrip-helper.h
include/ogmrip/ogmrip-keyfile-settings.h
include/ogmrip/ogmrip-lavc.h
include/ogmrip/ogmrip-mplayer.h
include/ogmrip/ogmrip-novideo.h
-%%GUI_SUPPORT%%include/ogmrip/ogmrip-options-plugin.h
+%%GTK2_SUPPORT%%include/ogmrip/ogmrip-options-plugin.h
include/ogmrip/ogmrip-options.h
include/ogmrip/ogmrip-player.h
include/ogmrip/ogmrip-plugin.h
include/ogmrip/ogmrip-settings.h
-%%GUI_SUPPORT%%include/ogmrip/ogmrip-source-chooser-widget.h
-%%GUI_SUPPORT%%include/ogmrip/ogmrip-source-chooser.h
+%%GTK2_SUPPORT%%include/ogmrip/ogmrip-source-chooser-widget.h
+%%GTK2_SUPPORT%%include/ogmrip/ogmrip-source-chooser.h
include/ogmrip/ogmrip-subp-codec.h
include/ogmrip/ogmrip-version.h
include/ogmrip/ogmrip-video-codec.h
include/ogmrip/ogmrip.h
-%%GUI_SUPPORT%%lib/libogmdvd-gtk.a
-%%GUI_SUPPORT%%lib/libogmdvd-gtk.la
-%%GUI_SUPPORT%%lib/libogmdvd-gtk.so
-%%GUI_SUPPORT%%lib/libogmdvd-gtk.so.1
+%%GTK2_SUPPORT%%lib/libogmdvd-gtk.a
+%%GTK2_SUPPORT%%lib/libogmdvd-gtk.la
+%%GTK2_SUPPORT%%lib/libogmdvd-gtk.so
+%%GTK2_SUPPORT%%lib/libogmdvd-gtk.so.1
lib/libogmdvd.a
lib/libogmdvd.la
lib/libogmdvd.so
@@ -82,10 +82,10 @@ lib/libogmjob.a
lib/libogmjob.la
lib/libogmjob.so
lib/libogmjob.so.1
-%%GUI_SUPPORT%%lib/libogmrip-gtk.a
-%%GUI_SUPPORT%%lib/libogmrip-gtk.la
-%%GUI_SUPPORT%%lib/libogmrip-gtk.so
-%%GUI_SUPPORT%%lib/libogmrip-gtk.so.1
+%%GTK2_SUPPORT%%lib/libogmrip-gtk.a
+%%GTK2_SUPPORT%%lib/libogmrip-gtk.la
+%%GTK2_SUPPORT%%lib/libogmrip-gtk.so
+%%GTK2_SUPPORT%%lib/libogmrip-gtk.so.1
lib/libogmrip-lavc.a
lib/libogmrip-lavc.la
lib/libogmrip-lavc.so
@@ -122,21 +122,21 @@ lib/ogmrip/container-plugins/libogmrip-avi.so
lib/ogmrip/container-plugins/libogmrip-mov.a
lib/ogmrip/container-plugins/libogmrip-mov.la
lib/ogmrip/container-plugins/libogmrip-mov.so
-%%MP4_SUPPORT%%lib/ogmrip/container-plugins/libogmrip-mp4.a
-%%MP4_SUPPORT%%lib/ogmrip/container-plugins/libogmrip-mp4.la
-%%MP4_SUPPORT%%lib/ogmrip/container-plugins/libogmrip-mp4.so
+%%MP4BOX_SUPPORT%%lib/ogmrip/container-plugins/libogmrip-mp4.a
+%%MP4BOX_SUPPORT%%lib/ogmrip/container-plugins/libogmrip-mp4.la
+%%MP4BOX_SUPPORT%%lib/ogmrip/container-plugins/libogmrip-mp4.so
lib/ogmrip/container-plugins/libogmrip-ogg.a
lib/ogmrip/container-plugins/libogmrip-ogg.la
lib/ogmrip/container-plugins/libogmrip-ogg.so
-%%GUI_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-lavc-options.a
-%%GUI_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-lavc-options.la
-%%GUI_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-lavc-options.so
-%%GUI_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-x264-options.a
-%%GUI_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-x264-options.la
-%%GUI_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-x264-options.so
-%%GUI_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-xvid-options.a
-%%GUI_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-xvid-options.la
-%%GUI_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-xvid-options.so
+%%GTK2_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-lavc-options.a
+%%GTK2_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-lavc-options.la
+%%GTK2_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-lavc-options.so
+%%GTK2_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-x264-options.a
+%%GTK2_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-x264-options.la
+%%GTK2_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-x264-options.so
+%%GTK2_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-xvid-options.a
+%%GTK2_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-xvid-options.la
+%%GTK2_SUPPORT%%lib/ogmrip/options-plugins/libogmrip-xvid-options.so
%%SRT_SUPPORT%%lib/ogmrip/subp-plugins/libogmrip-srt.a
%%SRT_SUPPORT%%lib/ogmrip/subp-plugins/libogmrip-srt.la
%%SRT_SUPPORT%%lib/ogmrip/subp-plugins/libogmrip-srt.so
@@ -163,35 +163,35 @@ libdata/pkgconfig/ogmdvd.pc
libdata/pkgconfig/ogmjob.pc
libdata/pkgconfig/ogmrip-gtk.pc
libdata/pkgconfig/ogmrip.pc
-%%GUI_SUPPORT%%share/applications/ogmrip.desktop
+%%GTK2_SUPPORT%%share/applications/ogmrip.desktop
share/locale/cs/LC_MESSAGES/ogmrip.mo
share/locale/de/LC_MESSAGES/ogmrip.mo
share/locale/fr/LC_MESSAGES/ogmrip.mo
share/locale/nb/LC_MESSAGES/ogmrip.mo
share/locale/ru/LC_MESSAGES/ogmrip.mo
share/locale/sk/LC_MESSAGES/ogmrip.mo
-%%GUI_SUPPORT%%%%DATADIR%%/ogmrip-crop.glade
-%%GUI_SUPPORT%%%%DATADIR%%/ogmrip-lavc.glade
-%%GUI_SUPPORT%%%%DATADIR%%/ogmrip-main.glade
-%%GUI_SUPPORT%%%%DATADIR%%/ogmrip-options.glade
-%%GUI_SUPPORT%%%%DATADIR%%/ogmrip-pref.glade
-%%GUI_SUPPORT%%%%DATADIR%%/ogmrip-profile-editor.glade
-%%GUI_SUPPORT%%%%DATADIR%%/ogmrip-profiles.glade
-%%GUI_SUPPORT%%%%DATADIR%%/ogmrip-progress.glade
-%%GUI_SUPPORT%%%%DATADIR%%/ogmrip-queue.glade
-%%GUI_SUPPORT%%%%DATADIR%%/ogmrip-spell.glade
-%%GUI_SUPPORT%%%%DATADIR%%/ogmrip-ui.xml
-%%GUI_SUPPORT%%%%DATADIR%%/ogmrip-update.glade
-%%GUI_SUPPORT%%%%DATADIR%%/ogmrip-x264.glade
-%%GUI_SUPPORT%%%%DATADIR%%/ogmrip-xvid.glade
-%%GUI_SUPPORT%%%%DATADIR%%/profiles/profiles.xml
-%%GUI_SUPPORT%%share/pixmaps/ogmrip.png
-%%GUI_SUPPORT%%@dirrm %%DATADIR%%/profiles
-%%GUI_SUPPORT%%@dirrm %%DATADIR%%
-%%GUI_SUPPORT%%@dirrmtry share/applications
+%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-crop.glade
+%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-lavc.glade
+%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-main.glade
+%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-options.glade
+%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-pref.glade
+%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-profile-editor.glade
+%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-profiles.glade
+%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-progress.glade
+%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-queue.glade
+%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-spell.glade
+%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-ui.xml
+%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-update.glade
+%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-x264.glade
+%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-xvid.glade
+%%GTK2_SUPPORT%%%%DATADIR%%/profiles/profiles.xml
+%%GTK2_SUPPORT%%share/pixmaps/ogmrip.png
+%%GTK2_SUPPORT%%@dirrm %%DATADIR%%/profiles
+%%GTK2_SUPPORT%%@dirrm %%DATADIR%%
+%%GTK2_SUPPORT%%@dirrmtry share/applications
@dirrm lib/ogmrip/video-plugins
@dirrm lib/ogmrip/subp-plugins
-%%GUI_SUPPORT%%@dirrm lib/ogmrip/options-plugins
+%%GTK2_SUPPORT%%@dirrm lib/ogmrip/options-plugins
@dirrm lib/ogmrip/container-plugins
@dirrm lib/ogmrip/audio-plugins
@dirrm lib/ogmrip