aboutsummaryrefslogtreecommitdiff
path: root/multimedia/openquicktime/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-09-24 20:05:22 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-09-24 20:05:22 +0000
commit36f5ffb45f74a51650f25672142f81a289ef19d6 (patch)
tree8c86782a686dc30c2e1efea9516cd758ed86aa08 /multimedia/openquicktime/Makefile
parent54d7301e037aa39cf01abefce7d5fcff639927bb (diff)
downloadports-36f5ffb45f74a51650f25672142f81a289ef19d6.tar.gz
ports-36f5ffb45f74a51650f25672142f81a289ef19d6.zip
Notes
Diffstat (limited to 'multimedia/openquicktime/Makefile')
-rw-r--r--multimedia/openquicktime/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/multimedia/openquicktime/Makefile b/multimedia/openquicktime/Makefile
new file mode 100644
index 000000000000..476063450a13
--- /dev/null
+++ b/multimedia/openquicktime/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: openquicktime
+# Date created: Mon Sep 24 16:26:33 BRT 2001
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openquicktime
+PORTVERSION= 1.0
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= openquicktime
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= lioux@FreeBSD.org
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+
+GNU_CONFIGURE= yes
+USE_GTK= yes
+USE_GMAKE= yes
+INSTALL_SHLIBS= yes
+PKGDEINSTALL= ${PKGINSTALL}
+
+post-patch:
+ @${PERL} -pi -e "s/xCC/xc/" ${WRKSRC}/configure
+
+post-install:
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} \
+ ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>