aboutsummaryrefslogtreecommitdiff
path: root/multimedia/phonon-xine
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-03-09 00:55:48 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-03-09 00:55:48 +0000
commit4ac1397e9e6ce3f8a6ea7d461ece9db212fc9483 (patch)
tree9940a6f7cc2c390c9651e0ced0de687fa53b0764 /multimedia/phonon-xine
parentcc4b09fcc1b7aa6d9ea7bf5c49c796475ca734a8 (diff)
downloadports-4ac1397e9e6ce3f8a6ea7d461ece9db212fc9483.tar.gz
ports-4ac1397e9e6ce3f8a6ea7d461ece9db212fc9483.zip
Notes
Diffstat (limited to 'multimedia/phonon-xine')
-rw-r--r--multimedia/phonon-xine/Makefile35
-rw-r--r--multimedia/phonon-xine/distinfo3
-rw-r--r--multimedia/phonon-xine/files/patch-CMakeLists.txt51
-rw-r--r--multimedia/phonon-xine/files/patch-cmake__FindPhonon.cmake73
-rw-r--r--multimedia/phonon-xine/files/patch-xine__CMakeLists.txt19
-rw-r--r--multimedia/phonon-xine/pkg-descr2
-rw-r--r--multimedia/phonon-xine/pkg-plist11
7 files changed, 194 insertions, 0 deletions
diff --git a/multimedia/phonon-xine/Makefile b/multimedia/phonon-xine/Makefile
new file mode 100644
index 000000000000..44677ec3c5b5
--- /dev/null
+++ b/multimedia/phonon-xine/Makefile
@@ -0,0 +1,35 @@
+# New ports collection Makefile for: phonon
+# Date created: 2008-01-30
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= phonon
+PORTVERSION= 4.3.1
+CATEGORIES= multimedia kde ipv6
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
+PKGNAMESUFFIX= -xine
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Phonon xine backend
+
+LIB_DEPENDS= phonon.4:${PORTSDIR}/multimedia/phonon \
+ xine.1:${PORTSDIR}/multimedia/libxine
+
+CONFLICTS= phonon-4.3.0*
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_KDE4= kdehier automoc4 kdeprefix
+USE_QT_VER= 4
+QT_COMPONENTS= gui dbus xml \
+ qmake_build moc_build rcc_build uic_build
+
+post-patch:
+#fix finding automoc when PREFIX is not matched KDE4_PREFIX
+ ${REINPLACE_CMD} -e 's|NO_DEFAULT_PATH|${KDE4_PREFIX} NO_DEFAULT_PATH|' \
+ ${WRKSRC}/cmake/FindAutomoc4.cmake
+
+.include <bsd.port.mk>
diff --git a/multimedia/phonon-xine/distinfo b/multimedia/phonon-xine/distinfo
new file mode 100644
index 000000000000..7c88843e413a
--- /dev/null
+++ b/multimedia/phonon-xine/distinfo
@@ -0,0 +1,3 @@
+MD5 (KDE/phonon-4.3.1.tar.bz2) = 767cb68052c108e95f293f30acdef3fb
+SHA256 (KDE/phonon-4.3.1.tar.bz2) = 7fb6d9efad29d7ac390d539cd516177c26cc2f92ddb9b3a5d70f2c49fc15269a
+SIZE (KDE/phonon-4.3.1.tar.bz2) = 575856
diff --git a/multimedia/phonon-xine/files/patch-CMakeLists.txt b/multimedia/phonon-xine/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..a8327f774222
--- /dev/null
+++ b/multimedia/phonon-xine/files/patch-CMakeLists.txt
@@ -0,0 +1,51 @@
+--- ./CMakeLists.txt.orig 2009-01-22 11:20:44.000000000 +0300
++++ ./CMakeLists.txt 2009-02-21 01:22:02.000000000 +0300
+@@ -127,12 +127,12 @@
+
+ try_run(_run_result _compile_result ${CMAKE_BINARY_DIR} ${_source_file} CMAKE_FLAGS "${_include_dirs}")
+
+- if(NOT _compile_result)
+- message(FATAL_ERROR "Could not compile simple test program:\n ${_source}")
+- endif(NOT _compile_result)
+- if(_run_result)
+- message(FATAL_ERROR "Qt compiled without support for -fvisibility=hidden. This will break plugins and linking of some applications. Please fix your Qt installation.")
+- endif(_run_result)
++# if(NOT _compile_result)
++# message(FATAL_ERROR "Could not compile simple test program:\n ${_source}")
++# endif(NOT _compile_result)
++# if(_run_result)
++# message(FATAL_ERROR "Qt compiled without support for -fvisibility=hidden. This will break plugins and linking of some applications. Please fix your Qt installation.")
++# endif(_run_result)
+
+ if (GCC_IS_NEWER_THAN_4_2)
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility-inlines-hidden")
+@@ -250,8 +250,8 @@
+
+
+ add_subdirectory(cmake)
+-add_subdirectory(phonon)
+-add_subdirectory(includes)
++# add_subdirectory(phonon)
++# add_subdirectory(includes)
+ if (Q_WS_MAC AND BUILD_PHONON_QT7)
+ add_subdirectory(qt7)
+ endif (Q_WS_MAC AND BUILD_PHONON_QT7)
+@@ -260,13 +260,13 @@
+ endif (Q_WS_WIN)
+
+ if (Q_WS_X11)
+- add_subdirectory(gstreamer)
++# add_subdirectory(gstreamer)
+ add_subdirectory(xine)
+ endif (Q_WS_X11)
+
+-if(NOT WIN32) # pkgconfig file
+- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/phonon.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc @ONLY)
+- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
+-endif(NOT WIN32)
++# if(NOT WIN32) # pkgconfig file
++# configure_file(${CMAKE_CURRENT_SOURCE_DIR}/phonon.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc @ONLY)
++# install(FILES ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc DESTINATION ${LIB_INSTALL_DIR}/../libdata/../libdata/../libdata/../libdata/../libdata/pkgconfig)
++# endif(NOT WIN32)
+
+ macro_display_feature_log()
diff --git a/multimedia/phonon-xine/files/patch-cmake__FindPhonon.cmake b/multimedia/phonon-xine/files/patch-cmake__FindPhonon.cmake
new file mode 100644
index 000000000000..44c470dd884b
--- /dev/null
+++ b/multimedia/phonon-xine/files/patch-cmake__FindPhonon.cmake
@@ -0,0 +1,73 @@
+--- ./cmake/FindPhonon.cmake.orig 2009-02-21 01:19:39.000000000 +0300
++++ ./cmake/FindPhonon.cmake 2009-02-21 01:19:39.000000000 +0300
+@@ -0,0 +1,70 @@
++# Find libphonon
++# Once done this will define
++#
++# PHONON_FOUND - system has Phonon Library
++# PHONON_INCLUDES - the Phonon include directory
++# PHONON_LIBS - link these to use Phonon
++# PHONON_VERSION - the version of the Phonon Library
++
++# Copyright (c) 2008, Matthias Kretz <kretz@kde.org>
++#
++# Redistribution and use is allowed according to the terms of the BSD license.
++# For details see the accompanying COPYING-CMAKE-SCRIPTS file.
++
++macro(_phonon_find_version)
++ file(READ "${PHONON_INCLUDE_DIR}/phonon/phononnamespace.h" _phonon_header LIMIT 5000 OFFSET 1000)
++ string(REGEX MATCH "define PHONON_VERSION_STR \"(4\\.[0-9]+\\.[0-9a-z]+)\"" _phonon_version_match "${_phonon_header}")
++ set(PHONON_VERSION "${CMAKE_MATCH_1}")
++ message(STATUS "Phonon Version: ${PHONON_VERSION}")
++endmacro(_phonon_find_version)
++
++find_package(PkgConfig)
++PKG_CHECK_MODULES(PKG_PHONON phonon)
++
++if(PHONON_FOUND)
++ # Already found, nothing more to do except figuring out the version
++ _phonon_find_version()
++else(PHONON_FOUND)
++ if(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
++ set(PHONON_FIND_QUIETLY TRUE)
++ endif(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
++
++ # As discussed on kde-buildsystem: first look at CMAKE_PREFIX_PATH, then at the suggested PATHS (kde4 install dir)
++ find_library(PHONON_LIBRARY NAMES phonon PATHS ${PKG_PHONON_LIBRARY_DIRS} ${KDE4_PREFIX}/lib ${KDE4_LIB_INSTALL_DIR} ${QT_LIBRARY_DIR} NO_SYSTEM_ENVIRONMENT_PATH NO_CMAKE_SYSTEM_PATH)
++ # then at the default system locations (CMAKE_SYSTEM_PREFIX_PATH, i.e. /usr etc.)
++ find_library(PHONON_LIBRARY NAMES phonon)
++
++ find_path(PHONON_INCLUDE_DIR NAMES phonon/phonon_export.h PATHS ${PKG_PHONON_INCLUDE_DIRS} ${KDE4_PREFIX}/include ${KDE4_INCLUDE_INSTALL_DIR} ${QT_INCLUDE_DIR} ${INCLUDE_INSTALL_DIR} NO_SYSTEM_ENVIRONMENT_PATH NO_CMAKE_SYSTEM_PATH)
++ find_path(PHONON_INCLUDE_DIR NAMES phonon/phonon_export.h)
++
++ if(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
++ set(PHONON_LIBS ${phonon_LIB_DEPENDS} ${PHONON_LIBRARY})
++ set(PHONON_INCLUDES ${PHONON_INCLUDE_DIR}/KDE ${PHONON_INCLUDE_DIR}/phonon ${PHONON_INCLUDE_DIR})
++ set(PHONON_FOUND TRUE)
++ _phonon_find_version()
++ else(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
++ set(PHONON_FOUND FALSE)
++ endif(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
++
++ if(PHONON_FOUND)
++ if(NOT PHONON_FIND_QUIETLY)
++ message(STATUS "Found Phonon: ${PHONON_LIBRARY}")
++ message(STATUS "Found Phonon Includes: ${PHONON_INCLUDES}")
++ endif(NOT PHONON_FIND_QUIETLY)
++ else(PHONON_FOUND)
++ if(Phonon_FIND_REQUIRED)
++ if(NOT PHONON_INCLUDE_DIR)
++ message(STATUS "Phonon includes NOT found!")
++ endif(NOT PHONON_INCLUDE_DIR)
++ if(NOT PHONON_LIBRARY)
++ message(STATUS "Phonon library NOT found!")
++ endif(NOT PHONON_LIBRARY)
++ message(FATAL_ERROR "Phonon library or includes NOT found!")
++ else(Phonon_FIND_REQUIRED)
++ message(STATUS "Unable to find Phonon")
++ endif(Phonon_FIND_REQUIRED)
++ endif(PHONON_FOUND)
++
++
++ mark_as_advanced(PHONON_INCLUDE_DIR PHONON_LIBRARY PHONON_INCLUDES)
++endif(PHONON_FOUND)
diff --git a/multimedia/phonon-xine/files/patch-xine__CMakeLists.txt b/multimedia/phonon-xine/files/patch-xine__CMakeLists.txt
new file mode 100644
index 000000000000..a36be59bb980
--- /dev/null
+++ b/multimedia/phonon-xine/files/patch-xine__CMakeLists.txt
@@ -0,0 +1,19 @@
+--- ./xine/CMakeLists.txt.orig 2009-01-08 17:47:18.000000000 +0300
++++ ./xine/CMakeLists.txt 2009-02-21 01:19:39.000000000 +0300
+@@ -27,6 +27,7 @@
+ endif (NOT _OFFT_IS_64BIT)
+ endif (UNIX)
+
++find_package(Phonon)
+ macro_optional_find_package(Xine)
+ macro_optional_find_package(XCB)
+
+@@ -97,7 +98,7 @@
+
+
+ if(XINE_FOUND)
+- include_directories(${XINE_INCLUDE_DIR})
++ include_directories(${PHONON_INCLUDES} ${XINE_INCLUDE_DIR})
+
+ configure_file(config-xine-widget.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-xine-widget.h )
+
diff --git a/multimedia/phonon-xine/pkg-descr b/multimedia/phonon-xine/pkg-descr
new file mode 100644
index 000000000000..e3459ceb600e
--- /dev/null
+++ b/multimedia/phonon-xine/pkg-descr
@@ -0,0 +1,2 @@
+Phonon is multimedia framework for KDE4.
+This port provides xine backend.
diff --git a/multimedia/phonon-xine/pkg-plist b/multimedia/phonon-xine/pkg-plist
new file mode 100644
index 000000000000..2fce39cc3232
--- /dev/null
+++ b/multimedia/phonon-xine/pkg-plist
@@ -0,0 +1,11 @@
+lib/kde4/plugins/phonon_backend/phonon_xine.so
+share/icons/oxygen/128x128/apps/phonon-xine.png
+share/icons/oxygen/16x16/apps/phonon-xine.png
+share/icons/oxygen/22x22/apps/phonon-xine.png
+share/icons/oxygen/32x32/apps/phonon-xine.png
+share/icons/oxygen/48x48/apps/phonon-xine.png
+share/icons/oxygen/64x64/apps/phonon-xine.png
+share/icons/oxygen/scalable/apps/phonon-xine.svgz
+share/kde4/services/phononbackends/xine.desktop
+@dirrmtry share/kde4/services/phononbackends
+@dirrmtry lib/kde4/plugins/phonon_backend