aboutsummaryrefslogtreecommitdiff
path: root/multimedia/phonon/files/patch-CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-09 16:52:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-09 16:52:28 +0000
commit568f8e877fb50618d4813b943d712e3bc08fd147 (patch)
tree16eef3a555a802ca06d05606c7f2a75ccbc6a431 /multimedia/phonon/files/patch-CMakeLists.txt
parentbdcf355d6dedb8678255a8053a2b423f9cc7cc6c (diff)
downloadports-568f8e877fb50618d4813b943d712e3bc08fd147.tar.gz
ports-568f8e877fb50618d4813b943d712e3bc08fd147.zip
Notes
Diffstat (limited to 'multimedia/phonon/files/patch-CMakeLists.txt')
-rw-r--r--multimedia/phonon/files/patch-CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/multimedia/phonon/files/patch-CMakeLists.txt b/multimedia/phonon/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..41f604aaad52
--- /dev/null
+++ b/multimedia/phonon/files/patch-CMakeLists.txt
@@ -0,0 +1,21 @@
+--- ../CMakeLists.txt.orgi 2008-07-25 14:58:35.000000000 +0200
++++ ../CMakeLists.txt 2008-07-25 14:59:12.000000000 +0200
+@@ -120,12 +120,12 @@
+
+ try_run(_run_result _compile_result ${CMAKE_BINARY_DIR} ${_source_file} CMAKE_FLAGS "${_include_dirs}")
+
+- if(NOT _compile_result)
+- message(FATAL_ERROR "Could not compile simple test program:\n ${_source}")
+- endif(NOT _compile_result)
+- if(_run_result)
+- message(FATAL_ERROR "Qt compiled without support for -fvisibility=hidden. This will break plugins and linking of some applications. Please fix your Qt installation.")
+- endif(_run_result)
++# if(NOT _compile_result)
++# message(FATAL_ERROR "Could not compile simple test program:\n ${_source}")
++# endif(NOT _compile_result)
++# if(_run_result)
++# message(FATAL_ERROR "Qt compiled without support for -fvisibility=hidden. This will break plugins and linking of some applications. Please fix your Qt installation.")
++# endif(_run_result)
+
+ if (GCC_IS_NEWER_THAN_4_2)
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility-inlines-hidden")