aboutsummaryrefslogtreecommitdiff
path: root/multimedia/phonon/files/patch-CMakeLists.txt
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2011-11-15 01:33:38 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2011-11-15 01:33:38 +0000
commitfee457bee0fe1e70c99235acc78b530e264d5350 (patch)
tree353edb1f6279407aeb98368a7021fb8d691b067a /multimedia/phonon/files/patch-CMakeLists.txt
parent46333cf9e3c84d20e4f3231cd55cfb9e96154bdb (diff)
downloadports-fee457bee0fe1e70c99235acc78b530e264d5350.tar.gz
ports-fee457bee0fe1e70c99235acc78b530e264d5350.zip
Notes
Diffstat (limited to 'multimedia/phonon/files/patch-CMakeLists.txt')
-rw-r--r--multimedia/phonon/files/patch-CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/multimedia/phonon/files/patch-CMakeLists.txt b/multimedia/phonon/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..9d6f2b74f048
--- /dev/null
+++ b/multimedia/phonon/files/patch-CMakeLists.txt
@@ -0,0 +1,30 @@
+commit 353bf15657c9a93138bce7431c5180b25efaede7
+Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
+Date: Mon Nov 14 19:14:02 2011 -0200
+
+ Fix if() clause the same way 13ec1718 does.
+
+ QT_QTDESIGNER_FOUND should not be expanded, as if it is not found the if
+ clause will effectively become `if(AND PHONON_BUILD_DESIGNER_PLUGIN)`.
+
+ This was fixed in master by commit 13ec1718, which for some reason has
+ never made its way to the 4.5 branch.
+
+ CCMAIL: kde-multimedia@kde.org
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7fbb816..71cb14a 100644
+--- ./CMakeLists.txt
++++ ./CMakeLists.txt
+@@ -55,9 +55,9 @@ endif(QT_QTDBUS_FOUND)
+ set(BUILDSYSTEM_INSTALL_DIR ${SHARE_INSTALL_PREFIX}/phonon-buildsystem/)
+
+ add_subdirectory(cmake)
+-if(${QT_QTDESIGNER_FOUND} AND PHONON_BUILD_DESIGNER_PLUGIN)
++if(QT_QTDESIGNER_FOUND AND PHONON_BUILD_DESIGNER_PLUGIN)
+ add_subdirectory(designer)
+-endif(${QT_QTDESIGNER_FOUND} AND PHONON_BUILD_DESIGNER_PLUGIN)
++endif(QT_QTDESIGNER_FOUND AND PHONON_BUILD_DESIGNER_PLUGIN)
+ add_subdirectory(phonon)
+ add_subdirectory(includes)
+ if(PHONON_BUILD_DEMOS)