aboutsummaryrefslogtreecommitdiff
path: root/multimedia/phonon
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-03-25 10:14:53 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-03-25 10:14:53 +0000
commitccd7c5cb51b94b642004686079f4244d6eb1f0d1 (patch)
tree0ef43adf034a830b4d08842bd2cad5030e1f29b9 /multimedia/phonon
parent6951a4e2684cc1085bc30b0ac843f4feadbde7db (diff)
Notes
Diffstat (limited to 'multimedia/phonon')
-rw-r--r--multimedia/phonon/Makefile6
-rw-r--r--multimedia/phonon/distinfo5
-rw-r--r--multimedia/phonon/files/patch-CMakeLists.txt32
-rw-r--r--multimedia/phonon/pkg-message5
-rw-r--r--multimedia/phonon/pkg-plist17
5 files changed, 25 insertions, 40 deletions
diff --git a/multimedia/phonon/Makefile b/multimedia/phonon/Makefile
index d1ecce4c0970..df05245ad39e 100644
--- a/multimedia/phonon/Makefile
+++ b/multimedia/phonon/Makefile
@@ -5,16 +5,16 @@
# $FreeBSD$
PORTNAME= phonon
-PORTVERSION= 4.4.2
+PORTVERSION= 4.4.4
CATEGORIES= multimedia kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= ${PHONON_BRANCH}/${PORTNAME}/${PORTVERSION}/
+MASTER_SITE_SUBDIR= ${PHONON_BRANCH}/${PORTNAME}/${PORTVERSION}/src/
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Multimedia framework for KDE4
-CONFLICTS= qt4-phonon-4* kdebase-runtime-4.1.[0-4]*
+CONFLICTS= qt4-phonon-4*
PHONON_BRANCH= stable
USE_BZIP2= yes
diff --git a/multimedia/phonon/distinfo b/multimedia/phonon/distinfo
index 5a88286e5da7..77acacd2f4e3 100644
--- a/multimedia/phonon/distinfo
+++ b/multimedia/phonon/distinfo
@@ -1,3 +1,2 @@
-MD5 (KDE/phonon-4.4.2.tar.bz2) = d9eab28383783261254f1cef3b92a3fa
-SHA256 (KDE/phonon-4.4.2.tar.bz2) = f1404c3f326201b382c26ba37f2d885d30bc71ba5fd8e1479afb632f92d93486
-SIZE (KDE/phonon-4.4.2.tar.bz2) = 629193
+SHA256 (KDE/phonon-4.4.4.tar.bz2) = 4c1d74eb06d58757bd2d81c29a3e9e86ff2e0751c8b4beec5a3365dda34d85f6
+SIZE (KDE/phonon-4.4.4.tar.bz2) = 362249
diff --git a/multimedia/phonon/files/patch-CMakeLists.txt b/multimedia/phonon/files/patch-CMakeLists.txt
deleted file mode 100644
index a3b0e7e15147..000000000000
--- a/multimedia/phonon/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,32 +0,0 @@
---- ./CMakeLists.txt.orig 2009-01-22 11:20:44.000000000 +0300
-+++ ./CMakeLists.txt 2009-02-21 01:36:17.000000000 +0300
-@@ -127,12 +127,12 @@
-
- try_run(_run_result _compile_result ${CMAKE_BINARY_DIR} ${_source_file} CMAKE_FLAGS "${_include_dirs}")
-
-- if(NOT _compile_result)
-- message(FATAL_ERROR "Could not compile simple test program:\n ${_source}")
-- endif(NOT _compile_result)
-- if(_run_result)
-- message(FATAL_ERROR "Qt compiled without support for -fvisibility=hidden. This will break plugins and linking of some applications. Please fix your Qt installation.")
-- endif(_run_result)
-+# if(NOT _compile_result)
-+# message(FATAL_ERROR "Could not compile simple test program:\n ${_source}")
-+# endif(NOT _compile_result)
-+# if(_run_result)
-+# message(FATAL_ERROR "Qt compiled without support for -fvisibility=hidden. This will break plugins and linking of some applications. Please fix your Qt installation.")
-+# endif(_run_result)
-
- if (GCC_IS_NEWER_THAN_4_2)
- set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility-inlines-hidden")
-@@ -260,8 +260,8 @@
- endif (Q_WS_WIN)
-
- if (Q_WS_X11)
-- add_subdirectory(gstreamer)
-- add_subdirectory(xine)
-+# add_subdirectory(gstreamer)
-+# add_subdirectory(xine)
- endif (Q_WS_X11)
-
- if(NOT WIN32) # pkgconfig file
diff --git a/multimedia/phonon/pkg-message b/multimedia/phonon/pkg-message
index 3aaf6ee5f229..c30d21f30391 100644
--- a/multimedia/phonon/pkg-message
+++ b/multimedia/phonon/pkg-message
@@ -1,3 +1,4 @@
Please consider to install backends for phonon:
-- Xine backend (multimedia/phonon-xine) and/or
-- Gstreamer backend (multimedia/phonon-gstreamer)
+multimedia/phonon-gstreamer Gstreamer backend
+multimedia/phonon-vlc VLC backend
+multimedia/phonon-xine Xine backend
diff --git a/multimedia/phonon/pkg-plist b/multimedia/phonon/pkg-plist
index 5e46b6707fb8..a01ec4486366 100644
--- a/multimedia/phonon/pkg-plist
+++ b/multimedia/phonon/pkg-plist
@@ -81,6 +81,8 @@ include/phonon/SeekSlider
include/phonon/StreamInterface
include/phonon/SubtitleDescription
include/phonon/SubtitleDescriptionModel
+include/phonon/VideoCaptureDevice
+include/phonon/VideoCaptureDeviceModel
include/phonon/VideoPlayer
include/phonon/VideoWidget
include/phonon/VideoWidgetInterface
@@ -109,6 +111,7 @@ include/phonon/experimental/audiodataoutput.h
include/phonon/experimental/audiodataoutputinterface.h
include/phonon/experimental/audioformat.h
include/phonon/experimental/avcapture.h
+include/phonon/experimental/avcaptureinterface.h
include/phonon/experimental/backendcapabilities.h
include/phonon/experimental/backendinterface.h
include/phonon/experimental/export.h
@@ -156,6 +159,18 @@ lib/libphononexperimental.so.4
lib/libphononexperimental.so.4.4.0
libdata/pkgconfig/phonon.pc
share/dbus-1/interfaces/org.kde.Phonon.AudioOutput.xml
+share/phonon-buildsystem/FindAutomoc4.cmake
+share/phonon-buildsystem/FindPackageHandleStandardArgs.cmake
+share/phonon-buildsystem/FindPhonon.cmake
+share/phonon-buildsystem/FindPhononInternal.cmake
+share/phonon-buildsystem/FindQt4.cmake
+share/phonon-buildsystem/MacroEnsureVersion.cmake
+share/phonon-buildsystem/MacroLogFeature.cmake
+share/phonon-buildsystem/MacroOptionalFindPackage.cmake
+share/phonon-buildsystem/MacroPushRequiredVars.cmake
+share/phonon-buildsystem/PhononMacros.cmake
+share/phonon-buildsystem/cmake_uninstall.cmake.in
+@dirrm share/phonon-buildsystem
@dirrm include/phonon/experimental
@dirrm include/phonon
@dirrm include/KDE/Phonon/Experimental
@@ -167,3 +182,5 @@ share/dbus-1/interfaces/org.kde.Phonon.AudioOutput.xml
%%QT_LIBDIR_REL%%/libphonon.so.4
%%QT_LIBDIR_REL%%/libphononexperimental.so
%%QT_LIBDIR_REL%%/libphononexperimental.so.4
+share/qt4/mkspecs/modules/qt_phonon.pri
+@dirrmtry share/qt4/mkspecs/modules