aboutsummaryrefslogtreecommitdiff
path: root/multimedia/py-ffmpeg
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2017-07-31 19:39:07 +0000
committerRene Ladan <rene@FreeBSD.org>2017-07-31 19:39:07 +0000
commitc6c3afa7e01e523c9f6a54320b3dd930f1308d01 (patch)
tree2df9e518627517f7c114d53c7148e91be89d6109 /multimedia/py-ffmpeg
parent20f9ef44a2bc886bc2719a512b1f6cfab7591f34 (diff)
Notes
Diffstat (limited to 'multimedia/py-ffmpeg')
-rw-r--r--multimedia/py-ffmpeg/Makefile37
-rw-r--r--multimedia/py-ffmpeg/distinfo3
-rw-r--r--multimedia/py-ffmpeg/files/patch-ffmpeg___ffmpeg.pxi37
-rw-r--r--multimedia/py-ffmpeg/files/patch-ffmpeg___ffmpeg.pyx92
-rw-r--r--multimedia/py-ffmpeg/files/patch-setup.py32
-rw-r--r--multimedia/py-ffmpeg/pkg-descr5
6 files changed, 0 insertions, 206 deletions
diff --git a/multimedia/py-ffmpeg/Makefile b/multimedia/py-ffmpeg/Makefile
deleted file mode 100644
index 432b271c5b43..000000000000
--- a/multimedia/py-ffmpeg/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-# Created by: David Naylor <dbn@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= ffmpeg
-PORTVERSION= 1.2.4
-PORTREVISION= 6
-CATEGORIES= multimedia python
-MASTER_SITES= GH LOCAL/dbn/${PORTNAME}
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-
-MAINTAINER= dbn@FreeBSD.org
-COMMENT= Python bindings for FFmpeg
-
-LICENSE= LGPL20 LGPL21 LGPL3
-LICENSE_COMB= dual
-
-BUILD_DEPENDS= cython:lang/cython
-LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
-
-DEPRECATED= Depreciated upstream in favour of ffpyplayer
-EXPIRATION_DATE=2017-06-30
-
-MAKE_ENV= FFMPEG_LIBRARIES="SDL SDL_mixer" FFMPEG_LIBRARY_DIRS=${LOCALBASE}/lib \
- FFMPEG_INCLUDES=${LOCALBASE}/include/SDL FFMPEG_ROOT=${LOCALBASE}
-GH_ACCOUNT= tito
-GH_PROJECT= ${PORTNAME}-android
-GH_TAGNAME= 6636c3a
-USE_GITHUB= yes
-USES= python
-USE_PYTHON= autoplist concurrent distutils
-USE_SDL= mixer
-WRKSRC_SUBDIR= python
-
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/ffmpeg/_ffmpeg.so
-
-.include <bsd.port.mk>
diff --git a/multimedia/py-ffmpeg/distinfo b/multimedia/py-ffmpeg/distinfo
deleted file mode 100644
index 56cde9c26f95..000000000000
--- a/multimedia/py-ffmpeg/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1491860248
-SHA256 (tito-ffmpeg-android-1.2.4-6636c3a_GH0.tar.gz) = 99d5ddac072b1ebed606dc453f82577043b30783af4610fc80ebeb5beb14e68d
-SIZE (tito-ffmpeg-android-1.2.4-6636c3a_GH0.tar.gz) = 7379991
diff --git a/multimedia/py-ffmpeg/files/patch-ffmpeg___ffmpeg.pxi b/multimedia/py-ffmpeg/files/patch-ffmpeg___ffmpeg.pxi
deleted file mode 100644
index 5fd1fb4dc712..000000000000
--- a/multimedia/py-ffmpeg/files/patch-ffmpeg___ffmpeg.pxi
+++ /dev/null
@@ -1,37 +0,0 @@
---- ffmpeg/_ffmpeg.pxi.orig 2013-10-28 16:04:02 UTC
-+++ ffmpeg/_ffmpeg.pxi
-@@ -35,6 +35,7 @@ cdef extern from "libavcodec/avcodec.h"
- unsigned char **data
- int *linesize
- int64_t pts
-+ int64_t pkt_pts;
- int repeat_pict
- int nb_samples
- int format
-@@ -53,8 +54,6 @@ cdef extern from "libavcodec/avcodec.h"
- int channels
- AVCodec *codec
- AVMediaType codec_type
-- int (*get_buffer)(AVCodecContext *c, AVFrame *pic)
-- void (*release_buffer)(AVCodecContext *c, AVFrame *pic)
- AVRational time_base
- AVSampleFormat sample_fmt
- struct AVPicture:
-@@ -83,7 +82,7 @@ cdef extern from "libavcodec/avcodec.h"
- ctypedef int (*lockmgr_t)(void **mutex, AVLockOp op)
- int av_lockmgr_register(lockmgr_t cb)
-
-- AVFrame *avcodec_alloc_frame()
-+ AVFrame *av_frame_alloc()
- int avcodec_decode_video2(AVCodecContext *avctx, AVFrame *picture,
- int *got_picture_ptr, AVPacket *avpkt)
- int avcodec_decode_audio4(AVCodecContext *avctx, AVFrame *frame, int
-@@ -100,7 +99,7 @@ cdef extern from "libavcodec/avcodec.h"
- int avcodec_default_get_buffer(AVCodecContext *s, AVFrame *pic)
- void avcodec_default_release_buffer(AVCodecContext *s, AVFrame *pic)
-
-- void avcodec_get_frame_defaults(AVFrame *)
-+ void av_frame_unref(AVFrame *)
-
- cdef extern from "libavresample/avresample.h" nogil:
- struct ResampleContext:
diff --git a/multimedia/py-ffmpeg/files/patch-ffmpeg___ffmpeg.pyx b/multimedia/py-ffmpeg/files/patch-ffmpeg___ffmpeg.pyx
deleted file mode 100644
index a1071885a891..000000000000
--- a/multimedia/py-ffmpeg/files/patch-ffmpeg___ffmpeg.pyx
+++ /dev/null
@@ -1,92 +0,0 @@
---- ffmpeg/_ffmpeg.pyx.orig 2013-10-28 16:04:02 UTC
-+++ ffmpeg/_ffmpeg.pyx
-@@ -81,8 +81,6 @@ DEF FF_REFRESH_EVENT = 2
- DEF FF_QUIT_EVENT = 3
- DEF FF_SCHEDULE_EVENT = 4
-
--cdef uint64_t global_video_pkt_pts = AV_NOPTS_VALUE
--
- ctypedef void (*event_callback_t)(void *)
-
- cdef struct Event:
-@@ -518,11 +516,11 @@ cdef int audio_decode_frame(VideoState *
- got_frame = 0
-
- if frame == NULL:
-- frame = avcodec_alloc_frame()
-+ frame = av_frame_alloc()
- if frame == NULL:
- return -1
- else:
-- avcodec_get_frame_defaults(frame)
-+ av_frame_unref(frame)
-
- len1 = avcodec_decode_audio4(vs.audio_st.codec,
- frame, &got_frame, pkt)
-@@ -784,7 +782,7 @@ cdef void alloc_picture(void *userdata)
-
- vp.ff_data_size = avpicture_get_size(PF_RGB24, vp.width, vp.height)
- vp.ff_data = <unsigned char *>av_malloc(vp.ff_data_size * sizeof(unsigned char))
-- vp.bmp = avcodec_alloc_frame()
-+ vp.bmp = av_frame_alloc()
- avpicture_fill(<AVPicture *>vp.bmp, vp.ff_data, PF_RGB24,
- vp.width, vp.height)
-
-@@ -886,19 +884,6 @@ cdef double synchronize_video(VideoState
- return pts
-
-
--cdef int our_get_buffer(AVCodecContext *c, AVFrame *pic) nogil:
-- cdef int ret = avcodec_default_get_buffer(c, pic)
-- cdef uint64_t *pts = <uint64_t*>av_malloc(sizeof(uint64_t))
-- memcpy(pts, &global_video_pkt_pts, sizeof(uint64_t))
-- pic.opaque = pts
-- return ret
--
--
--cdef void our_release_buffer(AVCodecContext *c, AVFrame *pic) nogil:
-- if pic != NULL: av_freep(&pic.opaque)
-- avcodec_default_release_buffer(c, pic)
--
--
- cdef int video_thread(void *arg) nogil:
- cdef VideoState *vs = <VideoState *>arg
- cdef AVPacket pkt1, *packet = &pkt1
-@@ -906,7 +891,7 @@ cdef int video_thread(void *arg) nogil:
- cdef AVFrame *pFrame
- cdef double pts, ptst = 0
-
-- pFrame = avcodec_alloc_frame()
-+ pFrame = av_frame_alloc()
-
- while True:
- if packet_queue_get(&vs.videoq, packet, 1) < 0:
-@@ -919,16 +904,13 @@ cdef int video_thread(void *arg) nogil:
-
- pts = 0
-
-- # Save global pts to be stored in pFrame
-- global_video_pkt_pts = packet.pts
- # Decode video frame
- with gil:
- len1 = avcodec_decode_video2(
- vs.video_st.codec, pFrame, &frameFinished, packet)
-- if packet.dts == AV_NOPTS_VALUE and pFrame.opaque:
-- memcpy(&ptst, pFrame.opaque, sizeof(uint64_t))
-- if ptst != AV_NOPTS_VALUE:
-- pts = ptst
-+ if packet.dts == AV_NOPTS_VALUE:
-+ if pFrame.pkt_pts != AV_NOPTS_VALUE:
-+ pts = pFrame.pkt_pts
- elif packet.dts != AV_NOPTS_VALUE:
- pts = packet.dts
- else:
-@@ -1038,8 +1020,6 @@ cdef int stream_component_open(VideoStat
-
- packet_queue_init(&vs.videoq)
- vs.video_tid = SDL_CreateThread(video_thread, vs)
-- codecCtx.get_buffer = our_get_buffer
-- codecCtx.release_buffer = our_release_buffer
-
- else:
- pass
diff --git a/multimedia/py-ffmpeg/files/patch-setup.py b/multimedia/py-ffmpeg/files/patch-setup.py
deleted file mode 100644
index b7f183db7026..000000000000
--- a/multimedia/py-ffmpeg/files/patch-setup.py
+++ /dev/null
@@ -1,32 +0,0 @@
---- setup.py.orig 2013-10-28 18:04:02.000000000 +0200
-+++ setup.py 2014-01-22 21:29:49.000000000 +0200
-@@ -15,7 +15,7 @@
- library_dirs = []
- include_dirs = []
- extra_objects = []
--extra_compile_args=['-ggdb', '-O0']
-+extra_compile_args=['-fPIC']
-
- ext_files = ['ffmpeg/_ffmpeg.pyx']
- root_ffmpeg = environ.get('FFMPEG_ROOT')
-@@ -29,14 +29,13 @@
- if environ.get('FFMPEG_LIBRARY_DIRS'):
- library_dirs += environ.get('FFMPEG_LIBRARY_DIRS').split(' ')
- libraries = environ.get('FFMPEG_LIBRARIES', 'gcc z sdl sdl_mixer m').split(' ')
-- extra_compile_args = ['-ggdb', '-O0']
- p = join(root_ffmpeg, 'lib')
-- extra_objects = [
-- join(p, 'libavformat.a'),
-- join(p, 'libavcodec.a'),
-- join(p, 'libswscale.a'),
-- join(p, 'libavresample.a'),
-- join(p, 'libavutil.a')]
-+ libraries += [
-+ 'avformat',
-+ 'avcodec',
-+ 'swscale',
-+ 'avresample',
-+ 'avutil']
-
- elif not have_cython:
- # Special hack for PGS4A-android, should we deprecated it ?
diff --git a/multimedia/py-ffmpeg/pkg-descr b/multimedia/py-ffmpeg/pkg-descr
deleted file mode 100644
index 6591ddb3a4d7..000000000000
--- a/multimedia/py-ffmpeg/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-py-ffmpeg includes a specific Python wrapper to decode audio / video,
-implemented to be as portable as possible. The goal is to use it for a
-core provider in the Kivy project, on android platform.
-
-WWW: http://txzone.net/