aboutsummaryrefslogtreecommitdiff
path: root/multimedia/py-librtmp
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-06-20 17:05:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-06-20 17:05:41 +0000
commit4376dbbb58dab5a7bf7a8240ca39b562de78343b (patch)
tree8997a738fc5162cf5f1383dd3c61c0423454979b /multimedia/py-librtmp
parent6cb7ca00bb0a9a3aa67008824300ee8d16203a1b (diff)
downloadports-4376dbbb58dab5a7bf7a8240ca39b562de78343b.tar.gz
ports-4376dbbb58dab5a7bf7a8240ca39b562de78343b.zip
Use PY_FLAVOR for dependencies.
FLAVOR is the current port's flavor, it should not be used outside of this scope. Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=472884
Diffstat (limited to 'multimedia/py-librtmp')
-rw-r--r--multimedia/py-librtmp/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/multimedia/py-librtmp/Makefile b/multimedia/py-librtmp/Makefile
index 202b8e308531..8dac1f4d4001 100644
--- a/multimedia/py-librtmp/Makefile
+++ b/multimedia/py-librtmp/Makefile
@@ -15,8 +15,8 @@ COMMENT= Python bindings for librtmp, built with cffi
LICENSE= BSD2CLAUSE
LIB_DEPENDS= librtmp.so:multimedia/librtmp
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=0:devel/py-cffi@${FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=0:devel/py-cffi@${FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=0:devel/py-cffi@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=0:devel/py-cffi@${PY_FLAVOR}
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -27,7 +27,7 @@ USE_PYTHON= autoplist distutils
.include <bsd.port.pre.mk>
.if ${PYTHON_REL} < 3400
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}singledispatch>=0:devel/py-singledispatch@${FLAVOR}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}singledispatch>=0:devel/py-singledispatch@${PY_FLAVOR}
.endif
post-install: