aboutsummaryrefslogtreecommitdiff
path: root/multimedia/qdvdauthor
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-01-07 01:03:35 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-01-07 01:03:35 +0000
commita8ad771dbec50cb7ab04c0ac0b1703a89b59d9fc (patch)
tree54c9c31489492eb3bc402b9996bcdef189d748a2 /multimedia/qdvdauthor
parent072a7d7978b67b4da46f116f2a1980942f594e6f (diff)
downloadports-a8ad771dbec50cb7ab04c0ac0b1703a89b59d9fc.tar.gz
ports-a8ad771dbec50cb7ab04c0ac0b1703a89b59d9fc.zip
Notes
Diffstat (limited to 'multimedia/qdvdauthor')
-rw-r--r--multimedia/qdvdauthor/Makefile17
-rw-r--r--multimedia/qdvdauthor/distinfo5
-rw-r--r--multimedia/qdvdauthor/files/patch-configure22
-rw-r--r--multimedia/qdvdauthor/files/patch-qdvdauthor-log.cpp11
-rw-r--r--multimedia/qdvdauthor/files/patch-qdvdauthor-log.h11
-rw-r--r--multimedia/qdvdauthor/pkg-descr2
6 files changed, 52 insertions, 16 deletions
diff --git a/multimedia/qdvdauthor/Makefile b/multimedia/qdvdauthor/Makefile
index 5152f0bdd658..01b05f5f823d 100644
--- a/multimedia/qdvdauthor/Makefile
+++ b/multimedia/qdvdauthor/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= qdvdauthor
-PORTVERSION= 0.0.10
-PORTREVISION= 1
+PORTVERSION= 0.1.0
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,11 +14,10 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= oz@nixil.net
COMMENT= QT graphical frontend for dvdauthor
-BUILD_DEPENDS= dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
- mpeg2enc:${PORTSDIR}/multimedia/mjpegtools \
- qmake:${PORTSDIR}/devel/qmake
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
RUN_DEPENDS= dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
- mpeg2enc:${PORTSDIR}/multimedia/mjpegtools
+ mpeg2enc:${PORTSDIR}/multimedia/mjpegtools \
+ dvd-slideshow:${PORTSDIR}/multimedia/dvd-slideshow
PLIST_FILES= bin/qdvdauthor \
bin/qslideshow \
@@ -38,7 +36,6 @@ OPTIONS= NETPBM "Create mpeg2 streams for movie menus" on \
MJPEGTOOLS "Convert background images into mpeg2 movie" on \
CDRTOOLS "Create iso images of DVD on the Hard Drive" on \
TRANSCODE "Support for movie format conversion" on \
- DVDSLIDE "Creates slideshow-style dvd with menus" on \
DVDRWTOOLS "Optional DVD recording/burning prog" off \
MPLAYER "Optional support for mplayer playback" off \
TOOLAME "Optional support for audio conversion" off \
@@ -55,9 +52,6 @@ WITH_MJPEGTOOLS=yes
.if exists(${LOCALBASE}/bin/mkisofs)
WITH_CDRTOOLS=yes
.endif
-.if exists(${LOCALBASE}/bin/dvd-slideshow)
-WITH_DVDSLIDE=yes
-.endif
.if exists(${LOCALBASE}/bin/growisofs)
WITH_DVDRWTOOLS=yes
.endif
@@ -83,9 +77,6 @@ RUN_DEPENDS+= mpeg2enc:${PORTSDIR}/multimedia/mjpegtools
.if !defined(WITHOUT_CDRTOOLS)
RUN_DEPENDS+= mkisofs:${PORTSDIR}/sysutils/cdrtools
.endif
-.if !defined(WITHOUT_DVDSLIDE)
-RUN_DEPENDS+= dvd-slideshow:${PORTSDIR}/multimedia/dvd-slideshow
-.endif
.if defined(WITH_DVDRWTOOLS)
RUN_DEPENDS+= growisofs:${PORTSDIR}/sysutils/dvd+rw-tools
.endif
diff --git a/multimedia/qdvdauthor/distinfo b/multimedia/qdvdauthor/distinfo
index c9a973ba450b..c884d187ec5b 100644
--- a/multimedia/qdvdauthor/distinfo
+++ b/multimedia/qdvdauthor/distinfo
@@ -1,2 +1,3 @@
-MD5 (qdvdauthor-0.0.10.tar.gz) = da494965fb5ed14037acdbdf75af0857
-SIZE (qdvdauthor-0.0.10.tar.gz) = 1168130
+MD5 (qdvdauthor-0.1.0.tar.gz) = 6016cae51d2d2be1159c5fd2625d25d4
+SHA256 (qdvdauthor-0.1.0.tar.gz) = 527fcdfa5bc1db3db5df07b258d13b2ca25b34a60ba3d8a50cf402e557efcd16
+SIZE (qdvdauthor-0.1.0.tar.gz) = 3483254
diff --git a/multimedia/qdvdauthor/files/patch-configure b/multimedia/qdvdauthor/files/patch-configure
new file mode 100644
index 000000000000..87e6fcea5439
--- /dev/null
+++ b/multimedia/qdvdauthor/files/patch-configure
@@ -0,0 +1,22 @@
+--- configure.orig Fri Dec 30 01:50:45 2005
++++ configure Fri Dec 30 02:01:29 2005
+@@ -147,8 +147,8 @@
+
+ check_vlclibs()
+ {
+- export xineVersion=`xine-config --version 2>&1 | awk -F. '{printf ("%.2d%.2d%.2d", $1, $2, $3);}'`;
+- if [ $xineVersion -lt 010000 ];
++ export vlcVersion=`vlc-config --version 2>&1 | awk -F. '{printf ("%.2d%.2d%.2d", $1, $2, $3);}'`;
++ if [ $vlcVersion -lt 000800 ];
+ then
+ echo "************************************************"
+ echo "** Attention, vlc-lib version too low. **"
+@@ -159,7 +159,7 @@
+ echo "** http://www.videolan.org **"
+ echo "************************************************"
+ echo "Current VLC-lib version :"
+- echo "`xine-config --version`"
++ echo "`vlc-config --version`"
+ exit;
+ fi;
+ }
diff --git a/multimedia/qdvdauthor/files/patch-qdvdauthor-log.cpp b/multimedia/qdvdauthor/files/patch-qdvdauthor-log.cpp
new file mode 100644
index 000000000000..f3fdc9bff034
--- /dev/null
+++ b/multimedia/qdvdauthor/files/patch-qdvdauthor-log.cpp
@@ -0,0 +1,11 @@
+--- qdvdauthor/log.cpp.orig Fri Dec 30 03:27:58 2005
++++ qdvdauthor/log.cpp Fri Dec 30 03:28:15 2005
+@@ -83,7 +83,7 @@
+ log (iLogLevel, (const char *)qsLog);
+ }
+
+-void Log::line (void *pObj, unsigned long iThreadID, const char *pFile, const char *pFunction, long iLine, type enLogLevel)
++void Log::line (void *pObj, pthread_t iThreadID, const char *pFile, const char *pFunction, long iLine, type enLogLevel)
+ {
+ m_cBuffer[0] = '\0';
+ if (enLogLevel < m_enLogLevel) {
diff --git a/multimedia/qdvdauthor/files/patch-qdvdauthor-log.h b/multimedia/qdvdauthor/files/patch-qdvdauthor-log.h
new file mode 100644
index 000000000000..eba2cd1a00bf
--- /dev/null
+++ b/multimedia/qdvdauthor/files/patch-qdvdauthor-log.h
@@ -0,0 +1,11 @@
+--- qdvdauthor/log.h.orig Fri Dec 30 03:28:24 2005
++++ qdvdauthor/log.h Fri Dec 30 03:28:35 2005
+@@ -40,7 +40,7 @@
+ void log (QString);
+ void log (type, QString);
+
+- void line (void *, unsigned long, const char *, const char *, long, type);
++ void line (void *, pthread_t, const char *, const char *, long, type);
+ private:
+
+ int m_enLogLevel;
diff --git a/multimedia/qdvdauthor/pkg-descr b/multimedia/qdvdauthor/pkg-descr
index 0c2f66da8a3c..60fcabff320e 100644
--- a/multimedia/qdvdauthor/pkg-descr
+++ b/multimedia/qdvdauthor/pkg-descr
@@ -1,6 +1,6 @@
qdvdauthor is a graphical frontend to the dvd authoring program dvdauthor
written with the QT toolkit.
-The program is alpha quality though still very useful.
+The program is considered beta quality at this point.
WWW: http://qdvdauthor.sourceforge.net/