aboutsummaryrefslogtreecommitdiff
path: root/multimedia/qdvdauthor
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-11-09 08:15:10 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-11-09 08:15:10 +0000
commitb17cc1cb1f81559e55e8be5f5742e40c8721b9fc (patch)
tree60790579cc3a4e4622198b04dc11ac04029527d6 /multimedia/qdvdauthor
parentcc9c710a2535b2f90ed1b0962e68b42d6cec94cc (diff)
downloadports-b17cc1cb1f81559e55e8be5f5742e40c8721b9fc.tar.gz
ports-b17cc1cb1f81559e55e8be5f5742e40c8721b9fc.zip
Notes
Diffstat (limited to 'multimedia/qdvdauthor')
-rw-r--r--multimedia/qdvdauthor/Makefile15
-rw-r--r--multimedia/qdvdauthor/distinfo4
-rw-r--r--multimedia/qdvdauthor/files/patch-configure11
-rw-r--r--multimedia/qdvdauthor/files/patch-qdvdauthor-imagemagicklib.inc10
-rw-r--r--multimedia/qdvdauthor/files/patch-qdvdauthor-qplayer-qxinewidget.h10
-rw-r--r--multimedia/qdvdauthor/files/patch-qdvdauthor-qxine-qxinewidget.h10
-rw-r--r--multimedia/qdvdauthor/pkg-plist3
7 files changed, 32 insertions, 31 deletions
diff --git a/multimedia/qdvdauthor/Makefile b/multimedia/qdvdauthor/Makefile
index 3e8e580bcd22..5d7cef2cde68 100644
--- a/multimedia/qdvdauthor/Makefile
+++ b/multimedia/qdvdauthor/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qdvdauthor
-PORTVERSION= 0.0.7
+PORTVERSION= 0.0.8
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,23 +17,26 @@ COMMENT= QT graphical frontend for dvdauthor
BUILD_DEPENDS= dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
mpeg2enc:${PORTSDIR}/multimedia/mjpegtools \
qmake:${PORTSDIR}/devel/qmake
-LIB_DEPENDS= Magick.6:${PORTSDIR}/graphics/ImageMagick \
- xine.9:${PORTSDIR}/multimedia/libxine
+LIB_DEPENDS= xine.9:${PORTSDIR}/multimedia/libxine
RUN_DEPENDS= dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
mpeg2enc:${PORTSDIR}/multimedia/mjpegtools
+PLIST_FILES= bin/qdvdauthor \
+ bin/qslideshow \
+ bin/qplayer
+
HAS_CONFIGURE= yes
USE_X_PREFIX= yes
USE_QT_VER= 3
QT_NONSTANDARD= yes
CONFIGURE_ENV= QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++
-CONFIGURE_ARGS= --qt-dir=${X11BASE} --with-image-magick-lib \
- --build-qslideshow --build-wxine
+CONFIGURE_ARGS= --qt-dir=${X11BASE} --with-xine-lib \
+ --build-qslideshow --build-qplayer
NO_BUILD= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/qdvdauthor ${PREFIX}/bin/qdvdauthor
${INSTALL_PROGRAM} ${WRKSRC}/bin/qslideshow ${PREFIX}/bin/qslideshow
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/qxine ${PREFIX}/bin/qxine
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/qplayer ${PREFIX}/bin/qplayer
.include <bsd.port.mk>
diff --git a/multimedia/qdvdauthor/distinfo b/multimedia/qdvdauthor/distinfo
index 7e7537e09ca0..d0987dee3a53 100644
--- a/multimedia/qdvdauthor/distinfo
+++ b/multimedia/qdvdauthor/distinfo
@@ -1,2 +1,2 @@
-MD5 (qdvdauthor-0.0.7.tar.gz) = bfde1dae2e3f01baa52c624bb8414405
-SIZE (qdvdauthor-0.0.7.tar.gz) = 610869
+MD5 (qdvdauthor-0.0.8.tar.gz) = 67294b179464cd07220a8f484545318a
+SIZE (qdvdauthor-0.0.8.tar.gz) = 679606
diff --git a/multimedia/qdvdauthor/files/patch-configure b/multimedia/qdvdauthor/files/patch-configure
new file mode 100644
index 000000000000..62111e1cf66c
--- /dev/null
+++ b/multimedia/qdvdauthor/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Fri Nov 5 14:57:58 2004
++++ configure Fri Nov 5 14:58:33 2004
+@@ -265,7 +265,7 @@
+ esac;
+ done;
+ # Here we check for xine, or mplayer
+- if [ VIDEO_LIB = "xine" ];
++ if [ $VIDEO_LIB = "xine" ];
+ then
+ check_xinelibs;
+ else
diff --git a/multimedia/qdvdauthor/files/patch-qdvdauthor-imagemagicklib.inc b/multimedia/qdvdauthor/files/patch-qdvdauthor-imagemagicklib.inc
deleted file mode 100644
index 98cbeee6938d..000000000000
--- a/multimedia/qdvdauthor/files/patch-qdvdauthor-imagemagicklib.inc
+++ /dev/null
@@ -1,10 +0,0 @@
---- qdvdauthor/imagemagicklib.inc.old Tue Jul 6 21:58:42 2004
-+++ qdvdauthor/imagemagicklib.inc Tue Jul 6 21:59:02 2004
-@@ -10,6 +10,7 @@
-
- #include <stdio.h>
- #include <stdlib.h>
-+#include <unistd.h>
-
- #include <qimage.h>
- #include <Magick++.h>
diff --git a/multimedia/qdvdauthor/files/patch-qdvdauthor-qplayer-qxinewidget.h b/multimedia/qdvdauthor/files/patch-qdvdauthor-qplayer-qxinewidget.h
new file mode 100644
index 000000000000..77c3b694728e
--- /dev/null
+++ b/multimedia/qdvdauthor/files/patch-qdvdauthor-qplayer-qxinewidget.h
@@ -0,0 +1,10 @@
+--- qdvdauthor/qplayer/qxinewidget.h.orig Fri Nov 5 14:56:16 2004
++++ qdvdauthor/qplayer/qxinewidget.h Fri Nov 5 14:56:28 2004
+@@ -31,6 +31,7 @@
+ #include <qtimer.h>
+ #include <qevent.h>
+ #include <qthread.h>
++#include <pthread.h>
+
+ #include <xine.h>
+
diff --git a/multimedia/qdvdauthor/files/patch-qdvdauthor-qxine-qxinewidget.h b/multimedia/qdvdauthor/files/patch-qdvdauthor-qxine-qxinewidget.h
deleted file mode 100644
index 923472eb3b4d..000000000000
--- a/multimedia/qdvdauthor/files/patch-qdvdauthor-qxine-qxinewidget.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- qdvdauthor/qxine/qxinewidget.h.orig Mon May 10 03:14:10 2004
-+++ qdvdauthor/qxine/qxinewidget.h Mon May 10 22:03:01 2004
-@@ -31,6 +31,7 @@
- #include <qtimer.h>
- #include <qevent.h>
- #include <qthread.h>
-+#include <pthread.h>
-
- #include <xine.h>
-
diff --git a/multimedia/qdvdauthor/pkg-plist b/multimedia/qdvdauthor/pkg-plist
index 4431fb9d4146..e69de29bb2d1 100644
--- a/multimedia/qdvdauthor/pkg-plist
+++ b/multimedia/qdvdauthor/pkg-plist
@@ -1,3 +0,0 @@
-bin/qdvdauthor
-bin/qslideshow
-bin/qxine