aboutsummaryrefslogtreecommitdiff
path: root/multimedia/qt5-multimedia
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2020-01-01 00:01:42 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2020-01-01 00:01:42 +0000
commit380910d24dc4975f98b6e875bec6dfcff63529bd (patch)
treeb50a2d1e2a55d34d5fe0f02211892111323eacdd /multimedia/qt5-multimedia
parent948b217a1e51af1032bc6054c89216f969ea1164 (diff)
downloadports-380910d24dc4975f98b6e875bec6dfcff63529bd.tar.gz
ports-380910d24dc4975f98b6e875bec6dfcff63529bd.zip
Fix OPENAL knob in multimedia/qt5-multimedia
The knob was already there, but didn't have any machinery attached. - Move USES=openal to the knob - Introduce a patch to actually make openal configurable (instead of only following autodetect, so you can still turn the knob off with OpenAL installed) - Tidy the port a little - Add OPENAL to default options. Previously, setting or unsetting OPENAL had no effect, and OpenAL was always a dependency and used. Now, it does have an effect. I've made it default so that the default options still match what the port previously did (that is, depend on OpenAL). Bump PORTREVISION because of that. (Based very loosely on a patch submitted by Piotr Smyrak) PR: 242595 Reported by: Piotr Smyrak
Notes
Notes: svn path=/head/; revision=521666
Diffstat (limited to 'multimedia/qt5-multimedia')
-rw-r--r--multimedia/qt5-multimedia/Makefile12
-rw-r--r--multimedia/qt5-multimedia/files/patch-src_multimedia_configure.json14
2 files changed, 24 insertions, 2 deletions
diff --git a/multimedia/qt5-multimedia/Makefile b/multimedia/qt5-multimedia/Makefile
index 8de00c61c05b..397907fd7a48 100644
--- a/multimedia/qt5-multimedia/Makefile
+++ b/multimedia/qt5-multimedia/Makefile
@@ -2,6 +2,7 @@
PORTNAME= multimedia
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= multimedia
PKGNAMEPREFIX= qt5-
@@ -10,7 +11,7 @@ COMMENT= Qt audio, video, radio and camera support module
# LICENSE set via USES_QT5 (bsd.qt.mk)
-USES= compiler:c++11-lang gl gnome pkgconfig openal qmake:norecursive \
+USES= compiler:c++11-lang gl gnome pkgconfig qmake:norecursive \
qt-dist:5,multimedia xorg
USE_GL= gl
USE_GNOME= glib20
@@ -29,24 +30,31 @@ QT_CONFIG= xlib
QT_DEFINES= _QTMULTIMEDIA_DUMMY
OPTIONS_DEFINE= GSTREAMER OPENAL
-OPTIONS_DEFAULT= ALSA GSTREAMER
+OPTIONS_DEFAULT= ALSA GSTREAMER OPENAL
OPTIONS_RADIO= AUDIOPLUGIN
OPTIONS_RADIO_AUDIOPLUGIN= ALSA PULSEAUDIO
OPTIONS_SUB= yes
AUDIOPLUGIN_DESC= Audio plugins to build
+
OPENAL_DESC= 3D positional spatialized sound support
+OPENAL_USES= openal
+OPENAL_VARS= QT_CONFIG+=openal
+OPENAL_VARS_OFF= QT_CONFIG+=-openal \
+ QMAKE_CONFIGURE_ARGS+=-no-openal
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
ALSA_VARS= QT_CONFIG+=alsa
ALSA_VARS_OFF= QT_CONFIG+=-alsa \
QMAKE_CONFIGURE_ARGS+=-no-alsa
+
GSTREAMER_BUILD_DEPENDS=${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
GSTREAMER_USE= GSTREAMER1=bad
GSTREAMER_VARS= QT_CONFIG+=gstreamer-1.0 \
QMAKE_CONFIGURE_ARGS+=-gstreamer 1.0
GSTREAMER_VARS_OFF= QT_CONFIG+=-gstreamer-1.0 \
QMAKE_CONFIGURE_ARGS+=-no-gstreamer
+
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
PULSEAUDIO_VARS= QT_CONFIG+=pulseaudio
PULSEAUDIO_VARS_OFF= QT_CONFIG+=-pulseaudio \
diff --git a/multimedia/qt5-multimedia/files/patch-src_multimedia_configure.json b/multimedia/qt5-multimedia/files/patch-src_multimedia_configure.json
new file mode 100644
index 000000000000..0c63a1c6db40
--- /dev/null
+++ b/multimedia/qt5-multimedia/files/patch-src_multimedia_configure.json
@@ -0,0 +1,14 @@
+This adds a configure knob to Qt itself, which responds to the
+FreeBSD Makefile knobs; otherwise, we can't turn off finding
+OpenAL when it is installed.
+
+--- src/multimedia/configure.json.orig 2019-10-15 04:21:48 UTC
++++ src/multimedia/configure.json
+@@ -12,6 +12,7 @@
+ "directshow": { "type": "boolean" },
+ "wmf": { "type": "boolean" },
+ "gstreamer": { "type": "optionalString", "values": [ "no", "yes", "0.10", "1.0" ] },
++ "openal": "boolean",
+ "pulseaudio": "boolean"
+ }
+ },