aboutsummaryrefslogtreecommitdiff
path: root/multimedia/qt5-multimedia
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /multimedia/qt5-multimedia
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'multimedia/qt5-multimedia')
-rw-r--r--multimedia/qt5-multimedia/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/multimedia/qt5-multimedia/Makefile b/multimedia/qt5-multimedia/Makefile
index d15253ae3b24..dcd5867f34e4 100644
--- a/multimedia/qt5-multimedia/Makefile
+++ b/multimedia/qt5-multimedia/Makefile
@@ -10,12 +10,11 @@ COMMENT= Qt audio, video, radio and camera support module
# LICENSE set via USES_QT5 (bsd.qt.mk)
-USES= pkgconfig qmake:norecursive
+USES= pkgconfig qmake:norecursive qt-dist:5,multimedia
USE_GL= gl
USE_GNOME= glib20
-USE_QT5= core gui network opengl qml quick widgets \
+USE_QT= core gui network opengl qml quick widgets \
buildtools_build
-QT_DIST= ${PORTNAME}
USE_XORG= x11 xext xv
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}