aboutsummaryrefslogtreecommitdiff
path: root/multimedia/replex
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-10-27 22:29:46 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-10-27 22:29:46 +0000
commit338eecf23761d8a27351a0657ead88ab54a8f9da (patch)
tree2f75f2dd22479e7d9e0d627ea798a4d2a036e75f /multimedia/replex
parent2078f2a7ae31de5a4474e59c2d813276c225277f (diff)
downloadports-338eecf23761d8a27351a0657ead88ab54a8f9da.tar.gz
ports-338eecf23761d8a27351a0657ead88ab54a8f9da.zip
Notes
Diffstat (limited to 'multimedia/replex')
-rw-r--r--multimedia/replex/Makefile23
1 files changed, 11 insertions, 12 deletions
diff --git a/multimedia/replex/Makefile b/multimedia/replex/Makefile
index e1e8002b8ed4..77dee54cc318 100644
--- a/multimedia/replex/Makefile
+++ b/multimedia/replex/Makefile
@@ -10,15 +10,14 @@ MASTER_SITE_SUBDIR=dinoex
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Remultiplex an MPEG2 TS into a PS for DVD
-NO_STAGE= yes
-
USE_GMAKE= yes
-MAKE_ARGS= CFLAGS="${CFLAGS}" DEFINES="${CPPFLAGS} -DO_LARGEFILE=0 -DVERSION=\\\"$(PORTVERSION)\\\"" \
- LIBS="${LDFLAGS}"
-
+MAKE_ARGS= CFLAGS="${CFLAGS}" DEFINES="${CPPFLAGS} -DO_LARGEFILE=0 \
+ -DVERSION=\\\"$(PORTVERSION)\\\"" LIBS="${LDFLAGS}"
PLIST_FILES= bin/replex
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= CHANGES README TODO
.endif
@@ -29,12 +28,12 @@ post-patch:
's|-L. -lreplex|libreplex.a $${LIBS}|g' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/replex ${PREFIX}/bin/
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/CHANGES ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/TODO ${DOCSDIR}/
+ ${INSTALL_PROGRAM} ${WRKSRC}/replex ${STAGEDIR}${PREFIX}/bin/
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CHANGES ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/TODO ${STAGEDIR}${DOCSDIR}/
.endif
.include <bsd.port.mk>