aboutsummaryrefslogtreecommitdiff
path: root/multimedia/ruby-gst/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-06-26 05:01:46 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-06-26 05:01:46 +0000
commit6388b9b87ed052e5087e0d330bc710a51b4cc1d3 (patch)
tree7235c38fb7fd538665fd499cbac7bc3de5a7c2d7 /multimedia/ruby-gst/Makefile
parent84e37fa0231575ef3780f5e12dafc701273766b3 (diff)
Notes
Diffstat (limited to 'multimedia/ruby-gst/Makefile')
-rw-r--r--multimedia/ruby-gst/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/multimedia/ruby-gst/Makefile b/multimedia/ruby-gst/Makefile
new file mode 100644
index 000000000000..f1cb8e5619d1
--- /dev/null
+++ b/multimedia/ruby-gst/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: ruby-gst
+# Date created: 26 June 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gst
+PORTVERSION= 0.1.0
+CATEGORIES= multimedia ruby
+MASTER_SITES= http://savannah.nongnu.org/download/ruby-gst/unstable.pkg/${PORTVERSION}/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= Ruby bindings for the GStreamer framework
+
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+LIB_DEPENDS= gstreamer-0.6.1:${PORTSDIR}/multimedia/gstreamer
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+DOCS= AUTHORS doc/api
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_MODEXAMPLESDIR}/
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${CP} -R ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>