aboutsummaryrefslogtreecommitdiff
path: root/multimedia/sabbu/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-01-18 06:45:00 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-01-18 06:45:00 +0000
commitd26e5189a4bd4a394f970b2adf465722bf48a18c (patch)
tree059f6173443e2c58b7a5ee55bfa28525b317b122 /multimedia/sabbu/Makefile
parent6781533bb2af4ed3eea602b244e4199564079201 (diff)
downloadports-d26e5189a4bd4a394f970b2adf465722bf48a18c.tar.gz
ports-d26e5189a4bd4a394f970b2adf465722bf48a18c.zip
Notes
Diffstat (limited to 'multimedia/sabbu/Makefile')
-rw-r--r--multimedia/sabbu/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/multimedia/sabbu/Makefile b/multimedia/sabbu/Makefile
new file mode 100644
index 000000000000..dafc4808081d
--- /dev/null
+++ b/multimedia/sabbu/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: sabbu
+# Date created: 2005-04-14
+# Whom: dikr.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= sabbu
+PORTVERSION= 0.3.0
+CATEGORIES= multimedia
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Program used to time subtitles
+
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+LIB_DEPENDS= avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
+ sndfile:${PORTSDIR}/audio/libsndfile
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_ICONV= yes
+USE_AUTOTOOLS= libtool:15
+
+USE_GNOME= gtk20
+CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= WITH_NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= WITH_NLS=""
+.endif
+
+.include <bsd.port.mk>