aboutsummaryrefslogtreecommitdiff
path: root/multimedia/simplescreenrecorder
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-05-12 05:53:36 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-05-12 05:53:36 +0000
commit3615d8ac3fdd990a625fb5ddce9193313da3d5d8 (patch)
treee6e91015a2ecaea22e367a8086a65143a28ab9ab /multimedia/simplescreenrecorder
parent90d571e7a6b3fdade592503d823b4735c82816d9 (diff)
downloadports-3615d8ac3fdd990a625fb5ddce9193313da3d5d8.tar.gz
ports-3615d8ac3fdd990a625fb5ddce9193313da3d5d8.zip
Notes
Diffstat (limited to 'multimedia/simplescreenrecorder')
-rw-r--r--multimedia/simplescreenrecorder/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/multimedia/simplescreenrecorder/Makefile b/multimedia/simplescreenrecorder/Makefile
index 3ff959509fdc..f205a6811fab 100644
--- a/multimedia/simplescreenrecorder/Makefile
+++ b/multimedia/simplescreenrecorder/Makefile
@@ -2,6 +2,7 @@
PORTNAME= simplescreenrecorder
DISTVERSION= 0.4.1
+PORTREVISION= 1
CATEGORIES= multimedia
MAINTAINER= yuri@FreeBSD.org
@@ -10,8 +11,7 @@ COMMENT= Screen video recorder
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libasound.so:audio/alsa-lib \
- libavformat.so:multimedia/ffmpeg
+LIB_DEPENDS= libavformat.so:multimedia/ffmpeg
USES= cmake compiler:c++11-lang pkgconfig qt:5 xorg
USE_GITHUB= yes
@@ -24,8 +24,11 @@ CMAKE_ON= WITH_QT5
CMAKE_OFF= WITH_GLINJECT # doesn't yet work on FreeBSD: https://github.com/MaartenBaert/ssr/issues/586#issuecomment-343780107
CMAKE_OFF+= WITH_OPENGL_RECORDING # extra option requiried when GLInject is off, because this makes OpenGL recording dysfunctional
-OPTIONS_DEFINE= PULSEAUDIO JACK
-OPTIONS_DEFAULT= PULSEAUDIO
+OPTIONS_DEFINE= ALSA PULSEAUDIO JACK
+OPTIONS_DEFAULT= ALSA PULSEAUDIO
+
+ALSA_CMAKE_BOOL= WITH_ALSA
+ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
PULSEAUDIO_CMAKE_BOOL= WITH_PULSEAUDIO
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio