aboutsummaryrefslogtreecommitdiff
path: root/multimedia/smpeg-xmms/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-12-19 17:05:16 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-12-19 17:05:16 +0000
commita79685d9cdb239db660f7d6b836bb7297df533a3 (patch)
tree8e8a4ad15d54ad25cef07c22a9f9befc3bfdd0aa /multimedia/smpeg-xmms/Makefile
parentb32ef69a26ecdc149e037795b0c28bc532f2e7bd (diff)
Add smpeg-xmms. A mpeg plugin for XMMS using SDL/smpeg as backend. Supports
hardware acceleration in Xfree 4.x if available, fullscreen, resizeable window, VCD support (doesn't work in FreeBSD yet), aspected ratio when resizing the window, etc.
Notes
Notes: svn path=/head/; revision=36134
Diffstat (limited to 'multimedia/smpeg-xmms/Makefile')
-rw-r--r--multimedia/smpeg-xmms/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/multimedia/smpeg-xmms/Makefile b/multimedia/smpeg-xmms/Makefile
new file mode 100644
index 000000000000..e5878802ed4b
--- /dev/null
+++ b/multimedia/smpeg-xmms/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: smpeg-xmms
+# Date created: 30 August 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= smpeg-xmms
+PORTVERSION= 0.3.3
+CATEGORIES= graphics gnome
+MASTER_SITES= ftp://ftp.xmms.org/xmms/plugins/smpeg-xmms/
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= smpeg.0:${PORTSDIR}/graphics/smpeg \
+ xmms.1:${PORTSDIR}/audio/xmms
+
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+
+USE_X_PREFIX= yes
+USE_GTK= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+
+post-configure:
+ @${PERL} -pi -e 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
+ ${WRKSRC}/libtool
+
+.include <bsd.port.mk>