aboutsummaryrefslogtreecommitdiff
path: root/multimedia/smpeg2
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2013-11-12 20:10:06 +0000
committerMarcus von Appen <mva@FreeBSD.org>2013-11-12 20:10:06 +0000
commitdda3bc596b8859b3d07abcc98c92b86c38938594 (patch)
tree1e0ff50de45ad228aa16153f9c33afe317b92bd7 /multimedia/smpeg2
parent0b5ceea1544b9e3a1822e644e3010e9e97e647e3 (diff)
Version 2 of the smpeg library.
SMPEG is a free MPEG1 video player library with sound support. Video playback is based on the ubiquitous Berkeley MPEG player, mpeg_play v2.2. Audio is played through a slightly modified mpegsound library, part of Splay v0.8.2. SMPEG supports MPEG audio (MP3), MPEG-1 video, and MPEG system streams. plaympeg is simple video players provided to test the library. The C library interface is 'documented' in smpeg.h, and the C++ library interface is spread out over the MPEG*.h files. This is a work in progress. Only 16 or 32 bit color depth is supported. The player will dynamically conver to other color depths, but playback will be much faster if your display is already set to 16 bit color depth. WWW: http://icculus.org/smpeg/ PR: ports/183360 Submitted by: Vladimir Kondratiev <wulf@corp.infotel.ru>
Notes
Notes: svn path=/head/; revision=333613
Diffstat (limited to 'multimedia/smpeg2')
-rw-r--r--multimedia/smpeg2/Makefile38
-rw-r--r--multimedia/smpeg2/distinfo2
-rw-r--r--multimedia/smpeg2/files/patch-Makefile.in11
-rw-r--r--multimedia/smpeg2/pkg-descr14
-rw-r--r--multimedia/smpeg2/pkg-plist20
5 files changed, 85 insertions, 0 deletions
diff --git a/multimedia/smpeg2/Makefile b/multimedia/smpeg2/Makefile
new file mode 100644
index 000000000000..08b1cc53d756
--- /dev/null
+++ b/multimedia/smpeg2/Makefile
@@ -0,0 +1,38 @@
+# Created by: Vladimir Kondratiev <wulf@mail.mipt.ru>
+# $FreeBSD$
+
+PORTNAME= smpeg2
+PORTVERSION= 2.0.0
+CATEGORIES= multimedia
+MASTER_SITES= http://www.libsdl.org/projects/smpeg/release/ \
+ http://rsync.macports.org/smpeg2/
+
+MAINTAINER= wulf@mail.mipt.ru
+COMMENT= Free MPEG1 video player library with sound support
+
+LICENSE= GPLv2
+
+GNU_CONFIGURE= yes
+USE_SDL= sdl2
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= PLAYMPEG
+OPTIONS_DEFAULT=
+PLAYMPEG_DESC= Build plaympeg binary (conficts with smpeg)
+OPTIONS_SUB= yes
+
+CONFIGURE_ARGS= --enable-mmx
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MPLAYMPEG}
+CONFLICTS+= smpeg
+.endif
+
+post-patch:
+.if ! ${PORT_OPTIONS:MPLAYMPEG}
+ @${REINPLACE_CMD} -e '/^bin_PROGRAMS =/s/plaympeg$$(EXEEXT)// ; \
+ /^man_MANS =/s/plaympeg\.1//' ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>
diff --git a/multimedia/smpeg2/distinfo b/multimedia/smpeg2/distinfo
new file mode 100644
index 000000000000..0b2fadf17009
--- /dev/null
+++ b/multimedia/smpeg2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (smpeg2-2.0.0.tar.gz) = 979a65b211744a44fa641a9b6e4d64e64a12ff703ae776bafe3c4c4cd85494b3
+SIZE (smpeg2-2.0.0.tar.gz) = 482322
diff --git a/multimedia/smpeg2/files/patch-Makefile.in b/multimedia/smpeg2/files/patch-Makefile.in
new file mode 100644
index 000000000000..e3165a6784e4
--- /dev/null
+++ b/multimedia/smpeg2/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2013-06-01 21:07:34.000000000 +0400
++++ Makefile.in 2013-07-07 10:10:56.035849523 +0400
+@@ -432,7 +432,6 @@
+ smpeg.h
+
+ libsmpeg2_la_LDFLAGS = \
+- -release $(LT_RELEASE) \
+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
+
+ EXTRA_DIST = \
+
diff --git a/multimedia/smpeg2/pkg-descr b/multimedia/smpeg2/pkg-descr
new file mode 100644
index 000000000000..8a1a63c6d3ab
--- /dev/null
+++ b/multimedia/smpeg2/pkg-descr
@@ -0,0 +1,14 @@
+SMPEG is a free MPEG1 video player library with sound support. Video playback
+is based on the ubiquitous Berkeley MPEG player, mpeg_play v2.2. Audio is
+played through a slightly modified mpegsound library, part of Splay v0.8.2.
+SMPEG supports MPEG audio (MP3), MPEG-1 video, and MPEG system streams.
+
+plaympeg is simple video players provided to test the library. The C library
+interface is 'documented' in smpeg.h, and the C++ library interface is spread
+out over the MPEG*.h files.
+
+This is a work in progress. Only 16 or 32 bit color depth is supported.
+The player will dynamically conver to other color depths, but playback
+will be much faster if your display is already set to 16 bit color depth.
+
+WWW: http://icculus.org/smpeg/
diff --git a/multimedia/smpeg2/pkg-plist b/multimedia/smpeg2/pkg-plist
new file mode 100644
index 000000000000..8b97729d919e
--- /dev/null
+++ b/multimedia/smpeg2/pkg-plist
@@ -0,0 +1,20 @@
+%%PLAYMPEG%%bin/plaympeg
+bin/smpeg2-config
+include/smpeg2/MPEG.h
+include/smpeg2/MPEGaction.h
+include/smpeg2/MPEGaudio.h
+include/smpeg2/MPEGerror.h
+include/smpeg2/MPEGframe.h
+include/smpeg2/MPEGlist.h
+include/smpeg2/MPEGring.h
+include/smpeg2/MPEGstream.h
+include/smpeg2/MPEGsystem.h
+include/smpeg2/MPEGvideo.h
+include/smpeg2/smpeg.h
+lib/libsmpeg2.a
+lib/libsmpeg2.la
+lib/libsmpeg2.so
+lib/libsmpeg2.so.0
+%%PLAYMPEG%%man/man1/plaympeg.1.gz
+share/aclocal/smpeg2.m4
+@dirrm include/smpeg2