aboutsummaryrefslogtreecommitdiff
path: root/multimedia/sms1xxx-kmod
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-06-19 21:50:18 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-06-19 21:50:18 +0000
commitfb4d14f6c17b0aa6aef7e3fe09702007da6aa53f (patch)
treea42e16cd79eeba10dcd7518d23de692466fe3169 /multimedia/sms1xxx-kmod
parenteb464769c4c79d10eb98e4023de8dcf8d1bb835f (diff)
downloadports-fb4d14f6c17b0aa6aef7e3fe09702007da6aa53f.tar.gz
ports-fb4d14f6c17b0aa6aef7e3fe09702007da6aa53f.zip
Notes
Diffstat (limited to 'multimedia/sms1xxx-kmod')
-rw-r--r--multimedia/sms1xxx-kmod/Makefile124
-rw-r--r--multimedia/sms1xxx-kmod/distinfo3
-rw-r--r--multimedia/sms1xxx-kmod/files/patch-firmwares-Makefile12
-rw-r--r--multimedia/sms1xxx-kmod/files/pkg-message.in21
-rw-r--r--multimedia/sms1xxx-kmod/pkg-descr11
-rw-r--r--multimedia/sms1xxx-kmod/pkg-plist6
6 files changed, 177 insertions, 0 deletions
diff --git a/multimedia/sms1xxx-kmod/Makefile b/multimedia/sms1xxx-kmod/Makefile
new file mode 100644
index 000000000000..3cca9cb8a187
--- /dev/null
+++ b/multimedia/sms1xxx-kmod/Makefile
@@ -0,0 +1,124 @@
+# New ports collection makefile for: sms1xxx-kmod
+# Date created: 10 February 2010
+# Whom: Ganael Laplanche <ganael.laplanche@martymac.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sms1xxx
+PORTVERSION= 20100203
+CATEGORIES= multimedia kld
+MASTER_SITES= http://contribs.martymac.org/FreeBSD-siano/
+PKGNAMESUFFIX= -kmod
+DISTNAME= siano-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ganael.laplanche@martymac.com
+COMMENT= FreeBSD driver for Siano-based USB DVB devices
+
+WRKSRC= ${WRKDIR}/siano-${PORTVERSION}
+
+NO_PACKAGE= should be recompiled for a particular FreeBSD kernel
+
+OPTIONS= STELLAR "Build Stellar firmware" off \
+ NOVA "Build Nova firmware" off \
+ DEBUG "Build with debug symbols" off
+
+ONLY_FOR_ARCHS= i386 amd64
+
+SUB_FILES= pkg-message
+KMODDIR?= /boot/modules
+PLIST_SUB+= KMODDIR=${KMODDIR}
+MAKE_ENV+= KMODDIR=${KMODDIR}
+
+PORTDOCS= CHANGELOG README COPYING
+
+# Supported firmwares / firmwares to build
+STELLAR_FW= stellar_dvbt
+NOVA_FW= novab0_dvbbda
+BUILD_FWS=
+
+.include <bsd.port.pre.mk>
+
+.if !exists(/usr/src/sys/Makefile)
+IGNORE= requires kernel source files
+.elif ${OSVERSION} <= 800063
+IGNORE= requires FreeBSD 8.0 or superior
+.endif
+
+.if defined(WITH_DEBUG)
+ALL_TARGET= debug
+.endif
+
+.if defined(WITH_STELLAR)
+BUILD_FWS+= ${STELLAR_FW}
+PLIST_SUB+= PL_STELLAR=""
+.if !exists(${DISTDIR}/${DIST_SUBDIR}/${STELLAR_FW}.fw)
+.if !defined(DISTFILE_INSTRUCTIONS)
+DISTFILE_INSTRUCTIONS=\n\
+ Due to licensing restrictions, firmware files must be fetched manually.\n
+.endif
+DISTFILE_INSTRUCTIONS+= \
+ \n- Please, get the appropriate firmware for your Stellar device\n\
+ and copy the file to '${DISTDIR}/${DIST_SUBDIR}/${STELLAR_FW}.fw'\n\
+ e.g. :\n\
+ wget 'ftp://ftp.terratec.net/Receiver/Cinergy_Piranha/Update/Cinergy_Piranha_Drv_Vista_XP_3.09.02.00.exe'\n\
+ unzip -j 'Cinergy_Piranha_Drv_Vista_XP_3.09.02.00.exe' \\\\\n\
+ \t'Cinergy Piranha/BDA Driver 3.09.02.00/Windos XP (32Bit)/SMS100x_Dvbt.inp'\n\
+ mv 'SMS100x_Dvbt.inp' '${DISTDIR}/${DIST_SUBDIR}/${STELLAR_FW}.fw'\n
+.endif
+.else
+PLIST_SUB+= PL_STELLAR="@comment "
+.endif
+
+.if defined(WITH_NOVA)
+BUILD_FWS+= ${NOVA_FW}
+PLIST_SUB+= PL_NOVA=""
+.if !exists(${DISTDIR}/${DIST_SUBDIR}/${NOVA_FW}.fw)
+.if !defined(DISTFILE_INSTRUCTIONS)
+DISTFILE_INSTRUCTIONS=\n\
+ Due to licensing restrictions, firmware files must be fetched manually.\n
+.endif
+DISTFILE_INSTRUCTIONS+= \
+ \n- Please, get the appropriate firmware for your Nova device\n\
+ and copy the file to '${DISTDIR}/${DIST_SUBDIR}/${NOVA_FW}.fw'\n\
+ e.g. :\n\
+ wget 'http://www.wintvcd.co.uk/drivers/WinTV-MiniStick_4_2_10_27180_WHQL.zip'\n\
+ unzip -j 'WinTV-MiniStick_4_2_10_27180_WHQL.zip' \\\\\n\
+ \t'driver17/hcw17dvb.1b0'\n\
+ mv 'hcw17dvb.1b0' '${DISTDIR}/${DIST_SUBDIR}/${NOVA_FW}.fw'\n
+.endif
+.else
+PLIST_SUB+= PL_NOVA="@comment "
+.endif
+
+pre-fetch:
+.if defined(DISTFILE_INSTRUCTIONS)
+ @${MKDIR} ${DISTDIR}/${DIST_SUBDIR}
+ @${PRINTF} "${DISTFILE_INSTRUCTIONS}"
+ @exit 1
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|SUBDIR=|SUBDIR= ${BUILD_FWS}|' \
+ ${WRKSRC}/firmwares/Makefile
+
+pre-build:
+.if defined(WITH_STELLAR)
+ @${CP} ${DISTDIR}/${DIST_SUBDIR}/${STELLAR_FW}.fw ${WRKSRC}/firmwares/${STELLAR_FW}/
+.endif
+.if defined(WITH_NOVA)
+ @${CP} ${DISTDIR}/${DIST_SUBDIR}/${NOVA_FW}.fw ${WRKSRC}/firmwares/${NOVA_FW}/
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/sms1xxx-kmod/distinfo b/multimedia/sms1xxx-kmod/distinfo
new file mode 100644
index 000000000000..a79c32d7f14c
--- /dev/null
+++ b/multimedia/sms1xxx-kmod/distinfo
@@ -0,0 +1,3 @@
+MD5 (sms1xxx/siano-20100203.tgz) = 986c678cdecc6f1c3d03657685770584
+SHA256 (sms1xxx/siano-20100203.tgz) = 100afe029e0ec9f8de00bd7e6e26c32480d16bd184f3d70ef4bc7b83bc31fbfb
+SIZE (sms1xxx/siano-20100203.tgz) = 479855
diff --git a/multimedia/sms1xxx-kmod/files/patch-firmwares-Makefile b/multimedia/sms1xxx-kmod/files/patch-firmwares-Makefile
new file mode 100644
index 000000000000..85e8445e6901
--- /dev/null
+++ b/multimedia/sms1xxx-kmod/files/patch-firmwares-Makefile
@@ -0,0 +1,12 @@
+--- firmwares/Makefile.orig 2010-02-12 07:09:22.519462110 +0000
++++ firmwares/Makefile 2010-02-12 07:17:10.216239773 +0000
+@@ -1,8 +1,3 @@
+-SUBDIR= stellar_dabtdmb \
+- stellar_dvbh \
+- stellar_dvbt \
+- novab0_dvbbda \
+- novab0_isdbtbda
+-# novab0_tdmb
++SUBDIR=
+
+ .include <bsd.subdir.mk>
diff --git a/multimedia/sms1xxx-kmod/files/pkg-message.in b/multimedia/sms1xxx-kmod/files/pkg-message.in
new file mode 100644
index 000000000000..8564bd2dc149
--- /dev/null
+++ b/multimedia/sms1xxx-kmod/files/pkg-message.in
@@ -0,0 +1,21 @@
+
+===============================================================================
+
+This port has installed the sms1xxx kernel module.
+
+1) To load the kernel module at boot time, add the following line
+ to /boot/loader.conf :
+
+sms1xxx_load="YES"
+
+2) If you have built additional firmware modules, also add them
+ to /boot/loader.conf, e.g. for nova firmware :
+
+novab0_dvbbda_load="YES"
+
+3) See %%DOCSDIR%%/README for more details
+
+4) Plug your device in, use your favourite DVB application and enjoy !
+
+===============================================================================
+
diff --git a/multimedia/sms1xxx-kmod/pkg-descr b/multimedia/sms1xxx-kmod/pkg-descr
new file mode 100644
index 000000000000..f1fb10d9df46
--- /dev/null
+++ b/multimedia/sms1xxx-kmod/pkg-descr
@@ -0,0 +1,11 @@
+FreeBSD driver for Siano-based USB DVB devices.
+
+This driver have been tested with the following devices :
+
+ * Terratec Cinergy Piranha
+ * Hauppauge WinTV MiniStick (HD)
+
+However, other Siano-based USB devices should work, just give a try
+(you may want to add new VIDs/PIDs to make your device detected) !
+
+WWW: http://contribs.martymac.org
diff --git a/multimedia/sms1xxx-kmod/pkg-plist b/multimedia/sms1xxx-kmod/pkg-plist
new file mode 100644
index 000000000000..da45059e8736
--- /dev/null
+++ b/multimedia/sms1xxx-kmod/pkg-plist
@@ -0,0 +1,6 @@
+@cwd %%KMODDIR%%
+%%PL_NOVA%%novab0_dvbbda.ko
+%%PL_STELLAR%%stellar_dvbt.ko
+sms1xxx.ko
+@exec kldxref %D
+@unexec kldxref %D