aboutsummaryrefslogtreecommitdiff
path: root/multimedia/streamanalyze
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-11-01 13:02:13 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-11-01 13:02:13 +0000
commit6137272f61b07134113a92955baf433fb60837cf (patch)
tree47c7e415237039202b2ba4474152b3e22268eb18 /multimedia/streamanalyze
parent887e40cee32495fb46cf6d29d4e1f3e88e273c19 (diff)
downloadports-6137272f61b07134113a92955baf433fb60837cf.tar.gz
ports-6137272f61b07134113a92955baf433fb60837cf.zip
Notes
Diffstat (limited to 'multimedia/streamanalyze')
-rw-r--r--multimedia/streamanalyze/Makefile35
-rw-r--r--multimedia/streamanalyze/distinfo2
-rw-r--r--multimedia/streamanalyze/pkg-descr9
3 files changed, 46 insertions, 0 deletions
diff --git a/multimedia/streamanalyze/Makefile b/multimedia/streamanalyze/Makefile
new file mode 100644
index 000000000000..3fe9556909f3
--- /dev/null
+++ b/multimedia/streamanalyze/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: streamanalyze
+# Date created: 2005-10-30
+# Whom: Heiner Eichmann
+#
+# $FreeBSD$
+#
+
+PORTNAME= streamanalyze
+PORTVERSION= 0.4
+CATEGORIES= multimedia
+MASTER_SITES= http://www.badabum.de/down/
+
+MAINTAINER= h.eichmann@gmx.de
+COMMENT= Shrink-factor calculator for StreamDVD
+
+LIB_DEPENDS= dvdread:${PORTSDIR}/multimedia/libdvdread
+
+WRKSRC= ${WRKDIR}/StreamAnalyze
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/streamanalyze
+PORTDOCS= README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|gcc -g -Wall|${CC} ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/#include <getopt\.h>/ d' ${WRKSRC}/streamanalyze.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/streamanalyze ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/multimedia/streamanalyze/distinfo b/multimedia/streamanalyze/distinfo
new file mode 100644
index 000000000000..5d625993e76c
--- /dev/null
+++ b/multimedia/streamanalyze/distinfo
@@ -0,0 +1,2 @@
+MD5 (streamanalyze-0.4.tar.gz) = c17b27f0b92c0478e63e067d8f8e359c
+SIZE (streamanalyze-0.4.tar.gz) = 13287
diff --git a/multimedia/streamanalyze/pkg-descr b/multimedia/streamanalyze/pkg-descr
new file mode 100644
index 000000000000..5eacf4e640e6
--- /dev/null
+++ b/multimedia/streamanalyze/pkg-descr
@@ -0,0 +1,9 @@
+StreamAnalyze is a little helper for people using StreamDVD to backup movies.
+Giving the video/audio/subpicture tracks you want to save, StreamAnalyze will
+calculate if the backup would fit on a dvd-r and, if not, print a shrink
+factor to reduce the video size.
+
+Before using StreamAnalyze you should call 'lsdvd' or 'tcprobe' to get an
+overview of what is available on the video DVD you want to backup.
+
+WWW: http://www.badabum.de/streamdvd.html