aboutsummaryrefslogtreecommitdiff
path: root/multimedia/subtitleeditor/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-01-08 03:49:07 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-01-08 03:49:07 +0000
commite3dd1f9e6ca4cb60e906cc1303477757cd18fb21 (patch)
tree382b5c8f86582dcde44c3e205bedf98a5b1c39e1 /multimedia/subtitleeditor/Makefile
parent46bd50407d900505c0151ad816f5c5f78b8ff18e (diff)
downloadports-e3dd1f9e6ca4cb60e906cc1303477757cd18fb21.tar.gz
ports-e3dd1f9e6ca4cb60e906cc1303477757cd18fb21.zip
Notes
Diffstat (limited to 'multimedia/subtitleeditor/Makefile')
-rw-r--r--multimedia/subtitleeditor/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/multimedia/subtitleeditor/Makefile b/multimedia/subtitleeditor/Makefile
new file mode 100644
index 000000000000..c49ac246a36e
--- /dev/null
+++ b/multimedia/subtitleeditor/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: subtitleeditor
+# Date created: 08 January 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= subtitleeditor
+PORTVERSION= 0.12.4
+CATEGORIES= multimedia
+MASTER_SITES= http://kitone.free.fr/subtitleeditor/files/ CSME
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Subtitle editor
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
+ glademm-2.4.1:${PORTSDIR}/devel/libglademm24 \
+ enchant.1:${PORTSDIR}/textproc/enchant \
+ pcre.0:${PORTSDIR}/devel/pcre-utf8
+
+USE_GNOME= gtk20
+USE_GSTREAMER= good
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+PLIST_SUB= DESKTOPDIR="${DESKTOPDIR:S,^${PREFIX}/,,}"
+MAN1= ${PORTNAME}.1
+
+post-patch:
+ @${REINPLACE_CMD} -e '/test/s|==|=|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|strtoll|std::strtoll|g' ${WRKSRC}/src/SubtitleASS.cc
+
+pre-configure::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "This ports need pcre with utf-8 support. If you already"
+ @${ECHO_MSG} "have pcre installed, you may need to run"
+ @${ECHO_MSG} "# portupgrade -fo devel/pcre-utf8 pcre"
+ @${ECHO_MSG} "for this port to build"
+ @${ECHO_MSG} ""
+ @sleep 2
+
+.include <bsd.port.mk>