aboutsummaryrefslogtreecommitdiff
path: root/multimedia/subtitleeditor
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-05-06 20:39:40 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-05-06 20:39:40 +0000
commit479ac4063c2a2cbe07c5647e90b5d47a84099cb8 (patch)
tree5453376f0d74cfc5d82e814752d73434fa362feb /multimedia/subtitleeditor
parente322edaf37fc4c3e8e1759cac6b0e93cfbefa0ed (diff)
downloadports-479ac4063c2a2cbe07c5647e90b5d47a84099cb8.tar.gz
ports-479ac4063c2a2cbe07c5647e90b5d47a84099cb8.zip
Notes
Diffstat (limited to 'multimedia/subtitleeditor')
-rw-r--r--multimedia/subtitleeditor/Makefile11
-rw-r--r--multimedia/subtitleeditor/distinfo6
-rw-r--r--multimedia/subtitleeditor/files/patch-src-CommandSystem.cc13
-rw-r--r--multimedia/subtitleeditor/pkg-plist35
4 files changed, 43 insertions, 22 deletions
diff --git a/multimedia/subtitleeditor/Makefile b/multimedia/subtitleeditor/Makefile
index 527e8ddf9c15..c5d5f5d2014c 100644
--- a/multimedia/subtitleeditor/Makefile
+++ b/multimedia/subtitleeditor/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= subtitleeditor
-PORTVERSION= 0.13.6
-PORTREVISION= 1
+PORTVERSION= 0.20.0
CATEGORIES= multimedia
-MASTER_SITES= http://kitone.free.fr/subtitleeditor/files/ CENKES
+MASTER_SITES= http://download.gna.org/${PORTNAME}/0.20/
-MAINTAINER= infofarmer@FreeBSD.org
+MAINTAINER= pav@FreeBSD.org
COMMENT= Subtitle editor
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
@@ -24,15 +23,15 @@ LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
USE_GNOME= gtk20
USE_GSTREAMER= good
USE_GETTEXT= yes
+INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
PLIST_SUB= DESKTOPDIR="${DESKTOPDIR:S,^${PREFIX}/,,}"
-MAN1= ${PORTNAME}.1
post-patch:
@${REINPLACE_CMD} -e '/test/s|==|=|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|strtoll|strtoq|g' ${WRKSRC}/src/SubtitleASS.cc
+ @${REINPLACE_CMD} -e 's|strtoll|strtoq|g' ${WRKSRC}/src/formats/SubtitleASS.cc
.include <bsd.port.mk>
diff --git a/multimedia/subtitleeditor/distinfo b/multimedia/subtitleeditor/distinfo
index 9df3e9b33a90..727d1adf2863 100644
--- a/multimedia/subtitleeditor/distinfo
+++ b/multimedia/subtitleeditor/distinfo
@@ -1,3 +1,3 @@
-MD5 (subtitleeditor-0.13.6.tar.gz) = 063ffbe94afe832ec46b1666cdf00228
-SHA256 (subtitleeditor-0.13.6.tar.gz) = 5c63baa89443dc96e2e86e8cd6719cc0df0eed9ea713c0f41d418d9ee318b6aa
-SIZE (subtitleeditor-0.13.6.tar.gz) = 579871
+MD5 (subtitleeditor-0.20.0.tar.gz) = 068075f138ccb131cefcb780bdaf3eab
+SHA256 (subtitleeditor-0.20.0.tar.gz) = 463270399b237885361e7e82d3d3498e932b59c66011c0d44625993bdfbdaada
+SIZE (subtitleeditor-0.20.0.tar.gz) = 569760
diff --git a/multimedia/subtitleeditor/files/patch-src-CommandSystem.cc b/multimedia/subtitleeditor/files/patch-src-CommandSystem.cc
new file mode 100644
index 000000000000..42304504dfdb
--- /dev/null
+++ b/multimedia/subtitleeditor/files/patch-src-CommandSystem.cc
@@ -0,0 +1,13 @@
+--- src/CommandSystem.cc.orig 2008-02-05 14:17:58.000000000 +0100
++++ src/CommandSystem.cc 2008-04-29 13:29:39.000000000 +0200
+@@ -120,8 +120,8 @@
+ {
+ se_debug(SE_DEBUG_COMMAND);
+
+- std::list<Command*>::const_reverse_iterator it;
+- for(it = m_stack.rbegin(); it!= m_stack.rend(); ++it)
++ std::list<Command*>::const_iterator it;
++ for(it = m_stack.begin(); it!= m_stack.end(); ++it)
+ {
+ (*it)->restore();
+ }
diff --git a/multimedia/subtitleeditor/pkg-plist b/multimedia/subtitleeditor/pkg-plist
index 936ff17a9e98..ff309428f39d 100644
--- a/multimedia/subtitleeditor/pkg-plist
+++ b/multimedia/subtitleeditor/pkg-plist
@@ -1,27 +1,36 @@
bin/subtitleeditor
%%DESKTOPDIR%%/subtitleeditor.desktop
-%%DATADIR%%/dialog-change-fps.glade
-%%DATADIR%%/dialog-encodings-chooser.glade
-%%DATADIR%%/dialog-find-and-replace.glade
-%%DATADIR%%/dialog-move-subtitles.glade
-%%DATADIR%%/dialog-preferences.glade
-%%DATADIR%%/dialog-scale.glade
-%%DATADIR%%/dialog-script-properties.glade
-%%DATADIR%%/dialog-spell-checking.glade
-%%DATADIR%%/dialog-split.glade
-%%DATADIR%%/dialog-style-editor.glade
+%%DATADIR%%/glade/dialog-configure-keyboard-shortcuts.glade
+%%DATADIR%%/glade/dialog-encodings-chooser.glade
+%%DATADIR%%/glade/dialog-find-and-replace.glade
+%%DATADIR%%/glade/dialog-change-framerate.glade
+%%DATADIR%%/glade/dialog-check-errors.glade
+%%DATADIR%%/glade/dialog-check-errors-preferences.glade
+%%DATADIR%%/glade/dialog-move-subtitles.glade
+%%DATADIR%%/glade/dialog-preferences.glade
+%%DATADIR%%/glade/dialog-scale-subtitles.glade
+%%DATADIR%%/glade/dialog-script-properties.glade
+%%DATADIR%%/glade/dialog-spell-checking.glade
+%%DATADIR%%/glade/dialog-split-document.glade
+%%DATADIR%%/glade/dialog-style-editor.glade
+%%DATADIR%%/glade/subtitleeditor.glade
%%DATADIR%%/menubar.xml
-%%DATADIR%%/subtitleeditor-icon.png
-%%DATADIR%%/subtitleeditor.glade
-%%DATADIR%%/subtitleeditor.png
+%%DATADIR%%/subtitleeditor.svg
+share/icons/hicolor/16x16/apps/subtitleeditor.png
+share/icons/hicolor/22x22/apps/subtitleeditor.png
+share/icons/hicolor/24x24/apps/subtitleeditor.png
+share/icons/hicolor/32x32/apps/subtitleeditor.png
+share/icons/hicolor/scalable/apps/subtitleeditor.svg
share/locale/ca/LC_MESSAGES/subtitleeditor.mo
share/locale/cs/LC_MESSAGES/subtitleeditor.mo
share/locale/es/LC_MESSAGES/subtitleeditor.mo
share/locale/fr/LC_MESSAGES/subtitleeditor.mo
share/locale/hu/LC_MESSAGES/subtitleeditor.mo
+share/locale/it/LC_MESSAGES/subtitleeditor.mo
share/locale/nl/LC_MESSAGES/subtitleeditor.mo
share/locale/pl/LC_MESSAGES/subtitleeditor.mo
share/locale/pt_BR/LC_MESSAGES/subtitleeditor.mo
share/locale/pt_PT/LC_MESSAGES/subtitleeditor.mo
@dirrmtry %%DESKTOPDIR%%
+@dirrm %%DATADIR%%/glade
@dirrm %%DATADIR%%