aboutsummaryrefslogtreecommitdiff
path: root/multimedia/totem/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2005-01-23 10:27:56 +0000
committerKoop Mast <kwm@FreeBSD.org>2005-01-23 10:27:56 +0000
commit79d54c3c9184de61acba06c5cf21e1a919222d8c (patch)
tree007ccf88fd70e1c8deb927d1d7622315c3b25d43 /multimedia/totem/Makefile
parent1b5152db3bd8781a622980ecf7e38bd9a1b5af5a (diff)
Update to version 0.100
PR: 76006 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=127127
Diffstat (limited to 'multimedia/totem/Makefile')
-rw-r--r--multimedia/totem/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index 56dfa45f9476..4705a4c782ae 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= totem
-PORTVERSION= 0.99.22
-PORTREVISION?= 1
+PORTVERSION= 0.100
CATEGORIES= multimedia gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/...$//}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER?= hendrik@scholz.net
@@ -28,7 +27,8 @@ INSTALLS_OMF= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lXrandr"
-OPTIONS= DVDNAV "Enable DVD support" on
+OPTIONS?= DVDNAV "Enable DVD support" on \
+ GSTREAMER "Use Gstreamer instead of Xine" off
MAN1= totem.1
GCONF_SCHEMAS= totem-handlers.schemas totem-video-thumbnail.schemas \
@@ -37,12 +37,14 @@ CONFLICTS= totem-gstreamer-[0-9]*
.include <bsd.port.pre.mk>
-.if defined(WITH_GSTREAMER_OVERRIDE)
+.if defined(WITH_GSTREAMER)
CONFIGURE_ARGS+=--enable-gstreamer
USE_GNOME+= gstreamerplugins
WITHOUT_DVDNAV= yes
+PLIST_SUB= GSTREAMER=""
.else
LIB_DEPENDS+= xine.12:${PORTSDIR}/multimedia/libxine
+PLIST_SUB= GSTREAMER="@comment "
.endif
.if defined(WITH_DVDNAV) && !defined(WITHOUT_DVDNAV)
@@ -82,7 +84,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|/dev/cdrom|${DEFAULT_CDROM_DEVICE}|' \
${WRKSRC}/src/totem-preferences.c \
${WRKSRC}/src/bacon-video-widget-gst.c
-.if defined(WITH_GSTREAMER_OVERRIDE)
+.if defined(WITH_GSTREAMER)
@${REINPLACE_CMD} -e 's|/dev/dvd|${DEFAULT_DVD_DEVICE}|' \
${WRKSRC}/src/bacon-video-widget-gst.c
.endif