aboutsummaryrefslogtreecommitdiff
path: root/multimedia/totem
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
commitf1bb12de8e50bf76ae21f37debda60994ec7fd99 (patch)
tree1671d4beef381f12d939e34b344eb385a3af4f19 /multimedia/totem
parent29adee7bb42244f34736c5c24ed18a9b269d0925 (diff)
downloadports-f1bb12de8e50bf76ae21f37debda60994ec7fd99.tar.gz
ports-f1bb12de8e50bf76ae21f37debda60994ec7fd99.zip
Notes
Diffstat (limited to 'multimedia/totem')
-rw-r--r--multimedia/totem/Makefile68
-rw-r--r--multimedia/totem/distinfo6
-rw-r--r--multimedia/totem/files/patch-browser-plugin_totemPlugin.cpp10
-rw-r--r--multimedia/totem/files/patch-src_totem-disk.c32
-rw-r--r--multimedia/totem/files/patch-src_totem-mozilla-plugin.cpp10
-rw-r--r--multimedia/totem/files/pkg-message-mozilla.in8
-rw-r--r--multimedia/totem/pkg-plist109
7 files changed, 138 insertions, 105 deletions
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index e21f47305209..b4d52e8e06f0 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -6,29 +6,30 @@
#
PORTNAME= totem
-PORTVERSION= 1.4.5
+PORTVERSION= 2.16.2
CATEGORIES= multimedia gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
MAINTAINER?= hendrik@scholz.net
COMMENT?= A Xine-based video player for the Gnome 2 Desktop
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
-LIB_DEPENDS= musicbrainz:${PORTSDIR}/audio/libmusicbrainz
+LIB_DEPENDS= musicbrainz:${PORTSDIR}/audio/libmusicbrainz \
+ hal.1:${PORTSDIR}/sysutils/hal
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
USE_BZIP2= yes
USE_GETTEXT= yes
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_GNOME= gnomeprefix intlhack gnomehack gnomedesktop desktopfileutils \
- nautiluscdburner
+ nautiluscdburner ltverhack
GNOME_DESKTOP_VERSION=2
WANT_GSTREAMER= yes
+INSTALLS_ICONS= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_AUTOTOOLS= libtool:15
+USE_LDCONFIG= yes
INSTALLS_OMF= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
@@ -46,19 +47,27 @@ CONFLICTS?= totem-gstreamer-[0-9]*
.include <bsd.port.pre.mk>
.if defined(WITH_MOZILLA_PLUGIN)
-USE_GECKO= firefox mozilla seamonkey
-.include "${.CURDIR}/../../www/mozilla/bsd.gecko.mk"
+USE_GECKO= firefox mozilla seamonkey xulrunner<->firefox firefox-devel<->firefox
+.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
PLIST_SUB+= MOZILLA=""
-LIB_DEPENDS+= dbus-1.2:${PORTSDIR}/devel/dbus
-CONFIGURE_ARGS+=--with-mozilla=${GECKO}
+CONFIGURE_ARGS+=--with-mozilla=${GECKO} \
+ --enable-gmp-plugin \
+ --enable-complex-plugin \
+ --enable-narrowspace-plugin
.else
PLIST_SUB+= MOZILLA="@comment "
-CONFIGURE_ARGS+=--disable-mozilla
+CONFIGURE_ARGS+=--without-mozilla \
+ --disable-browser-plugins \
+ --disable-mozilla \
+ --disable-basic-plugin \
+ --disable-gmp-plugin \
+ --disable-complex-plugin \
+ --disable-narrowspace-plugin
.endif
.if defined(WITH_GSTREAMER)
-CONFIGURE_ARGS+=--enable-gstreamer=0.10
-USE_GSTREAMER+= gnomevfs core gconf
+CONFIGURE_ARGS+=--enable-gstreamer=yes
+USE_GSTREAMER+= gnomevfs core gconf hal good
WITHOUT_DVDNAV= yes
PLIST_SUB+= GSTREAMER=""
.else
@@ -70,16 +79,6 @@ PLIST_SUB+= GSTREAMER="@comment "
LIB_DEPENDS+= dvdnav.4:${PORTSDIR}/multimedia/libdvdnav
.endif
-.if defined(WITH_CDROM_DEVICE)
-DEFAULT_CDROM_DEVICE=${WITH_CDROM_DEVICE}
-.else
-.if ${OSVERSION} < 500000
-DEFAULT_CDROM_DEVICE=/dev/acd0c
-.else
-DEFAULT_CDROM_DEVICE=/dev/acd0
-.endif
-.endif
-
.if defined(WITH_DVD_DEVICE)
DEFAULT_DVD_DEVICE=${WITH_DVD_DEVICE}
.else
@@ -91,29 +90,18 @@ DEFAULT_DVD_DEVICE=/dev/acd0
.endif
pre-everything::
- @${ECHO_MSG} "===> The default CDROM device is ${DEFAULT_CDROM_DEVICE}"
- @${ECHO_MSG} "===> Define WITH_CDROM_DEVICE if you want to change the default"
- @${ECHO_MSG} "===> For example, 'make WITH_CDROM_DEVICE=\"/dev/somedevice\"'"
- @${ECHO_MSG} "===>"
@${ECHO_MSG} "===> The default DVD device is ${DEFAULT_DVD_DEVICE}"
@${ECHO_MSG} "===> Define WITH_DVD_DEVICE if you want to change the default"
@${ECHO_MSG} "===> For example, 'make WITH_DVD_DEVICE=\"/dev/somedevice\"'"
post-patch:
@${CP} -f ${FILESDIR}/pkg-message.in ${PKGMESSAGE}
-.if defined(WITH_MOZILLA_PLUGIN)
- @${ECHO} "" >> ${PKGMESSAGE}
- @${CAT} ${FILESDIR}/pkg-message-mozilla.in >> ${PKGMESSAGE}
-.endif
- @${REINPLACE_CMD} -e 's|/plugins||; \
- s|@MOZILLA_PLUGINDIR@|${PREFIX}/lib/browser_plugins|' \
- ${WRKSRC}/src/Makefile.in
- @${REINPLACE_CMD} -e 's|/dev/cdrom|${DEFAULT_CDROM_DEVICE}|' \
- ${WRKSRC}/src/totem-preferences.c \
- ${WRKSRC}/src/backend/bacon-video-widget-gst.c
+ @${REINPLACE_CMD} -e ' s|@MOZILLA_PLUGINDIR@|${PREFIX}/lib/browser_plugins|; \
+ s|mozilla/plugins|browser_plugins|' \
+ ${WRKSRC}/browser-plugin/Makefile.in \
+ ${WRKSRC}/browser-plugin/idl/Makefile.in
.if defined(WITH_GSTREAMER)
@${REINPLACE_CMD} -e 's|/dev/dvd|${DEFAULT_DVD_DEVICE}|' \
- ${WRKSRC}/src/backend/bacon-video-widget-gst.c \
${WRKSRC}/src/backend/bacon-video-widget-gst-0.10.c
.endif
diff --git a/multimedia/totem/distinfo b/multimedia/totem/distinfo
index e966b0056ea3..7530eb61b1c4 100644
--- a/multimedia/totem/distinfo
+++ b/multimedia/totem/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/totem-1.4.5.tar.bz2) = 215861d6276b77ac4ad871abb18aa10c
-SHA256 (gnome2/totem-1.4.5.tar.bz2) = 9c6440b8fd1c4f8b1668c6a0f2946db06e641456e8b86b612275784eaccc5be1
-SIZE (gnome2/totem-1.4.5.tar.bz2) = 1720059
+MD5 (gnome2/totem-2.16.2.tar.bz2) = 6e98e3bc2b8531611906bd2bca73f743
+SHA256 (gnome2/totem-2.16.2.tar.bz2) = 7f088dc3630d040b44a5ddb84d07baae6fb5593d6fa6fd25b86bd9c46e82101d
+SIZE (gnome2/totem-2.16.2.tar.bz2) = 1831393
diff --git a/multimedia/totem/files/patch-browser-plugin_totemPlugin.cpp b/multimedia/totem/files/patch-browser-plugin_totemPlugin.cpp
new file mode 100644
index 000000000000..9a16349f4b0a
--- /dev/null
+++ b/multimedia/totem/files/patch-browser-plugin_totemPlugin.cpp
@@ -0,0 +1,10 @@
+--- browser-plugin/totemPlugin.cpp.orig Mon Aug 14 17:01:14 2006
++++ browser-plugin/totemPlugin.cpp Mon Aug 14 17:01:24 2006
+@@ -27,6 +27,7 @@
+ #include <stdint.h>
+ #include <unistd.h>
+ #include <fcntl.h>
++#include <signal.h>
+ #include <sys/wait.h>
+ #include <sys/poll.h>
+ #include <string.h>
diff --git a/multimedia/totem/files/patch-src_totem-disk.c b/multimedia/totem/files/patch-src_totem-disk.c
deleted file mode 100644
index 6b6ef565e287..000000000000
--- a/multimedia/totem/files/patch-src_totem-disk.c
+++ /dev/null
@@ -1,32 +0,0 @@
---- src/plparse/totem-disc.c.orig Thu Nov 24 16:53:02 2005
-+++ src/plparse/totem-disc.c Sun Dec 18 13:34:12 2005
-@@ -43,7 +43,29 @@
- #include <glib/gi18n.h>
- #include <libgnomevfs/gnome-vfs.h>
-
-+#ifdef __FreeBSD__
-+#include <sys/cdio.h>
-+#include <sys/disklabel.h>
-+
-+#define CDROM_DRIVE_STATUS 0x5326
-+#define CDROM_DISC_STATUS 0x5327
-+#define CDS_AUDIO 100
-+#define CDS_MIXED 105
-+#define CDS_DATA_1 101
-+#define CDS_DATA_2 102
-+#define CDS_NO_INFO 0 /* if not implemented */
-+#define CDS_NO_DISC 1
-+#define CDS_TRAY_OPEN 2
-+#define CDS_DRIVE_NOT_READY 3
-+#define CDS_DISC_OK 4
-+#define CDS_XA_2_1 103
-+#define CDS_XA_2_2 104
-+#define CDC_DVD 0x8000
-+#define ENOMEDIUM ENODEV
-+#define CDROM_GET_CAPABILITY CDIOCCLRDEBUG
-+#else
- #include <linux/cdrom.h>
-+#endif
-
- #include "totem-disc.h"
-
diff --git a/multimedia/totem/files/patch-src_totem-mozilla-plugin.cpp b/multimedia/totem/files/patch-src_totem-mozilla-plugin.cpp
deleted file mode 100644
index 2c34077eadd5..000000000000
--- a/multimedia/totem/files/patch-src_totem-mozilla-plugin.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/totem-mozilla-plugin.cpp.orig Tue Nov 8 21:50:10 2005
-+++ src/totem-mozilla-plugin.cpp Tue Nov 8 21:50:27 2005
-@@ -27,6 +27,7 @@
- #include <stdint.h>
- #include <unistd.h>
- #include <fcntl.h>
-+#include <signal.h>
- #include <sys/wait.h>
- #include <string.h>
-
diff --git a/multimedia/totem/files/pkg-message-mozilla.in b/multimedia/totem/files/pkg-message-mozilla.in
deleted file mode 100644
index ddbbe4e548a7..000000000000
--- a/multimedia/totem/files/pkg-message-mozilla.in
+++ /dev/null
@@ -1,8 +0,0 @@
-**************************************************************************
-The totem mozilla plugin requires a D-BUS-enabled desktop session. Consult
-the FreeBSD GNOME FAQ for instructions on setting up your desktop session
-through D-BUS:
-
- http://www.freebsd.org/gnome/docs/faq2.html#q25
-
-**************************************************************************
diff --git a/multimedia/totem/pkg-plist b/multimedia/totem/pkg-plist
index a9174c8c6ba1..47b223c57f2a 100644
--- a/multimedia/totem/pkg-plist
+++ b/multimedia/totem/pkg-plist
@@ -4,14 +4,30 @@ include/totem/1/plparser/totem-disc.h
include/totem/1/plparser/totem-pl-parser-builtins.h
include/totem/1/plparser/totem-pl-parser-features.h
include/totem/1/plparser/totem-pl-parser.h
-%%MOZILLA%%lib/browser_plugins/libtotem_mozilla.a
-%%MOZILLA%%lib/browser_plugins/libtotem_mozilla.la
-%%MOZILLA%%lib/browser_plugins/libtotem_mozilla.so
-%%MOZILLA%%lib/browser_plugins/libtotem_mozilla.xpt
+%%MOZILLA%%lib/browser_plugins/libtotem-basic-plugin.a
+%%MOZILLA%%lib/browser_plugins/libtotem-basic-plugin.la
+%%MOZILLA%%lib/browser_plugins/libtotem-basic-plugin.so
+%%MOZILLA%%lib/browser_plugins/libtotem-basic-plugin.xpt
+%%MOZILLA%%lib/browser_plugins/libtotem-complex-plugin.a
+%%MOZILLA%%lib/browser_plugins/libtotem-complex-plugin.la
+%%MOZILLA%%lib/browser_plugins/libtotem-complex-plugin.so
+%%MOZILLA%%lib/browser_plugins/libtotem-complex-plugin.xpt
+%%MOZILLA%%lib/browser_plugins/libtotem-gmp-plugin.a
+%%MOZILLA%%lib/browser_plugins/libtotem-gmp-plugin.la
+%%MOZILLA%%lib/browser_plugins/libtotem-gmp-plugin.so
+%%MOZILLA%%lib/browser_plugins/libtotem-gmp-plugin.xpt
+%%MOZILLA%%lib/browser_plugins/libtotem-mully-plugin.a
+%%MOZILLA%%lib/browser_plugins/libtotem-mully-plugin.la
+%%MOZILLA%%lib/browser_plugins/libtotem-mully-plugin.so
+%%MOZILLA%%lib/browser_plugins/libtotem-mully-plugin.xpt
+%%MOZILLA%%lib/browser_plugins/libtotem-narrowspace-plugin.a
+%%MOZILLA%%lib/browser_plugins/libtotem-narrowspace-plugin.la
+%%MOZILLA%%lib/browser_plugins/libtotem-narrowspace-plugin.so
+%%MOZILLA%%lib/browser_plugins/libtotem-narrowspace-plugin.xpt
lib/libtotem-plparser.a
lib/libtotem-plparser.la
lib/libtotem-plparser.so
-lib/libtotem-plparser.so.2
+lib/libtotem-plparser.so.1
lib/nautilus/extensions-1.0/libtotem-properties-page.a
lib/nautilus/extensions-1.0/libtotem-properties-page.la
lib/nautilus/extensions-1.0/libtotem-properties-page.so
@@ -82,12 +98,16 @@ share/gnome/omf/totem/totem-es.omf
share/gnome/omf/totem/totem-fr.omf
share/gnome/omf/totem/totem-ru.omf
share/gnome/omf/totem/totem-uk.omf
-share/gnome/pixmaps/media-player-48.png
share/gnome/pixmaps/vanity.png
+%%MOZILLA%%share/gnome/totem/doc/totemIBasicPlayer.html
+%%MOZILLA%%share/gnome/totem/doc/totemIComplexPlayer.html
+%%MOZILLA%%share/gnome/totem/doc/totemIGMPControls.html
+%%MOZILLA%%share/gnome/totem/doc/totemIGMPPlayer.html
+%%MOZILLA%%share/gnome/totem/doc/totemIMullYPlayer.html
+%%MOZILLA%%share/gnome/totem/doc/totemINarrowSpacePlayer.html
share/gnome/totem/filmholes-big-left.png
share/gnome/totem/filmholes-big-right.png
share/gnome/totem/filmholes.png
-share/gnome/totem/media-player-48.png
share/gnome/totem/mozilla-viewer.glade
share/gnome/totem/playlist-playing.png
share/gnome/totem/playlist.glade
@@ -107,18 +127,25 @@ share/gnome/totem/totem_logo.png
share/gnome/totem/uri.glade
share/gnome/totem/vanity.glade
share/gnome/totem/vanity.png
+share/icons/hicolor/16x16/apps/totem.png
+share/icons/hicolor/22x22/apps/totem.png
+share/icons/hicolor/24x24/apps/totem.png
+share/icons/hicolor/32x32/apps/totem.png
+share/icons/hicolor/scalable/apps/totem.svg
share/locale/am/LC_MESSAGES/totem.mo
share/locale/ar/LC_MESSAGES/totem.mo
share/locale/az/LC_MESSAGES/totem.mo
share/locale/be/LC_MESSAGES/totem.mo
share/locale/bg/LC_MESSAGES/totem.mo
share/locale/bn/LC_MESSAGES/totem.mo
+share/locale/bn_IN/LC_MESSAGES/totem.mo
share/locale/br/LC_MESSAGES/totem.mo
share/locale/ca/LC_MESSAGES/totem.mo
share/locale/cs/LC_MESSAGES/totem.mo
share/locale/cy/LC_MESSAGES/totem.mo
share/locale/da/LC_MESSAGES/totem.mo
share/locale/de/LC_MESSAGES/totem.mo
+share/locale/dz/LC_MESSAGES/totem.mo
share/locale/el/LC_MESSAGES/totem.mo
share/locale/en_CA/LC_MESSAGES/totem.mo
share/locale/en_GB/LC_MESSAGES/totem.mo
@@ -139,19 +166,21 @@ share/locale/id/LC_MESSAGES/totem.mo
share/locale/is/LC_MESSAGES/totem.mo
share/locale/it/LC_MESSAGES/totem.mo
share/locale/ja/LC_MESSAGES/totem.mo
-share/locale/ka/LC_MESSAGES/totem.mo
share/locale/ko/LC_MESSAGES/totem.mo
share/locale/ku/LC_MESSAGES/totem.mo
share/locale/lt/LC_MESSAGES/totem.mo
share/locale/lv/LC_MESSAGES/totem.mo
+share/locale/ka/LC_MESSAGES/totem.mo
share/locale/mg/LC_MESSAGES/totem.mo
share/locale/mk/LC_MESSAGES/totem.mo
share/locale/ml/LC_MESSAGES/totem.mo
+share/locale/mr/LC_MESSAGES/totem.mo
share/locale/ms/LC_MESSAGES/totem.mo
share/locale/nb/LC_MESSAGES/totem.mo
share/locale/ne/LC_MESSAGES/totem.mo
share/locale/nl/LC_MESSAGES/totem.mo
share/locale/nn/LC_MESSAGES/totem.mo
+share/locale/or/LC_MESSAGES/totem.mo
share/locale/pa/LC_MESSAGES/totem.mo
share/locale/pl/LC_MESSAGES/totem.mo
share/locale/pt/LC_MESSAGES/totem.mo
@@ -160,10 +189,12 @@ share/locale/ro/LC_MESSAGES/totem.mo
share/locale/ru/LC_MESSAGES/totem.mo
share/locale/rw/LC_MESSAGES/totem.mo
share/locale/sk/LC_MESSAGES/totem.mo
+share/locale/sl/LC_MESSAGES/totem.mo
share/locale/sq/LC_MESSAGES/totem.mo
share/locale/sr/LC_MESSAGES/totem.mo
share/locale/sr@Latn/LC_MESSAGES/totem.mo
share/locale/sv/LC_MESSAGES/totem.mo
+share/locale/ta/LC_MESSAGES/totem.mo
share/locale/te/LC_MESSAGES/totem.mo
share/locale/th/LC_MESSAGES/totem.mo
share/locale/tr/LC_MESSAGES/totem.mo
@@ -175,10 +206,7 @@ share/locale/xh/LC_MESSAGES/totem.mo
share/locale/zh_CN/LC_MESSAGES/totem.mo
share/locale/zh_HK/LC_MESSAGES/totem.mo
share/locale/zh_TW/LC_MESSAGES/totem.mo
-@dirrmtry share/locale/mg/LC_MESSAGES
-@dirrmtry share/locale/mg
-@dirrmtry share/locale/ku/LC_MESSAGES
-@dirrmtry share/locale/ku
+@dirrm share/gnome/totem/doc
@dirrm share/gnome/totem
@dirrm share/gnome/omf/totem
@dirrm share/gnome/help/totem/uk/figures
@@ -196,8 +224,65 @@ share/locale/zh_TW/LC_MESSAGES/totem.mo
@dirrm share/gnome/help/totem/C/figures
@dirrm share/gnome/help/totem/C
@dirrm share/gnome/help/totem
+@dirrmtry lib/browser_plugins
@dirrm include/totem/1/plparser
@dirrm include/totem/1
@dirrm include/totem
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@dirrmtry share/locale/zh_TW/LC_MESSAGES
+@dirrmtry share/locale/zh_TW
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/zh_CN/LC_MESSAGES
+@dirrmtry share/locale/zh_CN
+@dirrmtry share/locale/xh/LC_MESSAGES
+@dirrmtry share/locale/xh
+@dirrmtry share/locale/uk/LC_MESSAGES
+@dirrmtry share/locale/uk
+@dirrmtry share/locale/ug/LC_MESSAGES
+@dirrmtry share/locale/ug
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
+@dirrmtry share/locale/sr/LC_MESSAGES
+@dirrmtry share/locale/sr
+@dirrmtry share/locale/sl/LC_MESSAGES
+@dirrmtry share/locale/sl
+@dirrmtry share/locale/sk/LC_MESSAGES
+@dirrmtry share/locale/sk
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/ro/LC_MESSAGES
+@dirrmtry share/locale/ro
+@dirrmtry share/locale/pt/LC_MESSAGES
+@dirrmtry share/locale/pt
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/nn/LC_MESSAGES
+@dirrmtry share/locale/nn
+@dirrmtry share/locale/ne/LC_MESSAGES
+@dirrmtry share/locale/ne
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/mg/LC_MESSAGES
+@dirrmtry share/locale/mg
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrmtry share/locale/ko/LC_MESSAGES
+@dirrmtry share/locale/ko
+@dirrmtry share/locale/gl/LC_MESSAGES
+@dirrmtry share/locale/gl
+@dirrmtry share/locale/fi/LC_MESSAGES
+@dirrmtry share/locale/fi
+@dirrmtry share/locale/el/LC_MESSAGES
+@dirrmtry share/locale/el
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
+@dirrmtry share/locale/ca/LC_MESSAGES
+@dirrmtry share/locale/ca
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be/LC_MESSAGES
+@dirrmtry share/locale/be