aboutsummaryrefslogtreecommitdiff
path: root/multimedia/totem
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
commite18151212d3326dbf04797c6d5300fb1211ee875 (patch)
tree1ca56d6a4227efdb653cc8e2b2cbedbbc8de3d88 /multimedia/totem
parentcc0f3248a2eb77d7e3df88333fd25eb8594223dc (diff)
Notes
Diffstat (limited to 'multimedia/totem')
-rw-r--r--multimedia/totem/Makefile17
-rw-r--r--multimedia/totem/distinfo4
-rw-r--r--multimedia/totem/files/patch-src::Makefile.in12
-rw-r--r--multimedia/totem/files/patch-src::bacon-video-widget-xine.c15
-rw-r--r--multimedia/totem/files/patch-src_totem-disk.c4
-rw-r--r--multimedia/totem/pkg-plist22
6 files changed, 32 insertions, 42 deletions
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index 7219abe9e3ef..d7afe69d99ae 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= totem
-PORTVERSION= 1.0.4
-PORTREVISION?= 1
+PORTVERSION= 1.2.0
CATEGORIES= multimedia gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
@@ -23,7 +22,7 @@ USE_GNOME= gnomeprefix intlhack gnomehack gnomedesktop desktopfileutils \
nautiluscdburner
WANT_GSTREAMER= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
INSTALLS_OMF= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
@@ -36,11 +35,15 @@ OPTIONS?= DVDNAV "Enable DVD support" on \
MAN1= totem.1 totem-video-thumbnailer.1
GCONF_SCHEMAS= totem-handlers.schemas totem-video-thumbnail.schemas \
totem.schemas
-CONFLICTS?= totem-gstreamer-[0-9]*
+CONFLICTS= totem-gstreamer-[0-9]*
.include <bsd.port.pre.mk>
+LIB_DEPENDS+= musicbrainz:${PORTSDIR}/audio/libmusicbrainz
+
.if defined(WITH_GSTREAMER)
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
+RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
CONFIGURE_ARGS+=--enable-gstreamer
USE_GSTREAMER+= gnomevfs core gconf
WITHOUT_DVDNAV= yes
@@ -86,13 +89,11 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|/dev/cdrom|${DEFAULT_CDROM_DEVICE}|' \
${WRKSRC}/src/totem-preferences.c \
- ${WRKSRC}/src/bacon-video-widget-gst.c
+ ${WRKSRC}/src/backend/bacon-video-widget-gst.c
.if defined(WITH_GSTREAMER)
@${REINPLACE_CMD} -e 's|/dev/dvd|${DEFAULT_DVD_DEVICE}|' \
- ${WRKSRC}/src/bacon-video-widget-gst.c
+ ${WRKSRC}/src/backend/bacon-video-widget-gst.c
.endif
- @${REINPLACE_CMD} -e 's|@LOCALBASE@|${LOCALBASE}|' \
- ${WRKSRC}/src/bacon-video-widget-xine.c
post-install:
@-update-desktop-database
diff --git a/multimedia/totem/distinfo b/multimedia/totem/distinfo
index ed9376d4d0f8..0ce4edd042b6 100644
--- a/multimedia/totem/distinfo
+++ b/multimedia/totem/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/totem-1.0.4.tar.bz2) = 60dfa922d8de40fe3cdbdb5062065d55
-SIZE (gnome2/totem-1.0.4.tar.bz2) = 1394585
+MD5 (gnome2/totem-1.2.0.tar.bz2) = e07aded62a929779a4cd28c16fdb2efd
+SIZE (gnome2/totem-1.2.0.tar.bz2) = 1720687
diff --git a/multimedia/totem/files/patch-src::Makefile.in b/multimedia/totem/files/patch-src::Makefile.in
deleted file mode 100644
index 88baa73c4532..000000000000
--- a/multimedia/totem/files/patch-src::Makefile.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/Makefile.in.orig Thu Jan 13 13:03:04 2005
-+++ src/Makefile.in Thu Jan 13 13:04:42 2005
-@@ -236,7 +236,8 @@
-
- totem_mozilla_viewer_LDADD = $(X_LIBS) $(EXTRA_GNOME_LIBS) $(XTEST_LIBS) $(RANDR_LIBS) $(NVTV_LIBS)
-
--plugindir = $(libdir)/mozilla/plugins/
-+@HAVE_MOZILLA_FALSE@plugindir =
-+@HAVE_MOZILLA_TRUE@plugindir = $(libdir)/mozilla/plugins/
- module_flags = -export_dynamic -avoid-version
-
- vanity_SOURCES = \
diff --git a/multimedia/totem/files/patch-src::bacon-video-widget-xine.c b/multimedia/totem/files/patch-src::bacon-video-widget-xine.c
deleted file mode 100644
index 903e5b2e2b3e..000000000000
--- a/multimedia/totem/files/patch-src::bacon-video-widget-xine.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/bacon-video-widget-xine.c.orig Wed Mar 9 18:03:18 2005
-+++ src/bacon-video-widget-xine.c Wed Mar 9 18:05:59 2005
-@@ -2504,10 +2504,8 @@
-
- /* And we try and create symlinks from /usr/lib/win32 to
- * the local user path */
-- totem_create_symlinks ("/usr/lib/win32", path);
-- totem_create_symlinks ("/usr/lib/RealPlayer9/Codecs/", path);
-- totem_create_symlinks ("/usr/lib/RealPlayer9/users/Real/Codecs/", path);
-- totem_create_symlinks ("/usr/lib/RealPlayer8/Codecs", path);
-+ totem_create_symlinks ("@LOCALBASE@/lib/win32", path);
-+ totem_create_symlinks ("@LOCALBASE@/lib/RealPlayer/codecs", path);
-
- g_free (bvw->priv->codecs_path);
- bvw->priv->codecs_path = g_strdup (path);
diff --git a/multimedia/totem/files/patch-src_totem-disk.c b/multimedia/totem/files/patch-src_totem-disk.c
index 502ffec47a24..d522008f04bc 100644
--- a/multimedia/totem/files/patch-src_totem-disk.c
+++ b/multimedia/totem/files/patch-src_totem-disk.c
@@ -1,5 +1,5 @@
---- src/totem-disc.c.orig Sun Mar 13 08:37:57 2005
-+++ src/totem-disc.c Wed Mar 23 03:29:26 2005
+--- src/plparse/totem-disc.c.orig Sun Mar 13 08:37:57 2005
++++ src/plparse/totem-disc.c Wed Mar 23 03:29:26 2005
@@ -34,18 +34,40 @@
#include <stdio.h>
#include <stdlib.h>
diff --git a/multimedia/totem/pkg-plist b/multimedia/totem/pkg-plist
index 5c942a00c827..2dc09f12e3b2 100644
--- a/multimedia/totem/pkg-plist
+++ b/multimedia/totem/pkg-plist
@@ -5,9 +5,10 @@ include/totem/1/plparser/totem-pl-parser-builtins.h
include/totem/1/plparser/totem-pl-parser.h
lib/libtotem-plparser.a
lib/libtotem-plparser.so
-lib/libtotem-plparser.so.0
+lib/libtotem-plparser.so.1
lib/nautilus/extensions-1.0/libtotem-properties-page.a
lib/nautilus/extensions-1.0/libtotem-properties-page.so
+lib/nautilus/extensions-1.0/libtotem-properties-page.so.0
libdata/pkgconfig/totem-plparser.pc
share/gnome/applications/totem.desktop
share/gnome/help/totem/C/figures/totem_next_button.png
@@ -40,6 +41,16 @@ share/gnome/help/totem/es/figures/totem_volume_maximum_button.png
share/gnome/help/totem/es/figures/totem_volume_mute_button.png
share/gnome/help/totem/es/legal.xml
share/gnome/help/totem/es/totem.xml
+share/gnome/help/totem/fr/figures/totem_next_button.png
+share/gnome/help/totem/fr/figures/totem_pause_button.png
+share/gnome/help/totem/fr/figures/totem_play_button.png
+share/gnome/help/totem/fr/figures/totem_previous_button.png
+share/gnome/help/totem/fr/figures/totem_show_playlist_button.png
+share/gnome/help/totem/fr/figures/totem_start_window.png
+share/gnome/help/totem/fr/figures/totem_volume_maximum_button.png
+share/gnome/help/totem/fr/figures/totem_volume_mute_button.png
+share/gnome/help/totem/fr/legal.xml
+share/gnome/help/totem/fr/totem.xml
share/gnome/help/totem/ru/figures/totem_screenshot.png
share/gnome/help/totem/ru/figures/totem_start_window.png
share/gnome/help/totem/ru/legal.xml
@@ -47,6 +58,7 @@ share/gnome/help/totem/ru/totem.xml
share/gnome/omf/totem/totem-C.omf
share/gnome/omf/totem/totem-de.omf
share/gnome/omf/totem/totem-es.omf
+share/gnome/omf/totem/totem-fr.omf
share/gnome/omf/totem/totem-ru.omf
share/gnome/pixmaps/media-player-48.png
share/gnome/pixmaps/vanity.png
@@ -55,8 +67,6 @@ share/gnome/totem/filmholes-big-right.png
share/gnome/totem/filmholes.png
share/gnome/totem/media-player-48.png
share/gnome/totem/mozilla-viewer.glade
-share/gnome/totem/playlist-16.png
-share/gnome/totem/playlist-24.png
share/gnome/totem/playlist-playing.png
share/gnome/totem/playlist.glade
share/gnome/totem/popup.glade
@@ -92,6 +102,7 @@ share/locale/en_GB/LC_MESSAGES/totem.mo
share/locale/es/LC_MESSAGES/totem.mo
share/locale/et/LC_MESSAGES/totem.mo
share/locale/eu/LC_MESSAGES/totem.mo
+share/locale/fa/LC_MESSAGES/totem.mo
share/locale/fi/LC_MESSAGES/totem.mo
share/locale/fr/LC_MESSAGES/totem.mo
share/locale/ga/LC_MESSAGES/totem.mo
@@ -112,6 +123,7 @@ share/locale/mk/LC_MESSAGES/totem.mo
share/locale/ml/LC_MESSAGES/totem.mo
share/locale/ms/LC_MESSAGES/totem.mo
share/locale/nb/LC_MESSAGES/totem.mo
+share/locale/ne/LC_MESSAGES/totem.mo
share/locale/nl/LC_MESSAGES/totem.mo
share/locale/no/LC_MESSAGES/totem.mo
share/locale/pa/LC_MESSAGES/totem.mo
@@ -126,8 +138,10 @@ share/locale/sq/LC_MESSAGES/totem.mo
share/locale/sr/LC_MESSAGES/totem.mo
share/locale/sr@Latn/LC_MESSAGES/totem.mo
share/locale/sv/LC_MESSAGES/totem.mo
+share/locale/te/LC_MESSAGES/totem.mo
share/locale/th/LC_MESSAGES/totem.mo
share/locale/tr/LC_MESSAGES/totem.mo
+share/locale/ug/LC_MESSAGES/totem.mo
share/locale/uk/LC_MESSAGES/totem.mo
share/locale/vi/LC_MESSAGES/totem.mo
share/locale/wa/LC_MESSAGES/totem.mo
@@ -138,6 +152,8 @@ share/locale/zh_TW/LC_MESSAGES/totem.mo
@dirrm share/gnome/omf/totem
@dirrm share/gnome/help/totem/ru/figures
@dirrm share/gnome/help/totem/ru
+@dirrm share/gnome/help/totem/fr/figures
+@dirrm share/gnome/help/totem/fr
@dirrm share/gnome/help/totem/es/figures
@dirrm share/gnome/help/totem/es
@dirrm share/gnome/help/totem/de/figures