aboutsummaryrefslogtreecommitdiff
path: root/multimedia/totem
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
commit190418a078b1eb7ea3c5d38a08bdab3cbd422086 (patch)
treebb336ccecde7052d26d3d8d8c97238744a373aad /multimedia/totem
parent6b0c40606cac591d75b88d05c7276bd16c369035 (diff)
downloadports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.tar.gz
ports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.zip
Notes
Diffstat (limited to 'multimedia/totem')
-rw-r--r--multimedia/totem/Makefile14
-rw-r--r--multimedia/totem/distinfo4
-rw-r--r--multimedia/totem/files/patch-data_Makefile.in13
-rw-r--r--multimedia/totem/pkg-plist24
4 files changed, 28 insertions, 27 deletions
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index 5a7918826527..b1319f22e63c 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= totem
-PORTVERSION= 0.100
-PORTREVISION= 1
+PORTVERSION= 1.0
CATEGORIES= multimedia gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION}
@@ -16,18 +15,18 @@ DIST_SUBDIR= gnome2
MAINTAINER?= hendrik@scholz.net
COMMENT?= A Xine-based video player for the Gnome 2 Desktop
-LIB_DEPENDS= nautilus-burn.0:${PORTSDIR}/sysutils/nautilus-cd-burner
-
USE_REINPLACE= yes
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix intlhack gnomehack gnomedesktop desktopfileutils
+USE_GNOME= gnomeprefix intlhack gnomehack gnomedesktop desktopfileutils \
+ nautiluscdburner
WANT_GSTREAMER= yes
USE_GMAKE= yes
USE_LIBTOOL_VER=15
INSTALLS_OMF= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lXrandr"
+CONFIGURE_ARGS+=--disable-mozilla
OPTIONS?= DVDNAV "Enable DVD support" on \
GSTREAMER "Use Gstreamer instead of Xine" off
@@ -41,7 +40,7 @@ CONFLICTS= totem-gstreamer-[0-9]*
.if defined(WITH_GSTREAMER)
CONFIGURE_ARGS+=--enable-gstreamer
-USE_GSTREAMER= gnomevfs core
+USE_GSTREAMER+= gnomevfs core
WITHOUT_DVDNAV= yes
PLIST_SUB= GSTREAMER=""
.else
@@ -91,4 +90,7 @@ post-patch:
${WRKSRC}/src/bacon-video-widget-gst.c
.endif
+post-install:
+ @-update-desktop-database
+
.include <bsd.port.post.mk>
diff --git a/multimedia/totem/distinfo b/multimedia/totem/distinfo
index a2e694925bf5..dbe8c55a9a30 100644
--- a/multimedia/totem/distinfo
+++ b/multimedia/totem/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/totem-0.100.tar.bz2) = 885423cc7e1d5eb8ff62b7b8ec9c30bc
-SIZE (gnome2/totem-0.100.tar.bz2) = 1279913
+MD5 (gnome2/totem-1.0.tar.bz2) = eddfebd11ccb58caca72edc6485ed22f
+SIZE (gnome2/totem-1.0.tar.bz2) = 1402642
diff --git a/multimedia/totem/files/patch-data_Makefile.in b/multimedia/totem/files/patch-data_Makefile.in
deleted file mode 100644
index ac127a4ab657..000000000000
--- a/multimedia/totem/files/patch-data_Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- data/Makefile.in.orig Sun Jan 9 21:15:28 2005
-+++ data/Makefile.in Sun Jan 9 21:16:01 2005
-@@ -167,8 +167,8 @@
-
- desktop_in_in_files_all = totem.desktop.in.in.in vanity.desktop.in.in
- desktop_in_files_all = totem.desktop.in.in vanity.desktop.in
--@TOTEM_VANITY_TRUE@desktop_in_files = @TOTEM_VANITY_TRUE@totem.desktop.in.in vanity.desktop.in
--@TOTEM_VANITY_FALSE@desktop_in_files = @TOTEM_VANITY_FALSE@totem.desktop.in.in
-+@TOTEM_VANITY_TRUE@desktop_in_files = @TOTEM_VANITY_TRUE@totem.desktop.in vanity.desktop.in
-+@TOTEM_VANITY_FALSE@desktop_in_files = @TOTEM_VANITY_FALSE@totem.desktop.in
-
- desktopdir = $(datadir)/applications/
- desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
diff --git a/multimedia/totem/pkg-plist b/multimedia/totem/pkg-plist
index e2e6502bdf7e..3d9d848dc419 100644
--- a/multimedia/totem/pkg-plist
+++ b/multimedia/totem/pkg-plist
@@ -1,8 +1,14 @@
bin/totem
bin/totem-video-thumbnailer
-libdata/bonobo/servers/Totem_properties.server
-libexec/totem-properties-page
-share/gnome/application-registry/totem.applications
+include/totem/1/plparser/totem-disc.h
+include/totem/1/plparser/totem-pl-parser-builtins.h
+include/totem/1/plparser/totem-pl-parser.h
+lib/libtotem-plparser.a
+lib/libtotem-plparser.so
+lib/libtotem-plparser.so.0
+lib/nautilus/extensions-1.0/libtotem-properties-page.a
+lib/nautilus/extensions-1.0/libtotem-properties-page.so
+libdata/pkgconfig/totem-plparser.pc
share/gnome/applications/totem.desktop
share/gnome/help/totem/C/figures/totem_next_button.png
share/gnome/help/totem/C/figures/totem_pause_button.png
@@ -34,11 +40,10 @@ share/gnome/help/totem/es/figures/totem_volume_maximum_button.png
share/gnome/help/totem/es/figures/totem_volume_mute_button.png
share/gnome/help/totem/es/legal.xml
share/gnome/help/totem/es/totem.xml
+share/gnome/help/totem/ru/figures/totem_screenshot.png
+share/gnome/help/totem/ru/figures/totem_start_window.png
share/gnome/help/totem/ru/legal.xml
share/gnome/help/totem/ru/totem.xml
-share/gnome/help/totem/ru/figures/totem_start_window.png
-share/gnome/help/totem/ru/figures/totem_screenshot.png
-share/gnome/mime-info/totem.keys
share/gnome/omf/totem/totem-C.omf
share/gnome/omf/totem/totem-de.omf
share/gnome/omf/totem/totem-es.omf
@@ -54,6 +59,7 @@ share/gnome/totem/playlist-16.png
share/gnome/totem/playlist-24.png
share/gnome/totem/playlist-playing.png
share/gnome/totem/playlist.glade
+share/gnome/totem/popup.glade
share/gnome/totem/properties.glade
share/gnome/totem/rhythmbox-volume-max.png
share/gnome/totem/rhythmbox-volume-zero.png
@@ -91,6 +97,7 @@ share/locale/fr/LC_MESSAGES/totem.mo
share/locale/ga/LC_MESSAGES/totem.mo
share/locale/gu/LC_MESSAGES/totem.mo
share/locale/he/LC_MESSAGES/totem.mo
+share/locale/hi/LC_MESSAGES/totem.mo
share/locale/hr/LC_MESSAGES/totem.mo
share/locale/hu/LC_MESSAGES/totem.mo
share/locale/id/LC_MESSAGES/totem.mo
@@ -106,6 +113,7 @@ share/locale/ms/LC_MESSAGES/totem.mo
share/locale/nb/LC_MESSAGES/totem.mo
share/locale/nl/LC_MESSAGES/totem.mo
share/locale/no/LC_MESSAGES/totem.mo
+share/locale/pa/LC_MESSAGES/totem.mo
share/locale/pl/LC_MESSAGES/totem.mo
share/locale/pt/LC_MESSAGES/totem.mo
share/locale/pt_BR/LC_MESSAGES/totem.mo
@@ -116,6 +124,7 @@ share/locale/sq/LC_MESSAGES/totem.mo
share/locale/sr/LC_MESSAGES/totem.mo
share/locale/sr@Latn/LC_MESSAGES/totem.mo
share/locale/sv/LC_MESSAGES/totem.mo
+share/locale/th/LC_MESSAGES/totem.mo
share/locale/tr/LC_MESSAGES/totem.mo
share/locale/uk/LC_MESSAGES/totem.mo
share/locale/vi/LC_MESSAGES/totem.mo
@@ -135,5 +144,8 @@ share/locale/zh_TW/LC_MESSAGES/totem.mo
@dirrm share/gnome/help/totem
%%GSTREAMER%%@unexec rmdir lib/mozilla/plugins 2>/dev/null || /usr/bin/true
%%GSTREAMER%%@unexec rmdir lib/mozilla 2>/dev/null || /usr/bin/true
+@dirrm include/totem/1/plparser
+@dirrm include/totem/1
+@dirrm include/totem
@exec update-desktop-database > /dev/null || /usr/bin/true
@unexec update-desktop-database > /dev/null || /usr/bin/true