aboutsummaryrefslogtreecommitdiff
path: root/multimedia/tunapie/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2008-07-03 13:10:48 +0000
committerNicola Vitale <nivit@FreeBSD.org>2008-07-03 13:10:48 +0000
commit96682c1a49b1a1785db526e52b93670a4f414c2b (patch)
tree3e372a424eda0b1a032feda7421eb1876d530d5b /multimedia/tunapie/Makefile
parent3788a621e1379be9a5ac135b34d7fdbd9e2ee800 (diff)
Notes
Diffstat (limited to 'multimedia/tunapie/Makefile')
-rw-r--r--multimedia/tunapie/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/multimedia/tunapie/Makefile b/multimedia/tunapie/Makefile
index b119638f7dae..89bf9dd1f9cd 100644
--- a/multimedia/tunapie/Makefile
+++ b/multimedia/tunapie/Makefile
@@ -6,9 +6,8 @@
#
PORTNAME= tunapie
-PORTVERSION= 2.1.6
+PORTVERSION= 2.1.8
#PORTREVISION= 0
-PORTREVISION= 1
CATEGORIES= multimedia audio
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION:S,.r,rc,}
@@ -30,7 +29,10 @@ OPTIONS= ADULT "non-censored TV listings" off \
AUDACIOUS "use audacious instead of xmms" off \
BEEP_MEDIA_PLAYER "use beep-media-player instead of xmms" off
+.if !defined(NOMANPAGES)
MAN1= tunapie.1
+.endif
+
PLIST_SUB+= DESKTOPDIR="${DESKTOPDIR:S,^${PREFIX}/,,}"
FIND_FILES= -type f -and \( -name "install.sh" -or -name "*.py" \)
@@ -48,6 +50,9 @@ post-patch:
do-install:
@${MKDIR} ${DESKTOPDIR}
@cd ${WRKSRC} && ./install.sh ${ADULT_TVLIST}
+.if !defined(NOMANPAGES)
+ ${CP} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1/
+.endif
.include <bsd.port.pre.mk>