aboutsummaryrefslogtreecommitdiff
path: root/multimedia/tunapie
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-06-07 06:36:51 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-06-07 06:36:51 +0000
commit2327ce3c61512c46f6840866eb9824e0ee48c8f9 (patch)
tree6ee25b17cc03555d21c5ba4d129cf9c9a91a4434 /multimedia/tunapie
parent9221db7368f3107749b5e1a6fb225cb1feda8078 (diff)
downloadports-2327ce3c61512c46f6840866eb9824e0ee48c8f9.tar.gz
ports-2327ce3c61512c46f6840866eb9824e0ee48c8f9.zip
Notes
Diffstat (limited to 'multimedia/tunapie')
-rw-r--r--multimedia/tunapie/Makefile53
-rw-r--r--multimedia/tunapie/distinfo3
-rw-r--r--multimedia/tunapie/files/patch-install.sh15
-rw-r--r--multimedia/tunapie/files/patch-src-TunerFrame1.py18
-rw-r--r--multimedia/tunapie/files/patch-src-TunerPrefs.py39
-rw-r--r--multimedia/tunapie/pkg-descr7
-rw-r--r--multimedia/tunapie/pkg-plist23
7 files changed, 158 insertions, 0 deletions
diff --git a/multimedia/tunapie/Makefile b/multimedia/tunapie/Makefile
new file mode 100644
index 000000000000..c2ac81ffc202
--- /dev/null
+++ b/multimedia/tunapie/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: tunapie
+# Date created: 2006-04-03
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tunapie
+PORTVERSION= 0.9.9
+CATEGORIES= multimedia audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= nivit@email.it
+COMMENT= Tuner for streaming internet radio and TV
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/mx/__init__.py:${PORTSDIR}/lang/py-mx-base \
+ ${PYTHON_SITELIBDIR}/${WX_PYTHON_DIR}/wxPython/_wx.py:${PORTSDIR}/x11-toolkits/py-wxPython26 \
+ streamripper:${PORTSDIR}/audio/streamripper \
+ mplayer:${PORTSDIR}/multimedia/mplayer \
+ xmms:${PORTSDIR}/multimedia/xmms
+
+NO_BUILD= yes
+USE_PYTHON= yes
+
+OPTIONS= ADULT "non-censored TV listings" off
+
+FIND_FILES= -type f -and \( -name "install.sh" -or -name "*.py" \)
+
+post-patch:
+ cd ${WRKSRC} && ${FIND} . ${FIND_FILES} -exec ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ -e 's|%%DATADIR%%|${DATADIR}|g'\
+ -e 's|%%X11BASE%%|${X11BASE}|g'\
+ -e 's|%%PREFIX%%|${PREFIX}|g' \
+ -e 's|wxversion.select("2.6")|wxversion.select("${WX_PYTHON_DIR:S/^wx-//g}")|g' {} \;
+
+do-install:
+ cd ${WRKSRC} && ./install.sh ${ADULT_TVLIST}
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_ADULT)
+ADULT_TVLIST= --adult
+.endif
+
+.if defined(WITH_UNICODE) && (${OSVERSION} > 500000)
+WX_PYTHON_DIR= wx-2.6-gtk2-unicode
+.else
+WX_PYTHON_DIR= wx-2.6-gtk2-ansi
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/tunapie/distinfo b/multimedia/tunapie/distinfo
new file mode 100644
index 000000000000..add4a5f3705c
--- /dev/null
+++ b/multimedia/tunapie/distinfo
@@ -0,0 +1,3 @@
+MD5 (tunapie_0.9.9.tar.gz) = e67de4978036beea03eb349f8b0d14a9
+SHA256 (tunapie_0.9.9.tar.gz) = f01d2ece51063dbe9695fb57c3431e3074fcdd38b562f9bf3cc7baead5ed5dcc
+SIZE (tunapie_0.9.9.tar.gz) = 37727
diff --git a/multimedia/tunapie/files/patch-install.sh b/multimedia/tunapie/files/patch-install.sh
new file mode 100644
index 000000000000..46ef95257ab1
--- /dev/null
+++ b/multimedia/tunapie/files/patch-install.sh
@@ -0,0 +1,15 @@
+$FreeBSD$
+--- install.sh Sat Apr 1 23:21:08 2006
++++ install.sh.port Mon Apr 3 14:06:04 2006
+@@ -3,7 +3,7 @@
+ else cp src/tunersafe.py src/tuner.py
+ fi
+ python src/compile
+-cp tunapie /usr/local/bin
+-rm -rf /usr/local/share/tunapie
+-mkdir /usr/local/share/tunapie
+-cp src/*.py src/*.pyc src/*.jpg /usr/local/share/tunapie
++cp tunapie %%PREFIX%%/bin
++#rm -rf %%DATADIR%%
++mkdir %%DATADIR%%
++cp src/*.py src/*.pyc src/*.jpg %%DATADIR%%
diff --git a/multimedia/tunapie/files/patch-src-TunerFrame1.py b/multimedia/tunapie/files/patch-src-TunerFrame1.py
new file mode 100644
index 000000000000..bdf647bc01c6
--- /dev/null
+++ b/multimedia/tunapie/files/patch-src-TunerFrame1.py
@@ -0,0 +1,18 @@
+$FreeBSD$
+--- src/TunerFrame1.py Tue May 9 23:17:31 2006
++++ src/TunerFrame1.py.port Wed May 10 11:38:29 2006
+@@ -352,10 +352,10 @@
+ for name in self.favname:
+ self.favorites.Append(name)
+ self.name=[]
+- self.mediaplayer='/usr/bin/xmms'
+- self.videoplayer='/usr/bin/mplayer -nojoystick'
+- self.term='/usr/bin/x-terminal-emulator'
+- self.ripper='/usr/bin/streamripper -t -u winamp2 -o never'
++ self.mediaplayer='%%X11BASE%%/bin/xmms'
++ self.videoplayer='%%LOCALBASE%%/bin/mplayer -nojoystick'
++ self.term='%%X11BASE%%/bin/xterm'
++ self.ripper='%%LOCALBASE%%/bin/streamripper -t -u winamp2 -o never'
+ self.rdir=self.home+'/.tunapie/streamripper'
+ self.shoutice=1 #0 is icecast server 1 is shoutcast
+ self.mediaplayer,self.videoplayer,self.term,self.ripper,self.rdir,self.shoutice=\
diff --git a/multimedia/tunapie/files/patch-src-TunerPrefs.py b/multimedia/tunapie/files/patch-src-TunerPrefs.py
new file mode 100644
index 000000000000..c12421e9ef6d
--- /dev/null
+++ b/multimedia/tunapie/files/patch-src-TunerPrefs.py
@@ -0,0 +1,39 @@
+$FreeBSD$
+--- src/TunerPrefs.py Wed May 24 23:10:23 2006
++++ src/TunerPrefs.py.port Sat May 27 10:59:16 2006
+@@ -74,7 +74,7 @@
+
+ self.audiopath = wx.TextCtrl(id=wxID_PREFERENCESAUDIOPATH,
+ name='audiopath', parent=self, pos=wx.Point(160, 16),
+- size=wx.Size(208, 22), style=0, value='/usr/bin/xmms')
++ size=wx.Size(208, 22), style=0, value='%%X11BASE%%/bin/xmms')
+ self.audiopath.SetFont(wx.Font(7, 77, wx.NORMAL, wx.NORMAL, False,
+ u'Sans'))
+ self.audiopath.SetBackgroundColour(wx.Colour(255, 253, 239))
+@@ -82,7 +82,7 @@
+
+ self.videopath = wx.TextCtrl(id=wxID_PREFERENCESVIDEOPATH,
+ name='videopath', parent=self, pos=wx.Point(160, 48),
+- size=wx.Size(208, 22), style=0, value='/usr/bin/mplayer')
++ size=wx.Size(208, 22), style=0, value='%%LOCALBASE%%/bin/mplayer')
+ self.videopath.SetFont(wx.Font(7, 77, wx.NORMAL, wx.NORMAL, False,
+ u'Sans'))
+ self.videopath.SetBackgroundColour(wx.Colour(255, 253, 239))
+@@ -110,7 +110,7 @@
+ self.termpath = wx.TextCtrl(id=wxID_PREFERENCESTERMPATH,
+ name='termpath', parent=self, pos=wx.Point(160, 80),
+ size=wx.Size(208, 22), style=0,
+- value='/usr/bin/x-terminal-emulator')
++ value='%%X11BASE%%/bin/xterm')
+ self.termpath.SetFont(wx.Font(7, wx.SWISS, wx.NORMAL, wx.NORMAL, False,
+ u'Sans'))
+ self.termpath.SetBackgroundColour(wx.Colour(255, 253, 239))
+@@ -118,7 +118,7 @@
+
+ self.rippath = wx.TextCtrl(id=wxID_PREFERENCESRIPPATH, name='rippath',
+ parent=self, pos=wx.Point(160, 112), size=wx.Size(208, 22),
+- style=0, value='/usr/bin/streamripper')
++ style=0, value='%%LOCALBASE%%/bin/streamripper')
+ self.rippath.SetFont(wx.Font(7, 77, wx.NORMAL, wx.NORMAL, False,
+ u'Sans'))
+ self.rippath.SetBackgroundColour(wx.Colour(255, 253, 239))
diff --git a/multimedia/tunapie/pkg-descr b/multimedia/tunapie/pkg-descr
new file mode 100644
index 000000000000..65d945112ef3
--- /dev/null
+++ b/multimedia/tunapie/pkg-descr
@@ -0,0 +1,7 @@
+Tuner for streaming internet radio and TV (nsv stream), written in Python,
+providing searchable listings of audio and video media broadcasts from
+the shoutcast server (Winamp). Helper programs can be specified to play
+different categories of stream.
+
+Author: James Stone
+WWW: http://sourceforge.net/projects/tunapie
diff --git a/multimedia/tunapie/pkg-plist b/multimedia/tunapie/pkg-plist
new file mode 100644
index 000000000000..f7ca3af2c1b3
--- /dev/null
+++ b/multimedia/tunapie/pkg-plist
@@ -0,0 +1,23 @@
+@comment $FreeBSD$
+bin/tunapie
+%%DATADIR%%/AboutTuner.py
+%%DATADIR%%/AboutTuner.pyc
+%%DATADIR%%/RecordQueue.py
+%%DATADIR%%/RecordQueue.pyc
+%%DATADIR%%/RecordTime.py
+%%DATADIR%%/RecordTime.pyc
+%%DATADIR%%/Splash.py
+%%DATADIR%%/Tunapie.py
+%%DATADIR%%/Tunapie.pyc
+%%DATADIR%%/TunerFrame1.py
+%%DATADIR%%/TunerFrame1.pyc
+%%DATADIR%%/TunerInfoDialog.py
+%%DATADIR%%/TunerInfoDialog.pyc
+%%DATADIR%%/TunerPrefs.py
+%%DATADIR%%/TunerPrefs.pyc
+%%DATADIR%%/tplogo.jpg
+%%DATADIR%%/tuner.py
+%%DATADIR%%/tuner.pyc
+%%DATADIR%%/tuneradult.py
+%%DATADIR%%/tunersafe.py
+@dirrm %%DATADIR%%