aboutsummaryrefslogtreecommitdiff
path: root/multimedia/tunapie
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2007-04-11 14:04:22 +0000
committerNicola Vitale <nivit@FreeBSD.org>2007-04-11 14:04:22 +0000
commitefe4df7339436dea6f5e10c2be0518f307d3468b (patch)
tree5ce657ff8946eabb0a3a3b15029247c909c5b1c6 /multimedia/tunapie
parent6060d4b13d1a012e0ad88221fa469161e3247ada (diff)
downloadports-efe4df7339436dea6f5e10c2be0518f307d3468b.tar.gz
ports-efe4df7339436dea6f5e10c2be0518f307d3468b.zip
Notes
Diffstat (limited to 'multimedia/tunapie')
-rw-r--r--multimedia/tunapie/Makefile5
-rw-r--r--multimedia/tunapie/distinfo6
-rw-r--r--multimedia/tunapie/files/patch-install.sh12
-rw-r--r--multimedia/tunapie/files/patch-src-TunerFrame1.py11
-rw-r--r--multimedia/tunapie/files/patch-src-TunerPrefs.py38
5 files changed, 13 insertions, 59 deletions
diff --git a/multimedia/tunapie/Makefile b/multimedia/tunapie/Makefile
index 30e118f07d46..d9f4ff9b5d3e 100644
--- a/multimedia/tunapie/Makefile
+++ b/multimedia/tunapie/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tunapie
-PORTVERSION= 1.4
+PORTVERSION= 1.4.1
CATEGORIES= multimedia audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -46,7 +46,6 @@ post-patch:
-e 's|%%X11BASE%%|${X11BASE}|g' {} ";"
do-install:
- @${MKDIR} ${DATADIR} ${DATADIR}/pixmaps
@${MKDIR} ${DESKTOPDIR}
@cd ${WRKSRC} && ./install.sh ${ADULT_TVLIST}
@@ -67,7 +66,7 @@ VIDEOPLAYER= ${LOCALBASE}/bin/mplayer
# default AUDIOPLAYER
.if defined(WITH_AUDACIOUS)
-RUN_DEPENDS+= audacious:${PORTSDIR}/multimedia/audacious
+RUN_DEPENDS+= ${PREFIX}/lib/audacious/Container/libpls.so:${PORTSDIR}/multimedia/audacious-plugins
AUDIOPLAYER= ${LOCALBASE}/bin/audacious
.elifdef(WITH_BEEP_MEDIA_PLAYER)
RUN_DEPENDS+= beep-media-player:${PORTSDIR}/multimedia/beep-media-player
diff --git a/multimedia/tunapie/distinfo b/multimedia/tunapie/distinfo
index 4c018977a1f5..6dbf9b799b26 100644
--- a/multimedia/tunapie/distinfo
+++ b/multimedia/tunapie/distinfo
@@ -1,3 +1,3 @@
-MD5 (tunapie-1.4.tar.gz) = 6a9a46fa4f3019929f40b71d958db8eb
-SHA256 (tunapie-1.4.tar.gz) = 75db58bc69e30fe1cffb990f7509aba3c091f67dfdc90561e8af49bdf8710290
-SIZE (tunapie-1.4.tar.gz) = 40549
+MD5 (tunapie-1.4.1.tar.gz) = 99a0b7c77a43782a381de4fb14c17596
+SHA256 (tunapie-1.4.1.tar.gz) = 3eff5dd91ec171a6e2895abae83024a4abfe3c104fb412b801878ab3e559dbb9
+SIZE (tunapie-1.4.1.tar.gz) = 40644
diff --git a/multimedia/tunapie/files/patch-install.sh b/multimedia/tunapie/files/patch-install.sh
index 017548eb1096..a4c47b10f8f8 100644
--- a/multimedia/tunapie/files/patch-install.sh
+++ b/multimedia/tunapie/files/patch-install.sh
@@ -1,10 +1,10 @@
---- install.sh Mon Apr 9 00:35:07 2007
-+++ install.sh.port Mon Apr 9 16:25:12 2007
-@@ -1,12 +1,10 @@
+--- install.sh Tue Apr 10 23:54:02 2007
++++ install.sh.port Wed Apr 11 09:15:43 2007
+@@ -1,14 +1,12 @@
#!/bin/sh
-if [ "$1" = "--adult" ]; then echo '1'>/etc/tunapie.config
-else echo '0'>/etc/tunapie.config
-+if [ "$1" = "--adult" ]; then echo '1'> %%LOCALBASE%%/etc/tunapie.config.default
++if [ "$1" = "--adult" ]; then echo '1'>%%LOCALBASE%%/etc/tunapie.config.default
+else echo '0'>%%LOCALBASE%%/etc/tunapie.config.default
fi
python src/compile
@@ -12,11 +12,15 @@
-rm -rf /usr/local/share/tunapie
-mkdir /usr/local/share/tunapie
-cp src/*.py src/*.pyc /usr/local/share/tunapie
+-mkdir -p /usr/local/share/pixmaps
-cp src/tplogo.xpm /usr/local/share/pixmaps/
+-mkdir -p /usr/local/man/man1
-cp tunapie.1 /usr/local/man/man1
-cp tunapie.desktop /usr/local/share/applications
+cp tunapie %%PREFIX%%/bin
++mkdir %%DATADIR%%
+cp src/*.py src/*.pyc %%DATADIR%%
++mkdir -p %%DATADIR%%/pixmaps
+cp src/tplogo.xpm %%DATADIR%%/pixmaps/
+cp tunapie.1 %%MANPREFIX%%/man/man1
+cp tunapie.desktop %%DESKTOPDIR%%
diff --git a/multimedia/tunapie/files/patch-src-TunerFrame1.py b/multimedia/tunapie/files/patch-src-TunerFrame1.py
deleted file mode 100644
index f7771098a819..000000000000
--- a/multimedia/tunapie/files/patch-src-TunerFrame1.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/TunerFrame1.py Mon Apr 9 00:35:15 2007
-+++ src/TunerFrame1.py.port Mon Apr 9 16:27:24 2007
-@@ -130,7 +130,7 @@
- self.SetBackgroundColour(wx.Colour(246, 246, 246))
- self.SetBackgroundStyle(wx.BG_STYLE_SYSTEM)
- self.SetThemeEnabled(True)
-- self.SetIcon(wx.Icon('pixmaps/tplogo.xpm',wx.BITMAP_TYPE_XPM))
-+ self.SetIcon(wx.Icon('%%DATADIR%%/pixmaps/tplogo.xpm',wx.BITMAP_TYPE_XPM))
- self.SetFont(wx.Font(10, wx.SWISS, wx.NORMAL, wx.NORMAL, False,u'Sans'))
- self.SetAutoLayout(True)
- self.SetMinSize(wx.Size(770, 410))
diff --git a/multimedia/tunapie/files/patch-src-TunerPrefs.py b/multimedia/tunapie/files/patch-src-TunerPrefs.py
deleted file mode 100644
index e5f1aa709c04..000000000000
--- a/multimedia/tunapie/files/patch-src-TunerPrefs.py
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/TunerPrefs.py Mon Apr 9 00:35:15 2007
-+++ src/TunerPrefs.py.port Mon Apr 9 16:31:46 2007
-@@ -96,7 +96,7 @@
-
- self.audiopath = wx.TextCtrl(id=wxID_PREFERENCESAUDIOPATH,
- name='audiopath', parent=self, pos=wx.Point(144, 16),
-- size=wx.Size(200, 22), style=0, value='/usr/bin/xmms')
-+ size=wx.Size(200, 22), style=0, value='%%AUDIOPLAYER%%')
- self.audiopath.SetFont(wx.Font(7, 77, wx.NORMAL, wx.NORMAL, False,
- u'Sans'))
- self.audiopath.SetBackgroundColour(wx.Colour(255, 253, 239))
-@@ -105,7 +105,7 @@
-
- self.videopath = wx.TextCtrl(id=wxID_PREFERENCESVIDEOPATH,
- name='videopath', parent=self, pos=wx.Point(144, 48),
-- size=wx.Size(200, 22), style=0, value='/usr/bin/mplayer')
-+ size=wx.Size(200, 22), style=0, value='%%VIDEOPLAYER%%')
- self.videopath.SetFont(wx.Font(7, 77, wx.NORMAL, wx.NORMAL, False,
- u'Sans'))
- self.videopath.SetBackgroundColour(wx.Colour(255, 253, 239))
-@@ -133,7 +133,7 @@
- self.termpath = wx.TextCtrl(id=wxID_PREFERENCESTERMPATH,
- name='termpath', parent=self, pos=wx.Point(144, 80),
- size=wx.Size(200, 22), style=0,
-- value='/usr/bin/x-terminal-emulator')
-+ value='%%X11BASE%%/bin/xterm')
- self.termpath.SetFont(wx.Font(7, wx.SWISS, wx.NORMAL, wx.NORMAL, False,
- u'Sans'))
- self.termpath.SetBackgroundColour(wx.Colour(255, 253, 239))
-@@ -142,7 +142,7 @@
-
- self.rippath = wx.TextCtrl(id=wxID_PREFERENCESRIPPATH, name='rippath',
- parent=self, pos=wx.Point(144, 112), size=wx.Size(200, 22),
-- style=0, value='/usr/bin/streamripper')
-+ style=0, value='%%LOCALBASE%%/bin/streamripper')
- self.rippath.SetFont(wx.Font(7, 77, wx.NORMAL, wx.NORMAL, False,
- u'Sans'))
- self.rippath.SetBackgroundColour(wx.Colour(255, 253, 239))