aboutsummaryrefslogtreecommitdiff
path: root/multimedia/tvheadend
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2018-01-06 19:32:43 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2018-01-06 19:32:43 +0000
commitae8fef38f4c5ebd563bf9abbc51daad0d25e36a3 (patch)
treeb282be73950ced5245c2daeede8eba9ef93d60d4 /multimedia/tvheadend
parentc2e67fd35c9e7911df3e3bc742610933b61835ef (diff)
Update to 4.2.5
PR: 224855 Submitted by: Talal Al Dik <tad@vif.com>
Notes
Notes: svn path=/head/; revision=458287
Diffstat (limited to 'multimedia/tvheadend')
-rw-r--r--multimedia/tvheadend/Makefile3
-rw-r--r--multimedia/tvheadend/distinfo6
-rw-r--r--multimedia/tvheadend/files/patch-src_byteswap.h45
-rw-r--r--multimedia/tvheadend/files/patch-src_tcp.c64
-rw-r--r--multimedia/tvheadend/files/patch-src_tcp.h11
5 files changed, 4 insertions, 125 deletions
diff --git a/multimedia/tvheadend/Makefile b/multimedia/tvheadend/Makefile
index b3c2c6f0ae47..eb668f9198c0 100644
--- a/multimedia/tvheadend/Makefile
+++ b/multimedia/tvheadend/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= tvheadend
-PORTVERSION= 4.2.3
+PORTVERSION= 4.2.5
DISTVERSIONPREFIX= v
-PORTREVISION= 1
CATEGORIES= multimedia
MAINTAINER= decke@FreeBSD.org
diff --git a/multimedia/tvheadend/distinfo b/multimedia/tvheadend/distinfo
index e89ae6a24ab3..28cbb5784e9c 100644
--- a/multimedia/tvheadend/distinfo
+++ b/multimedia/tvheadend/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1501062908
-SHA256 (tvheadend-tvheadend-v4.2.3_GH0.tar.gz) = 2d289a1a8a0a960feba1da2da97c977a2b714d87adfdfaf00a53142e39d808e6
-SIZE (tvheadend-tvheadend-v4.2.3_GH0.tar.gz) = 21518785
+TIMESTAMP = 1515264849
+SHA256 (tvheadend-tvheadend-v4.2.5_GH0.tar.gz) = 36816c8b506af6b0f5df442bd96aa301223dc7c44d8b88eec53262e92956d740
+SIZE (tvheadend-tvheadend-v4.2.5_GH0.tar.gz) = 21528718
diff --git a/multimedia/tvheadend/files/patch-src_byteswap.h b/multimedia/tvheadend/files/patch-src_byteswap.h
deleted file mode 100644
index 3bc7634b5253..000000000000
--- a/multimedia/tvheadend/files/patch-src_byteswap.h
+++ /dev/null
@@ -1,45 +0,0 @@
---- src/byteswap.h.orig 2015-10-21 17:12:45 UTC
-+++ src/byteswap.h
-@@ -0,0 +1,42 @@
-+/*-
-+ * Copyright (c) 2010 Isilon Systems, Inc.
-+ * Copyright (c) 2010 iX Systems, Inc.
-+ * Copyright (c) 2010 Panasas, Inc.
-+ * All rights reserved.
-+ *
-+ * Redistribution and use in source and binary forms, with or without
-+ * modification, are permitted provided that the following conditions
-+ * are met:
-+ * 1. Redistributions of source code must retain the above copyright
-+ * notice unmodified, this list of conditions, and the following
-+ * disclaimer.
-+ * 2. Redistributions in binary form must reproduce the above copyright
-+ * notice, this list of conditions and the following disclaimer in the
-+ * documentation and/or other materials provided with the distribution.
-+ *
-+ * THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
-+ * IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
-+ * OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
-+ * IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
-+ * INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
-+ * NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-+ * DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-+ * THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-+ * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
-+ * THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-+ */
-+
-+#ifndef _INFINIBAND_BYTESWAP_H_
-+#define _INFINIBAND_BYTESWAP_H_
-+/*
-+ * This file is included for compatibility with the userland libraries
-+ * accompanying the infiniband stack.
-+ */
-+#include <sys/types.h>
-+#include <sys/endian.h>
-+
-+#define bswap_16 bswap16
-+#define bswap_32 bswap32
-+#define bswap_64 bswap64
-+
-+#endif /* _INFINIBAND_BYTESWAP_H_ */
diff --git a/multimedia/tvheadend/files/patch-src_tcp.c b/multimedia/tvheadend/files/patch-src_tcp.c
deleted file mode 100644
index ff2c9f9c4ea1..000000000000
--- a/multimedia/tvheadend/files/patch-src_tcp.c
+++ /dev/null
@@ -1,64 +0,0 @@
-- DSCP cannot be modified on FreeBSD yet
-src/tcp.c:61:14: error: use of undeclared identifier 'IPTOS_DSCP_MASK'
- v = dscp & IPTOS_DSCP_MASK;
-
-- Change include order for FreeBSD
-In file included from src/tcp.c:33:
-/usr/include/netinet/ip.h:69:17: error: field has incomplete type 'struct in_addr'
- struct in_addr ip_src,ip_dst; /* source and dest address */
- ^
-/usr/include/netinet/ip.h:69:9: note: forward declaration of 'struct in_addr'
- struct in_addr ip_src,ip_dst; /* source and dest address */
- ^
-/usr/include/netinet/ip.h:69:24: error: field has incomplete type 'struct in_addr'
- struct in_addr ip_src,ip_dst; /* source and dest address */
- ^
-/usr/include/netinet/ip.h:69:9: note: forward declaration of 'struct in_addr'
- struct in_addr ip_src,ip_dst; /* source and dest address */
- ^
-/usr/include/netinet/ip.h:181:19: error: field has incomplete type 'struct in_addr'
- struct in_addr ipt_addr;
- ^
-/usr/include/netinet/ip.h:69:9: note: forward declaration of 'struct in_addr'
- struct in_addr ip_src,ip_dst; /* source and dest address */
- ^
-/usr/include/netinet/ip.h:216:17: error: field has incomplete type 'struct in_addr'
- struct in_addr ippseudo_src; /* source internet address */
- ^
-/usr/include/netinet/ip.h:69:9: note: forward declaration of 'struct in_addr'
- struct in_addr ip_src,ip_dst; /* source and dest address */
- ^
-/usr/include/netinet/ip.h:217:17: error: field has incomplete type 'struct in_addr'
- struct in_addr ippseudo_dst; /* destination internet address */
- ^
-/usr/include/netinet/ip.h:69:9: note: forward declaration of 'struct in_addr'
- struct in_addr ip_src,ip_dst; /* source and dest address */
- ^
---- src/tcp.c.orig 2017-01-20 19:41:51.000000000 +0100
-+++ src/tcp.c 2017-02-08 11:15:26.836727000 +0100
-@@ -30,8 +30,8 @@
- #include <fcntl.h>
- #include <errno.h>
- #include <signal.h>
--#include <netinet/ip.h>
- #include <netinet/in.h>
-+#include <netinet/ip.h>
- #include <netinet/tcp.h>
- #include <arpa/inet.h>
-
-@@ -56,6 +56,7 @@
- int
- socket_set_dscp(int sockfd, uint32_t dscp, char *errbuf, size_t errbufsize)
- {
-+#ifdef IPTOS_DSCP_MASK
- int r, v;
-
- v = dscp & IPTOS_DSCP_MASK;
-@@ -65,6 +66,7 @@
- snprintf(errbuf, errbufsize, "IP_TOS failed: %s", strerror(errno));
- return -1;
- }
-+#endif
- return 0;
- }
-
diff --git a/multimedia/tvheadend/files/patch-src_tcp.h b/multimedia/tvheadend/files/patch-src_tcp.h
deleted file mode 100644
index 8a60d225b66e..000000000000
--- a/multimedia/tvheadend/files/patch-src_tcp.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/tcp.h.orig 2015-09-25 13:57:59 UTC
-+++ src/tcp.h
-@@ -19,6 +19,8 @@
- #ifndef TCP_H_
- #define TCP_H_
-
-+#include <sys/socket.h>
-+
- #include "htsbuf.h"
- #include "htsmsg.h"
-